LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-09-2006, 03:24 PM   #1
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Rep: Reputation: 16
Wireless support in 11.0


Hi, I was wondering if someone could help me out. Im currently running slackware 11.0 and its not reading my wireless card. I have two wirless devices atm. A on board broadcom wireless card and a pcmcia Netgear WG511T. I have downloaded and installed Madwifi for the Atheros based WG511T, and ndiswrapper for the broadcom card. I have no idea why iwconfig gives no wireless extensions.. please help.

lspci

Code:
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
02:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

lsmod | grep ath_pci

Code:
ath_pci                69264   0  (unused)
ath_rate_sample         9160   0  [ath_pci]
wlan                  143932   0  [ath_pci ath_rate_sample]
ath_hal               174672   0  [ath_pci ath_rate_sample]
dmesg | grep wifi

wifi%d: request_irq failed

dmesg | grep ndiswrapper

Code:
ndiswrapper version 1.31 loaded (preempt=no,smp=no)
usb.c: registered new driver ndiswrapper
lsmod | grep ndiswrapper

Code:
ndiswrapper           147864   0
usbcore                56812   1  [ndiswrapper usb-ohci ehci-hcd]
iwconfig
Code:
lo        no wireless extensions.

eth0      no wireless extensions.
ifconfig -a
Code:
eth0      Link encap:Ethernet  HWaddr *
          inet addr:*  Bcast:*  Mask:*
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12789 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9476 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16810378 (16.0 MiB)  TX bytes:1240487 (1.1 MiB)
          Interrupt:5 Base address:0xb000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:104 errors:0 dropped:0 overruns:0 frame:0
          TX packets:104 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8656 (8.4 KiB)  TX bytes:8656 (8.4 KiB)

Thank you so much in advance to anyone who could let me know what to do.
 
Old 12-09-2006, 04:10 PM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 725
Blog Entries: 3

Rep: Reputation: 77
It looks like you're have a IRQ conflict:

Quote:
dmesg | grep wifi

wifi%d: request_irq failed
Maybe try to have one card work at a time. For example, don't load ndiswrapper and work only with your netgear card.

Did you do the wireless setting in /etc/rc.d/rc.wireless.conf as explained in the slack book: http://slackbook.org/html/network-co...-wireless.html

You may then see "something" with command iwconfig
 
Old 12-09-2006, 04:44 PM   #3
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
Ok, I rmmod ndiswrapper and commented it out in rc.modules. I read the slack book guide which doest provide much information on troubleshooting if the card is not automatically brought up, it simply tells me how to fill in the appropriate settings to connect to my network but thats not my trouble. I agree it is probably something to do with the irq, but im not sure how to solve something like that.

Oh btw I also tried to pass pci=assign-busses at boot, with no luck.
 
Old 12-09-2006, 05:16 PM   #4
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 725
Blog Entries: 3

Rep: Reputation: 77
Regarding the madwifi driver, did you install it by compiling it yourself or did you use a slackware package ? One such package can be found here:

http://www.slackware.com/~alien/slackbuilds/madwifi/

On that page, you'll also find reference to a wiki for madwifi on Slackware:

http://madwifi.org/wiki/UserDocs/Distro/Slackware
 
Old 12-09-2006, 06:03 PM   #5
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
Ok, I uninstalled the drivers (which I downloaded from madwifi's website) and installed the slackware package from http://www.slackware.com/~alien/slackbuilds/madwifi/
It didnt help much but im not getting the irq error any more.

As for the wiki on madwifi the only new information that might have helped, didnt solve the problem. specifically I modified a few lines in /etc/rc.d/rc.inet1.conf
Code:
# Config information for ath0 (using dhcp):
IFNAME[1]="ath0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="mywirelessbox"
Then added to to my card's section in rc.wireless.conf
Code:
WPA="wpa_supplicant"
WPADRIVER="madwifi"
btw thanks so much for your help
 
Old 12-09-2006, 06:05 PM   #6
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
I should also point out that it works flawless with my backtrack linux live cd.
 
Old 12-10-2006, 03:16 AM   #7
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 725
Blog Entries: 3

Rep: Reputation: 77
I'm afraid I can not help you further as I don't use either madwifi or WPA encryption.

But one last check, if you want to use WPA encryption, I assume that you have installed the wpa_supplicant package that you can find here:

http://www.slackware.com/~alien/slac...pa_supplicant/

Good luck.
 
Old 12-21-2006, 05:19 AM   #8
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
There is an entry in the HCL of this forum for the WG511T. Maybe have a look at it. Also, if you're struggling to set the card up, I would suggest doing it first without WPA or WEP. Once you get it working you can focus on those.
 
Old 12-21-2006, 09:56 AM   #9
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Can you authenticate using a straight command line calling wpa_supplicant?

If not, troubleshoot that first.

I'll share my configuration, hoping it will help. I'm no stranger to wireless, have been using EAP-TLS with a RADIUS server for several years, but I was unable to automate my Atheros card/WPA config using the rc.wireless.conf file despite help from some pretty sharp folks here. I had to do it via inet1.conf. Even then, wpa_supplicant has to try twice to authenticate. It only delays things by a second, so I ignore it.

rc.inet1.conf
Code:
# Default gateway IP address:
GATEWAY="192.168.1.1"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="ath0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]=""
GATEWAY="192.168.1.1"
WLAN_ESSID[4]=my_ssid
WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="madwifi"
/etc/wpa_supplicant.conf:
Code:
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="my_ssid"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="my_psk"
}
 
Old 01-03-2007, 06:32 PM   #10
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
Please someone help me, this is driving me mad! I've been reading so much but nothing is working. My card STILL isnt even being recognized. I dont care about connecting, wpa, wpe or any of that all I want is it to recognize my card. Now my lspci isnt even listing the atheros card...

This is what its telling me, im not even sure if this is it but there is no atheros listed at all.
Code:
05:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:00.0 Class ffff: Illegal Vendor ID Unknown device ffff (rev ff)

if it means anything, I also have a broadcom wireless card thats on board. I dont know if the two are somehow conflicting. The wireless works perfect on linux live cds so I know it cant be my card / compatability.

please help =(
 
Old 01-03-2007, 08:28 PM   #11
piete
Member
 
Registered: Apr 2005
Location: Havant, Hampshire, UK
Distribution: Slamd64, Slackware, PS2Linux
Posts: 465

Rep: Reputation: 44
As suggested before, for debug purposes I would pick a card and disable any of the others at bios level. Once you know you're only working with one card, you can proceed ...

Step one in dealing with anything PCMCIA is to establish that the bus is working properly.

Get a hold of the cardctl program and abuse dmesg. I would be suprised if you didn't already have it installed, but hey.

From booting up without the card you should be able to put it in and have dmesg recognise that a card has been inserted. You can then use something akin to:

cardctl info
cardctl stop 0
cardctl eject 0

To check that there are no problems with pcmcia itself.

If you have built your own kernel, then you will need to rebuild the madwifi driver to match the new kernel ... otherwise check you've installed the package that matches the kernel you're using.

I confess, i cheat and grab Eric's build scripts & source files from http://www.slackware.com/~alien/slac...madwifi/build/ then just run the .slackBuild (as root - i trust him ).

Once you've got this ... go back and check dmesg and cardctl.

At this point, everything should be registering and *stuff* should be happening in dmesg. This is the time to start playing with settings. In getting my card to work, i ended up hacking the wireless startup script due to some oddity with a loop. Come back if you still have problems and i will actually go to the effort of diffing my files with slack 11s for you ... mine are built on 10.1 i think, but I wouldn't swear to that!

Let us know how it goes,
- Piete.
 
Old 01-04-2007, 01:56 AM   #12
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
Piete, you are awesome, thank you for helping me figure this out. Im using the kernel that comes with 11.0 (2.4.33.3). This is a fresh install so there are no madwifi drivers installed yet or anything for that matter. I wanted to start compleatly fresh so I can possibly help someone else out with the same problem. The last time I had it installed I picked up the correct drivers that corresponded with this kernel. I think it's a really weird problem...

First, I disabled the on board wireless card in bios. After booting lspci still gave me this:
Code:
05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
The PCMCIA service starts at start up. Although "dmesg | grep pcmcia" returns with nothing. (not sure if that's normal)

lspci is not listing the previous unknown vendor card. After inserting the card lspci gives me:
Code:
06:00.0 Class ffff: Illegal Vendor ID Unknown device ffff (rev ff)
(Im thinking this is a big clue )

cardctl info remains the same as when the card is inserted
Code:
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255
If you need any info at all to help just let me know. Ill post it asap. I'm gonna get this to work if it kills me. The reason why this is extremely frustrating is because my the Linux live cd works perfect!

Last edited by Th3_J3st3R; 01-04-2007 at 01:57 AM.
 
Old 01-04-2007, 08:01 AM   #13
piete
Member
 
Registered: Apr 2005
Location: Havant, Hampshire, UK
Distribution: Slamd64, Slackware, PS2Linux
Posts: 465

Rep: Reputation: 44
In your first post, the card was showing up in lspci - what's changed?

We can disregard the bios-disabled broadcom for now, I think.

If the only thing that's different is that you previously had the madwifi drivers installed and now you don't, then we should install Eric's package and revisit both dmesg & cardctl.

With regards to pcmcia at startup in dmesg: i get nothing either =)

You should see something like the following at startup.

Code:
Starting PCMCIA services:
<Probing for PCIC: edit /etc/rc.d/rc.pcmcia>
cardmgr[79]: watching 2 sockets
What sort of install have you done? Since my next question is to do a full-install to make sure no vital packages are missing.

I shall ponder more!
- Piete.
 
Old 01-05-2007, 05:19 PM   #14
Th3_J3st3R
Member
 
Registered: Mar 2003
Location: Milwaukee
Distribution: Slackware 12.0
Posts: 84

Original Poster
Rep: Reputation: 16
Alright I downloaded Erics package and ran the .SlackBuild. Im not sure if all it was supposed to do was create a custom madwifi package which Im supposed to run the make - make install from (which is what I did) or is it supposed to install completely?

Regardless, madwifi is installed and the ath_pci modules were loaded with warnings (not sure how to view the warnings). Then cardctl gives me the same message. lspci keeps spewing out
Code:
06:00.0 Class ffff: Illegal Vendor ID Unknown device ffff (rev ff)
If I remove the card it docent list that anymore.

The kernel is a (something)pci.i I believe. It will give me the same errors and such with bare.i though, and it was a full install. The startup is the same except it is only watching one slot. In regards to my first post, I since did a reinstall (trying to solve it) and now it wont even list my card. This problem is so weird, could it be this crappy compaq hardware? Im wondering if there is some way of determining a possible irq conflict? Or hacking the kernel? How can I be the only one with this problem .. figures.

Im not at my computer right now but after some more digging I found a thread claiming
Quote:
"After a while it turned out that most of my problems where caused by incorrect BIOS settings (duh). It seems that if I excluded all interrupts except for IRQ 11 from the PCI settings then everything worked fine even with the kernel supplied yenta_socket pcmcia driver. BTW I am using the original redhat supplied kernel 2.4.18-14."
-From: http://www.kielczewski.org/fmv.html

maybe an answer?

-jester

Last edited by Th3_J3st3R; 01-05-2007 at 05:32 PM.
 
Old 01-05-2007, 06:02 PM   #15
piete
Member
 
Registered: Apr 2005
Location: Havant, Hampshire, UK
Distribution: Slamd64, Slackware, PS2Linux
Posts: 465

Rep: Reputation: 44
Definitly worth giving that suggestion a go, it can't hurt to try it.

Eric's script should have made you a package in /tmp which you can then go ahead and use (installpkg).

The kernel is probably bareacpi, then. Try the bios hack first then try a reinstall with the huge26.s kernel, see if that helps. You'll need to install the modules for huge26 by hand from /extra/linux-2.6.17/kernel-modules-2.6.17....tgz - another installpkg job!

Setting up linux on a laptop is never easy ... if you want an easy ride, I understand Ubuntu is good on laptops. Otherwise, we shall crack on!

Bios irq first, kernel next.

You can do it =)
- Piete.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless support need sunlinux Linux - Hardware 3 06-24-2006 06:58 AM
WPA (Wireless) Support? carlosinfl Ubuntu 1 12-23-2005 07:26 PM
Ubuntu wireless support - psmouse support Zaulden Ubuntu 2 08-03-2005 02:21 PM
Good Wireless support gonus Linux - Hardware 5 01-01-2005 05:31 PM


All times are GMT -5. The time now is 09:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration