LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-06-2007, 08:55 PM   #1
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Wireless Rate Setting set to 11Mb


After much mucking around I have managed to get my Broadcomm wireless card working with WPA using wpa_supplicant - marvellous!!
However, iwconfig is reporting a rate of 11Mb unless I specifically set the rate to 54M from the cli with:
Code:
iwconfig eth1 rate 54M
when iwconfig then reports a bit rate of 54Mb/sec. I have this is my rc.wireless.conf
Code:
# Generic example (decribe all possible settings)
*)
    INFO="Eds Broadcomm Wireless"
    # ESSID (extended network name) : My Network, any
    ESSID="BTVOYAGER2091-59"
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="2"
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M
    RATE="54M"
    # Encryption key : 4567-89AB-CD, s:password
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;
esac
and this in my rc.inet1.conf
Code:
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
WLAN_ESSID[1]=BTVOYAGER2091-59
WLAN_MODE[1]=Managed
WLAN_RATE[1]="54M auto"
WLAN_CHANNEL[1]="2"
WLAN_KEY[1]="here_is_my_secret_key"
#WLAN_IWPRIV[1]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=here_is_my_secret_key TxRate=0"
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
I would have thought the rate settings of 54 would be passed to iwconfig but they don't seem to be. Am I missing something ? BTW my hardware supports a 54Mb connection and entering the iwconfig command at the CLI seems to work as iwconfig then reports the new rate. Any ideas ?

Cheers
 
Old 03-06-2007, 09:45 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
"54M auto"

I really don't know too much about this ... but did you try just:

"54M"

?
 
Old 03-07-2007, 08:12 AM   #3
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Yep - tried that and other combinations of commenting out RATE or WLAN_RATE[1] but nothing seems to make a difference.
 
Old 03-07-2007, 01:06 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
The bcm43xx driver can only handle 11M regardless of what the card is capable of. If you need 54M throughput, you'll have to move to ndiswrapper and a Windows driver.
 
Old 03-07-2007, 07:42 PM   #5
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Thanks - after much more messing about I now have ndiswrapper setup to load the bcmwl5.inf windows files and get a 54Mb connection. It looks like I have to stop the bcm43xx driver from loading to get this to work - is blacklisting the way to go with this ?

Thanks again....
 
Old 03-08-2007, 07:08 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Yeah, you'll have to blacklist bcm43xx. As you've seen, having both bcm43xx and ndiswrapper loaded at the same time causes trouble.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error for wireless request "Set Bit Rate" (8B20) king_scott_2 Linux - Wireless Networking 3 06-26-2006 05:27 PM
vivanco 11mb usb wlan : does it works ? riccisit Linux - Hardware 2 10-01-2005 04:12 AM
Can't set maximum refresh rate dahonk Linux - Hardware 2 07-13-2004 01:12 AM
cant set monitor refresh rate (RH 9) vendejp Linux - Hardware 6 03-31-2004 11:08 PM
how do I set the refresh rate settings? tdnik Linux - General 3 01-03-2002 11:10 AM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration