LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-16-2007, 05:39 PM   #1
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,185

Rep: Reputation: 47
Wireless problem


Last summer I set up my Slackware tower with a wireless pci card and got it working...it shows up as eth1. I also have an ethernet card that shows up on eth0. I only needed the wireless capability during the hot summer months. Since then I went back to my wired eth0 connection. Now I want to use the wireless again but am having problems getting a connection on eth1. I unplugged my wired eth0 connection, but that still gets an IP address. Should ifconfig show an ipaddress anymore on eth0?

I re-ran netconfig and then rebooted but eth1 is not getting the address. How can I turn off eth0?
 
Old 06-16-2007, 06:16 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
Quote:
I unplugged my wired eth0 connection, but that still gets an IP address.
Unless you're using a fixed IP address, that statement is insane of course. Are your eth0 and eth1 assignments swapped sor some reason?

Eric
 
Old 06-16-2007, 06:28 PM   #3
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,185

Original Poster
Rep: Reputation: 47
I'm not sure what you mean. I have a static IP set up for my Slack pc...it's part of a network of 3 pcs and I give it the static address of 192.168.1.45 and my router is setup to always set up that IP address for my Slack pc. I may have disabled my eth0 card last year in Slack 10.1 in /etc/modules which is now /etc/rc.d/rc.modules-2.6.13 (I'm using kernel 2.6.x now and last year I was in 2.4.x). The wired card is a Netgear and uses natsemi and the wireless card is a Belkin which I bought a Linuxant Driverloader license (the bm43xx driver that can be built into the kernel makes my pc not boot).

Maybe I have to add natsemi (my wired eth0 module) to /etc/modprobe.d/blacklist?

Last edited by linuxhippy; 06-16-2007 at 06:33 PM.
 
Old 06-16-2007, 06:40 PM   #4
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu
Posts: 1,185

Original Poster
Rep: Reputation: 47
That was it!! I added this to /etc/modprobe.d/blacklist:

blacklist natsemi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless problem! help ....... PriaM Linux - Hardware 2 06-17-2007 10:29 AM
wireless internet problem and DVD drive problem Legion Linux - Hardware 2 08-28-2006 09:09 PM
wireless problem yumener Linux - Hardware 3 05-06-2006 03:02 PM
wireless problem thagu Linux - Wireless Networking 1 01-22-2006 03:58 AM
Problem with wireless nostromo Slackware 5 09-26-2005 04:35 AM


All times are GMT -5. The time now is 03:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration