LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-03-2008, 12:57 PM   #61
delta function
Member
 
Registered: Jul 2004
Posts: 51

Rep: Reputation: 20

In my case, I am not using rc.inet1. I disabled it, because i usually use only wifi networking ( wlan0 ). So i do not have to fill in the rest for rc.wireless etc ....

This is how i did it:

I start the wpa_supplicant form rc.local :

wpa_supplicant -B -D wext -c /etc/wpa_supplicant.conf

then i start the dhcp

dhcpcd wlan0

I have entered all the networks to wpa_supplicant.conf

Works like a charm.

One tip:
For security reason, I am not using the plain password with the psk= entry.

I use wpa_passphrase to generate the needed code.

Console:
wpa_passphrase {ssid} {password}

it will respond with a line like this :
network={
ssid="ssid"
#psk="password" <---- remove this,so it cannot be seen
psk=44116ea881531996d8a23af58b376d70f196057429c258f529577a26e727ec1b <- the coded password
}
 
Old 09-05-2008, 07:49 AM   #62
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Solved

delta: thanks. If you read my previous posts you'll see I'm doing basically the same thing. By putting that in rc.local it worked fine. But I found it odd that the scripts did not work particularly when going through them a little bit and everything seemed fine (to my limited understanding of bash scripting).

ligar: your advice worked but I need to put the timeout statement right under the dhcp line. When I had it at the bottom of .conf it didn't work.
The psk needs to be in quotes if it is your key. It cannot be in quotes if it is the hexadecimal conversion that delta talks about.

Solution for using scripts with wpa_supplicant (for me)
1. Delete rc.wireless.conf
2. Ensure rc.inet1 and rc.wireless are executable
3. Adjust rc.inet1.conf for your setup. For 1 eth and 1 wireless, the following works for me:

Working rc.inet1.conf is:
Code:
# Config information for eth0:
USE_DHCP[0]="yes"

# Change this to "yes" for debugging output to stdout.
DEBUG_ETH_UP="yes"

IFNAME[1]="wlan0"
USE_DHCP[1]="yes"
DHCP_TIMEOUT[1]=2
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
4. Adjust wpa_supplicant.conf (located at /etc)
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
  scan_ssid=0
  ssid="bbnet"
  proto=WPA2
  key_mgmt=WPA-PSK
  pairwise=TKIP
  group=TKIP
  psk="your pass key"
#  or comment single line above and uncomment next line
#psk=hex of your pass key produced by wpa_passphrase {ssid} {password}
}
I still get a single occurrence of:
Code:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
But it works. This might go away when I turn debug off in rc.inet1.conf.

Edit: Just pulled eth0 plug and tried again. Works well.
Turning debug off in rc.inet1.conf did not eliminate the one occurrence of the line with wpa_ctrl. Changing timeout did not alter it either. No big deal.

Thank you for everyone's help.

Last edited by forum1793; 09-05-2008 at 08:03 AM.
 
Old 09-05-2008, 08:12 AM   #63
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 930

Rep: Reputation: 96
Quote:
Originally Posted by forum1793 View Post
ligar: your advice worked but I need to put the timeout statement right under the dhcp line. When I had it at the bottom of .conf it didn't work.
That's very strange. The variables are read from the conf file but the order shouldn't matter. Maybe there was a hidden character or something causing the relevant line to get skipped. In any case, I'm glad that you have a solution now .
 
Old 09-06-2008, 10:12 AM   #64
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Based on your reply I tried again with the timeout at bottom.
This time it worked. Weird. Maybe I had typo or as you said maybe some strange hidden character.
 
Old 09-07-2008, 01:23 PM   #65
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
So I took wireless card and put in my friends system.

Everything is basically the same except for she has 690g and I have 780g mboards. I also copied the rc.inet1 and rc.wireless scripts as well as wpa_supplicant.conf and rc.inet1.conf. Installed card, made appropriate changes to confs, and... it wouldn't work.

Couldn't even get wpa_supplicant -d ... to work.

We have exact same routers. But one difference we changed hers to run b/g mode instead of g only. And, we were using router with something else that only worked in B mode. Is there a setting I need to change for this? Do I need to tell it to use "ad-hoc". I never specified "managed" previously and it worked. Maybe that is default. The info at /usr/doc/wpa... not real clear on the mode. It states for ssid not being broadcast must use ap_scan=2 but our router was broadcasting.

wpa_supplicant -Bw ... functioned but did not associate.
dhcpcd wlan0 then just hung.

ifconfig wlan0 up, brought it up such that networks could be scanned and multiple routers were seen. This indicates the hardware and drivers are installed and functioning.


Running out of time, we switched to XP and it worked.

Thoughts?
 
Old 09-07-2008, 01:37 PM   #66
perry
Member
 
Registered: Sep 2003
Location: USA & Canada
Distribution: Slackware 12.0
Posts: 978

Rep: Reputation: 30
Have you given NDISWRAPPER a try ?

Quote:
Originally Posted by forum1793 View Post

Running out of time, we switched to XP and it worked.

Thoughts?
If you switched to XP and it worked then that means you have a .INF file to work with. Either check out the driver CD your wireless modem came with or track down your installation files, your looking for a Windows driver that ends with .INF

Then check out these instructions

Best of luck

- Perry
 
Old 09-07-2008, 02:25 PM   #67
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
The hardware and drivers (b43) seem to be working OK. They are seen in lsmod. dmesg shows firmware is loaded. iwlist wlan0 scanning shows many wireless routers. ndiswrapper has worked for me in past but I don't think is needed here.
 
Old 10-19-2008, 12:55 PM   #68
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Quote:
Originally Posted by forum1793 View Post
So I took wireless card and put in my friends system.

Everything is basically the same except for she has 690g and I have 780g mboards. I also copied the rc.inet1 and rc.wireless scripts as well as wpa_supplicant.conf and rc.inet1.conf. Installed card, made appropriate changes to confs, and... it wouldn't work.

Couldn't even get wpa_supplicant -d ... to work.

We have exact same routers. But one difference we changed hers to run b/g mode instead of g only. And, we were using router with something else that only worked in B mode. Is there a setting I need to change for this? Do I need to tell it to use "ad-hoc". I never specified "managed" previously and it worked. Maybe that is default. The info at /usr/doc/wpa... not real clear on the mode. It states for ssid not being broadcast must use ap_scan=2 but our router was broadcasting.

wpa_supplicant -Bw ... functioned but did not associate.
dhcpcd wlan0 then just hung.

ifconfig wlan0 up, brought it up such that networks could be scanned and multiple routers were seen. This indicates the hardware and drivers are installed and functioning.


Running out of time, we switched to XP and it worked.

Thoughts?
Oddly enough, went back to friends place and the wireless worked right away. Pretty goofy.

Only difference I remember is previously (when scripts and/or wpa_supplicant command not working) a device using 802.11b was also using router. We changed router to allow this.

When working at apartment recently, the other device was not on. So it seems devices connected to router alter pc's ability to connect to router. Is there a setting in the .conf's that can help this? Maybe using "managed" or something else?
 
Old 03-02-2009, 07:39 PM   #69
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Hi all,

My apologies for the sudden disappearance 6 months ago! However, I am now back (and following a move of house) attempting to get wireless working again - I see from the Slackware changelog though that 12.2 is released with "simplified wired and wireless networking with wicd in /extra".

So I have the 12.2 DVD ISO downloading now and I'm going to attempt an upgrade later (still using my Vista laptop for now).

I may be back...
 
Old 03-03-2009, 08:18 PM   #70
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Quote:
Originally Posted by resaguk View Post
"simplified wired and wireless networking with wicd in /extra"
Did exactly what it said on the tin after a few simple config edits.
 
  


Reply

Tags
atheros, madwifi, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware blocking internet or settings incorrect for Java Wireless Toolkit? lifeforce4 Slackware 0 02-15-2008 11:41 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 07:25 AM
How do I automatically bring up wireless internet conneciton in Slackware 10.1? n00bified Linux - Hardware 1 12-28-2005 02:17 PM
Slackware 9.1 - Wireless Internet problem jelitegamer Linux - Software 3 09-01-2004 06:39 PM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration