LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-26-2008, 09:43 AM   #31
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Use WICD


I had a Treadnet 424 usb. I spend MUCH time trying to get it working. Had to use rtl8187 (I think) with ndiswrapper. Barely got this working, slowly, if wpa2 was not used. When using wpa2, nothing connected. I altered the rc.d files, commented things out, added things. I added other programs (wireless-assistant?). Nothing connected. I could see the networks but could not connect to my wpa2 connection.

Finally tried the rworkman version of wicd and it worked.

My thanks to rworkman and, evidently, nawcom for their efforts.

With regards to earlier comment about not having router broadcast: microsoft claims not having it broadcast is more of a risk. If router is not broadcasting, than PC/laptop will continue to send out signals and others can allow connection, tricking your PC into going through their router. Obviously that could be a problem if they're monitoring the packets. I could be wrong though as I am not by any means overly knowledgeable on the topic.
 
Old 07-26-2008, 07:43 PM   #32
wheelsg
Member
 
Registered: Feb 2004
Location: Westchester, NY
Distribution: slackware
Posts: 56

Rep: Reputation: 15
Quote:
Originally Posted by resaguk View Post
But isn't Madwifi for Atheros chipsets? As far as I can tell my wifi card is not Atheros based - I *think* it's Realtek 8185...
Oooops. Lost track of threads. Use the link Mike sent and use that with wpa_supplicant (-Dndiswrapper).

Still wishing you luck,
Geoff.
 
Old 07-28-2008, 04:46 AM   #33
storkus
Member
 
Registered: Jun 2008
Posts: 310

Rep: Reputation: 45
If he's using the driver from my link, why would he have to use ndiswrapper?

Mike
 
Old 07-28-2008, 07:30 PM   #34
wheelsg
Member
 
Registered: Feb 2004
Location: Westchester, NY
Distribution: slackware
Posts: 56

Rep: Reputation: 15
Yipes. Point well taken. It's a module all its own. Fantastic. But I didn't see it listed as supported by wpa_supplicant, that's why I thought the wrapper would be needed. What would be the driver indicated to supplicant, or would it only be the interface parameter?
 
Old 07-29-2008, 02:43 AM   #35
storkus
Member
 
Registered: Jun 2008
Posts: 310

Rep: Reputation: 45
Since I haven't had to set up wpa_supplicant yet, this might be a stupid question, but I thought wpa_supplicant did all the crypto finagling on the computer rather than on the wireless chip--is that wrong?

Mike
 
Old 07-29-2008, 04:18 AM   #36
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,390

Rep: Reputation: Disabled
The rtl-wifi drivers do not support WPA (on it's own or using wpa_supplicant). Open WEP is as far as it will go. Basically you're stuck with ndiswrapper if you want any kind of decent encryption.

You will have to pass the "-Dwext" parameter to wpa_supplicant though, and not "-Dndiswrapper" as suggested earlier. The wpa_supplicant communicates with all modern wireless drivers using "wext" aka the kernel's "wireless extensions". Only for very old versions of the ndiswrapper you needed the "ndiswrapper" protocol of wpa_supplicant.

Storkus, care to elaborate on the "rc.inet1/rc.wireless mess" as you so elegantly stated? Obviously since you have not even dealt with WPA yet, you have not seen everything these scripts can do for your wireless card.

Eric
 
Old 07-30-2008, 03:59 AM   #37
storkus
Member
 
Registered: Jun 2008
Posts: 310

Rep: Reputation: 45
You have a point there, Eric, but my point was how difficult it was trying to set up wifi for the first time ever (for me) even without encryption using the default Slackware scripts. Everything else in the rc world is just a quick search and edit and is fairly straightforward, which is why I like it versus the System V way. But the wireless stuff really threw me; as I said, though, it was the first time I had ever set up a wireless connection on ANY machine, so I was a bit down on the learning curve to begin with and had to give myself a crash-course on 802.11 terminology, techniques, etc. The only other thing I have ever seen (so far) in the Linux world that compares would be Sys-V init scripts, MTA configs, and sometimes x(free86|org).conf.

Mike
 
Old 07-30-2008, 07:52 AM   #38
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 38
I commented in another thread. Curiously, it seems that it is only under certain conditions that the Ath5k-based network stops working. I am puzzled - I have done some research and looked into the system, but it really seems that it is the driver that is, well, wobbly.
 
Old 08-02-2008, 10:44 AM   #39
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
One confusing point I had when trying to get wireless working was where to put the config info. Should it go into rc.inet1.conf, rc.wireless.conf, wpa_supplicant.conf, or even somewhere in kde or wireless assisstant.

Where do the script writer(s) prefer this information to be placed?
 
Old 08-02-2008, 11:49 AM   #40
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,390

Rep: Reputation: Disabled
Use rc.inet1.conf for all your wired and wireless network configuration. See the examples in the original rc.inet1.conf file.
Only in the case where you use WPA, you are required to use /etc/wpa_supplicant.conf additionally (although it would be good to know that for non-encrypted and WEP networks, you can use wpa_supplicant.conf as well).

Eric
 
Old 08-03-2008, 03:08 AM   #41
storkus
Member
 
Registered: Jun 2008
Posts: 310

Rep: Reputation: 45
Quote:
Originally Posted by mjjzf View Post
I commented in another thread. Curiously, it seems that it is only under certain conditions that the Ath5k-based network stops working. I am puzzled - I have done some research and looked into the system, but it really seems that it is the driver that is, well, wobbly.
2.6.26.1 just got released and in the changelog there's a (seeming) big change in ath5k. I also know just from the web page that the driver is considered beta (I think) and is under very heavy development, so it's no surprise to me that it's wobbly, especially considering the entire effort is one big reverse-engineering job. Wobbly or not, though, it's an "A" for effort and the fact it works as well as it does with just a couple of years or so work is amazing!

Mike
 
Old 08-03-2008, 07:57 PM   #42
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 796

Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by kiyoura View Post
For anyone who cares, this fixed my problem.

Code:
wget http://snapshots.madwifi.org/special/madwifi-nr-r3366+ar5007.tar.gz
tar -zxvf madwifi-nr-r3366+ar5007.tar.gz
cd madwifi-nr-r3366+ar5007
make
checkinstall --fstrans=no -S -y
installpkg madwifi-nr-r3366+ar5007-i386-1.tgz
cd .. 
rm -rf  madwifi-nr-r3366+ar5007*
I believe that some some cards or systems require this..."special" madwifi version. Regardless anyone with problems try this; may have to set up checkinstall in order to make the packages. BUT IT WORKED!
http://snapshots.madwifi.org/special...+ar5007.tar.gz
this tar.gz file has nothing more than a web address in it
that points to http://madwifi.org/ticket/1192
the fix for this ticket is to download and install a newer version
than the current release

there is no need to make the package just run make install
 
Old 08-25-2008, 09:09 PM   #43
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Recently got this asus wireless nic after reading that I would not need to use ndiswrapper. Followed directions here.

Could not get it working using rc.inet1 or rc.wireless with wpa. Put info in wpa_supplicant and still would not work. Loaded wicd, the workman version, commented out most things in rc.inet1.conf, rc.wireless.conf, and wpa_supplicant.conf. Ran /etc/rc.d/rc.wicd start. Then, in X, configured and ran wicd. It worked well.

I am curious though why it does not work with scripts, with info in any of the confs?

Last edited by forum1793; 08-25-2008 at 09:10 PM. Reason: typo
 
Old 08-25-2008, 09:32 PM   #44
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 651

Rep: Reputation: 92
Hi:

Quote:
Originally Posted by forum1793 View Post
Could not get it working using rc.inet1 or rc.wireless with wpa. Put info in wpa_supplicant and still would not work. Loaded wicd, the workman version, commented out most things in rc.inet1.conf, rc.wireless.conf, and wpa_supplicant.conf. Ran /etc/rc.d/rc.wicd start. Then, in X, configured and ran wicd. It worked well.
Plus 1 for saved by rworkman and wicd :-).

Andrew
 
Old 08-31-2008, 10:30 AM   #45
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Overall question: What is wrong with values in my conf files in getting wpa2 to work via the scripts?

WICD works but this requires running rc.wicd which can be put in a startup script easy enough. It also requires the user running the wicd program in KDE and pressing the connect button every time. There is probably a way to automate that but I haven't looked into it yet. It also potentially does not allow it to work unless X is running and this could be a problem.

So I would like to get it running via rc.inet1 and wpa2. I noticed scripts are a little newer than ones I was using so I switched to new ones. This didn't help.
Edit: Alien Bob: thank you for the continued efforts.

Because card works with wicd, we know hardware and driver requirements are met. Also, running ifconfig wlan0 up from command line works and iwlist scanning works so I think card and driver are OK.

In code below, xxx is stuff I've removed. If you see "" that is what it is.

Dmesg shows:
Code:
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: switched to short barker preamble (BSSID=xxx)
rc.inet1.conf, wireless part, is:
Code:
IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]=""
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
WLAN_WPAWAIT[4]=30
I've tried renaming rc.wireless.conf so that it did not exist and that did not seem to make any difference. It currently is:
Code:
VERBOSE=1

case "$HWADDR" in

#    INFO=""
    ESSID=""
    NWID=""
    MODE=""
    FREQ=""
    CHANNEL=""
    SENS=""
    RATE="auto"
    KEY=""
    RTS=""
    FRAG=""
    IWCONFIG=""
    IWSPY=""
    IWPRIV=""
    ;;
esac
I must have missed removing the auto part but have removed it and tried again with no difference.

wpa_supplicant.conf is:
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
  scan_ssid=0
  ssid="xxx"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=xxx #hex values from wpa program
}
If from command line:
Code:
bash-3.1# sh rc.inet1 restart
Polling for DHCP server on interface eth0:
Polling for DHCP server on interface wlan0:
No carrier detected on wlan0.  Reducing DHCP timeout to 3 seconds.
bash-3.1# sh rc.inet1 wlan0_start
Polling for DHCP server on interface wlan0:
No carrier detected on wlan0.  Reducing DHCP timeout to 3 seconds.
After this iwlist scanning does not show wlan0 is up, but if manually turn on wlan0, iwlist scanning works (but still doesn't connect).

Code:
bash-3.1# ifconfig wlan0 up
bash-3.1# iwlist scanning
lo        Interface doesn't support scanning.

ip6tnl0   Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: xxx
                    ESSID:"xxx"
                    Mode:Master
                    Channel:xxx
                    Frequency:xxx
                    Quality=68/100  Signal level=-42 dBm  Noise level=-50 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=xxx

Last edited by forum1793; 08-31-2008 at 10:47 AM.
 
  


Reply

Tags
atheros, madwifi, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware blocking internet or settings incorrect for Java Wireless Toolkit? lifeforce4 Slackware 0 02-15-2008 11:41 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 07:25 AM
How do I automatically bring up wireless internet conneciton in Slackware 10.1? n00bified Linux - Hardware 1 12-28-2005 02:17 PM
Slackware 9.1 - Wireless Internet problem jelitegamer Linux - Software 3 09-01-2004 06:39 PM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration