Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 03-31-2005, 02:26 AM   #1
Registered: Jul 2003
Location: Random
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
Wireless Intellimouse explorer...


Tell you what i just installed slackware 10.1 my mouse (wireless intellimouse explorer 2.0) does not work. Actually it shows the good `ol cursor but it only goes vertical i.e. up and down. Does anyody have a similar problem?

This mouse used to work straight out of the box. I mean really straight out of the box no tweaking of xorg.config.

Here is where i have tweaked my section pointer up to;

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

And yes the reciever module of the mouse is connected via the USB. Please i need some real help someone with a real idea of whats up!

Thanks very much in Advance...


Last edited by xmeson; 03-31-2005 at 07:50 AM.
Old 03-31-2005, 07:29 AM   #2
Senior Member
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Hmm. Guts had the same problem as you with Logitech wireless mouse.

The last time I spoke to him (AIM), he have converted to Suse. And according to him, the mouse works out of the box there. So, you may want to message him for the xorg.conf.
Old 03-31-2005, 09:13 AM   #3
Registered: Sep 2003
Posts: 173

Rep: Reputation: 30
I have the same problem with mine. Once I build my own kernel the problem goes away. Don't know what the problem is with the packaged kernel.
Old 05-03-2005, 03:11 AM   #4
LQ Newbie
Registered: Nov 2004
Distribution: Redhat
Posts: 8

Rep: Reputation: 0
my solving

I've had the same problem a while ago and here's how I solved it:
-uncomment the following lines in /etc/rc.d/rc.modules
/sbin/modprobe usb-uhci
/sbin/modprobe hid
/sbin/modprobe usbmouse
/sbin/modprobe mousedev
/sbin/modprobe evdev
-edit your /etc/X11/xorg.conf :
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Hope it helps..


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless intellimouse explorer 2.0 sidebuttons dittohead Linux - Hardware 11 07-16-2004 12:33 PM
Wireless IntelliMouse Explorer configuration Belerefontis Slackware 0 07-15-2004 04:59 PM
MS Wireless Intellimouse Explorer and Slackware 9.0 sambartle Linux - Hardware 32 02-15-2004 12:51 PM
MS Wireless USB intellimouse Explorer nitewulf50 Linux - Hardware 2 11-23-2002 04:20 PM
MS Wireless Intellimouse Explorer will not work with Mandrake 8.2 PSB Linux - Newbie 2 10-20-2002 10:32 AM

All times are GMT -5. The time now is 10:37 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration