LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-13-2012, 11:48 AM   #1
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Wireless Intel3945abg - unable to get wpa_supplicant status


I've just installed a fresh copy of the most Slackware 13.37 and looking to connect to wireless but I'm not sure where to set this to associate it with a SSID. Additionally, wpa_gui reports it's unable to get wpa_supplicant status.

When I restart /etc/rc.d/rc.inet1:
etc/rc.d/rc.inet1: wlan0 information: 'any ESSID'
SET failed on device wlan0 ; Operation not supported

iwconfig:
wlan0 IEEE 802.11abg ESSID: off/any
Mode: Managed Access Point: Not-Associated TX-Power15 dBm
Retry long limit:7 RTS thr: off Fragment thr: off
Enycryption key: off
Power management: off

/etc/wpa_supplicant.conf and /etc/rc.d/rc.inet1.conf are currently default

Any assitance would be much appreciated to connectiong to wireless.
 
Old 06-13-2012, 11:56 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
For wireless operation, it is probably easiest to install wicd from the /extra directory of your install media. It can be used either from a GUI or from the command line using wicd-client. You will need to configure wicd for initial operation.
Note that wicd works best if /etc/rc.d/rc.inet1.conf is left at the default.
 
Old 06-13-2012, 01:07 PM   #3
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by allend View Post
For wireless operation, it is probably easiest to install wicd from the /extra directory of your install media. It can be used either from a GUI or from the command line using wicd-client. You will need to configure wicd for initial operation.
Note that wicd works best if /etc/rc.d/rc.inet1.conf is left at the default.
Thanks for your help. I will give that a go.
 
Old 06-13-2012, 09:49 PM   #4
hf2046
Member
 
Registered: Mar 2011
Distribution: Slack64
Posts: 109

Rep: Reputation: 20
If you use any sort of security with your wireless access point, you need to modify the /etc/wpa_supplicant.conf file.

Try Alien's wiki:

http://alien.slackbook.org/dokuwiki/...wpa_encryption

Or just 'man wpa_supplicant.conf' at the command line.
 
Old 06-13-2012, 10:44 PM   #5
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,849
Blog Entries: 15

Rep: Reputation: 1189Reputation: 1189Reputation: 1189Reputation: 1189Reputation: 1189Reputation: 1189Reputation: 1189Reputation: 1189Reputation: 1189
You probably could grab Network Manager off of SlackBuilds.org and use it as well to help configure your wireless connection. it has an add-on package called Network Manager Applet which gives it a UI interface. It and WICD should work well enough.
 
Old 06-15-2012, 02:30 AM   #6
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 439

Rep: Reputation: Disabled
If you want to take the rc.inet1 + wpa_supplicant.conf method, you have to edit /etc/rc.d/rc.inet1.conf and /etc/wpa_supplicant.conf.

/etc/wpa_supplicant.conf is easy because you can usually just add the output of:
Code:
wpa_passphrase "Your Essid" <Passphrase>
(notice "Your Essid" is in quotes, and Passphrase is not.)

That'll generate a very basic network={} section for you that you can just append to /etc/wpa_supplicant.conf.

As for /etc/rc.d/rc.inet1.conf, Alien Bob has an entire page for it (and the configuration file itself has the information you need at the bottom):

http://alien.slackbook.org/dokuwiki/...ckware:network
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wpa_gui, could not get status from wpa_supplicant tmkd Slackware 5 12-17-2010 04:17 AM
Unable to ping device using wpa_supplicant and madwifi kureckam Linux - Wireless Networking 1 06-19-2009 04:37 PM
Slackware2.1, intel3945ABG wpa_supplicant problem satori@sanitarium Slackware 2 12-06-2008 04:00 PM
Slack12.1, Intel3945ABG -- wireless driver cannot be built. dafydil Linux - Wireless Networking 19 11-02-2008 05:41 PM
Unable to get IP Address with ipw2200 and wpa_supplicant Crushing Belial Slackware 2 02-14-2007 11:15 AM


All times are GMT -5. The time now is 05:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration