LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-07-2010, 03:37 PM   #16
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 141Reputation: 141

Quote:
Originally Posted by mattca View Post
Exellent If you start to have trouble, a report would be appreciated.

Maybe I'll try upgrading my kernel sometime soon.



Yes, the lib80211 module seems to load on boot, with the wl. This command was issued immediately after booting (with non-functioning wireless):

Any idea about lib80211_crypt_tkip? Should that be there as well?

Thanks again.
That all looks fine as far as I can tell. When it isn't working, check the output of dmesg for errors with the wireless. Might give some clue.

What kind of encryption are you using? How are you managing the network? If you're not, I would recommend trying WICD to manage your connections and see if that helps.
 
Old 03-07-2010, 04:13 PM   #17
Geriao
Member
 
Registered: Dec 2009
Distribution: Ubuntu Karmic Koala, Slackware 13.0
Posts: 66

Rep: Reputation: 16
If you use WPA/WPA2, I highly recommend reading Alien's wiki on that. It solved my problems, which were similar to yours.
 
Old 03-07-2010, 04:56 PM   #18
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 517

Rep: Reputation: 132Reputation: 132
Quote:
Originally Posted by mattca View Post
[edit: you say you're using 2.6.32 and the driver isn't working quite right.. what's it doing, or not doing? I wonder if it would be less hassle than what I'm dealing with now..]
In kernel 2.6.33 (Slackware-Current), the b43 driver gives fatal DMA errors. It *kinda* works if I load wl first, unload wl, and then load b43.

With the 2.6.32.x kernels, the b43 driver caused very high CPU usage for me.

Update: Kernel 2.6.34-RC1: Works for about 20 seconds, then disconnects and won't reconnect

My PCI-ID is also 14e4:4315, btw.

If you decide to try kernel 2.6.33, the broadcom-sta driver needs to be patched or else it won't compile

Code:
--- src/include/linuxver.h.orig	2010-03-07 15:52:49.861196761 -0700
+++ src/include/linuxver.h	2010-03-07 15:54:11.872197040 -0700
@@ -20,7 +20,7 @@
 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0))
 #include <linux/config.h>
 #else
-#include <linux/autoconf.h>
+#include <generated/autoconf.h>
 #endif
 #include <linux/module.h>

Last edited by piratesmack; 03-14-2010 at 01:26 PM.
 
1 members found this post helpful.
Old 03-08-2010, 07:23 AM   #19
Geriao
Member
 
Registered: Dec 2009
Distribution: Ubuntu Karmic Koala, Slackware 13.0
Posts: 66

Rep: Reputation: 16
Quote:
Originally Posted by piratesmack View Post

Also, if you decide to try kernel 2.6.33 the broadcom-sta driver needs to be patched or else it won't compile

Code:
--- src/include/linuxver.h.orig	2010-03-07 15:52:49.861196761 -0700
+++ src/include/linuxver.h	2010-03-07 15:54:11.872197040 -0700
@@ -20,7 +20,7 @@
 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0))
 #include <linux/config.h>
 #else
-#include <linux/autoconf.h>
+#include <generated/autoconf.h>
 #endif
 #include <linux/module.h>
That's a more elegant solution. What I did to recompile wl was to make a symbolic link in /usr/src/linux/include/ to ../generated/linuxver.h.
 
Old 03-09-2010, 07:40 PM   #20
slackwaredanny
Member
 
Registered: Feb 2010
Location: Sweden
Distribution: Slackware
Posts: 88
Blog Entries: 3

Rep: Reputation: 20
hope you get it to work okay,and if anybody got the bluetooth working please share!
 
Old 03-11-2010, 08:25 PM   #21
mattca
Member
 
Registered: Jan 2009
Distribution: Slackware 14.1
Posts: 321

Original Poster
Rep: Reputation: 51
Thanks for all the input everyone.

I seem to have gotten it sorted out. First, I found a command sequence that seemed to make it work consistently:

Code:
iwconfig eth1 essid <my essid>
iwconfig eth1 key <my key>
ifconfig eth1 down
ifconfig eth1 up
/etc/rc.d/rc.inet1 eth1_start
Then today at work I noticed that on my work laptop my essid & key were in rc.wireless.conf, not rc.inet1.conf (as it was on this laptop). I moved the settings to rc.wireless.conf, and it worked. I've rebooted 5 times, and it's worked each time.

I remember reading somewhere that rc.wireless.conf was being phased out, and that using rc.inet1.conf was preferred. Can someone explain what's going on here?

And, slackwaredenny, you'll probably have more luck if you start a new post with your question.
 
Old 03-13-2010, 02:26 PM   #22
vss2094
Member
 
Registered: Aug 2009
Location: Jeddah, KSA
Distribution: Slackware64-Multilib**
Posts: 49

Rep: Reputation: 16
Thumbs up

@ piratesmack

I too found it not compiling properly on kernel 2.6.33.
But this patch made it running well.

Right now posting from my HP Pavilion dv2000 with 14e4:4315.

thanks everybody
 
  


Reply

Tags
broadcom, slackware, wifi, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom 4312 on Debian AMD64? jman82s Linux - Laptop and Netbook 6 05-15-2009 08:41 PM
HP Compaq 6720s laptop with Broadcom 4312 wireless Pscylo Slackware 9 04-25-2008 05:32 PM
HP6720s Broadcom 4312 Pscylo Linux - Wireless Networking 0 04-16-2008 06:35 PM
Wireless configured for broadcom 4312 but local access only , Ethernet doesn't work calcium20 Slackware 3 02-05-2008 10:05 PM
Broadcom 4310/4312 wireless problems KentS Slackware 2 12-20-2007 05:43 AM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration