LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-10-2010, 02:25 PM   #1
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1


Hi.
I'm new to Slackware Linux, and I am having a problem getting
my wireless connection set up. I'm using Slackware linux 13.1
on an older Gateway laptop.

This is my situation:
The correct module for my card is loaded, ipw2200, and
it's dependent modules also.
as root, I ran iwlist scan, with the following output:


eth1 Scan completed :
ESSID:"1111"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.437 GHz (Channel 6)
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=48/100 Signal level=-72 dBm
Extra: Last beacon: 120ms ago

There are Cell 01 - Cell 06 which are also listed, and several of
them have
ESSID 1111, which is the one I need to use; I'm only showing
one of the ESSID 1111 's which lists out.
Please note this is for interface eth1.

in /etc/rc.d/rc.inet1.conf, I put

# configuration for my SRSU-RGC wireless connection
#IFNAME[5]="wlan0"
IFNAME[5]="eth1"
USE_DHCP[5]="yes"
#DHCP_KEEPRESOLV[5]="yes"
#DHCP_KEEPNTP[5]="yes"
#DHCP_KEEPGW[5]="yes"
WLAN_ESSID[5]="1111"
WLAN_MODE[5]=Master
##WLAN_CHANNEL[5]="auto"
WLAN_KEY[5]=""

I'm not showing the hex wep key I use for my site, but it's in the
actual file.
I've tried this with wlan0 and eth1 as the IFNAME (not at the same
time :|), with and without those DHCP_KEEP.... variables, with
Master or Managed, and nothing works.

The output of /etc/rc.d/rc.inet1 is always

bash-4.1# ./rc.inet1
Polling for DHCP server on interface eth0:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: waiting for carrier
dhcpcd: timed out
dhcpcd: allowing 8 seconds for IPv4LL timeout
dhcpcd: timed out
./rc.inet1: eth1 information: 'Any ESSID'
./rc.inet1: eth1 information: 'Any ESSID'

This output is exactly the same whether or not I've set
IFNAME[5]="eth1" or IFNAME[5]="wlan0".

I've done all of this using the "Configuring your network
in Slackware - Alien's Wike" as my guide. I must be
missing something, but I don't know what it is. Any
help on this would be greatly appreciated.
Thanks in advance.
Ferrel
 
Old 12-10-2010, 03:04 PM   #2
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 867

Rep: Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747
Quote:
Originally Posted by ferrel View Post
Hi.
This output is exactly the same whether or not I've set
IFNAME[5]="eth1" or IFNAME[5]="wlan0".
Are IFNAME[0] through IFNAME[4] already assigned to devices? If not, try editing the [0] entries.
 
Old 12-10-2010, 03:20 PM   #3
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1

They are all unused.

Okay, I changed rc.inet1.conf to

# configuration for my SRSU-RGC wireless connection
IFNAME[0]="eth0"
USE_DHCP[0]="yes"
WLAN_ESSID[0]="1111"
WLAN_MODE[0]=Master
WLAN_KEY[0]=""

./rc.inet1 shows

bash-4.1# ./rc.inet1
Polling for DHCP server on interface eth0:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: waiting for carrier
dhcpcd: timed out
dhcpcd: allowing 8 seconds for IPv4LL timeout
dhcpcd: timed out
./rc.inet1: eth1 information: 'Any ESSID'
 
Old 12-10-2010, 03:42 PM   #4
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,494

Rep: Reputation: 437Reputation: 437Reputation: 437Reputation: 437Reputation: 437
Is your access point using WEP or WPA encryption?

Is it possible to turn encryption off for a short period of time to see if you can connect without it? (That isn't a solution; it's just to see if the problem in connecting at all versus encryption mismatch.)
 
Old 12-10-2010, 03:53 PM   #5
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1

I don't think I can turn it off...I'm connecting to a University
network with a private computer. Is there a way to do it?
 
Old 12-10-2010, 03:58 PM   #6
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1

Also, it's definitely WEP (forgot to mention in my last reply).
 
Old 12-10-2010, 03:59 PM   #7
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 867

Rep: Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747
It might not hurt to try disabling the settings in rc.inet1.conf and installing the wicd package from /extra. Then you'll be able to adjust and monitor the wireless from the wicd applet in X (Xfce or KDE), or from the command line with "wicd-curses". If it is a configuration issue like WEP64 vs WEP128 vs WPA [...] you'll be able to test things more quickly that way.
 
Old 12-10-2010, 04:01 PM   #8
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 867

Rep: Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747Reputation: 1747
Quote:
Originally Posted by ferrel View Post
Also, it's definitely WEP (forgot to mention in my last reply).
Are you using a hex key for that? Just wondering because I've found passphrases to be less than portable.
 
Old 12-10-2010, 04:03 PM   #9
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1

The WEP key is all numbers and letters; isn't that in hex?
 
Old 12-10-2010, 04:54 PM   #10
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1

I'll see what I can do with wicd.
 
Old 12-10-2010, 05:26 PM   #11
fibster
Member
 
Registered: Feb 2006
Location: Washington State
Distribution: Slackware
Posts: 40

Rep: Reputation: 16
Alien Bob I thought used to have a how to on that. I am at work sorry but it was pretty easy set up.
 
Old 12-11-2010, 11:52 AM   #12
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Wireless Connection Problem Slackware 13.1

I installed wicd from /extra on the SlackDVD, added myself
to group netdev, wiped the changes I'd made to rc.inet1.conf,
rebooted, ran wicd, and connected! Very easy. I looked in
/etc/rc.d to see a conf file for the changes made, but it's
not there. I'm curious about the settings it's using, but I
certainly can't complain! Thanks to all for the help.
Ferrel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-14-2009 11:58 PM
Problem:VPN wireless connection with OpenSwan on Slackware 12.0 Salgeras Linux - Wireless Networking 2 10-05-2007 02:46 AM
Slackware 11 + Belkin USB Wireless Card = No Connection? Sir.Del Linux - Wireless Networking 4 03-01-2007 01:39 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 06:25 AM
Accesing wireless net connection in Slackware 10 NeoMetal Linux - Wireless Networking 5 08-31-2004 03:41 PM


All times are GMT -5. The time now is 02:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration