LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-18-2008, 12:24 PM   #1
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Rep: Reputation: 15
Wireless autoconnect (error for wireless request "set Nickname" (8B1C))


Hello.i am trying to configure my wireless.It works but if i try to configure for autoconnect at startup using static ip it faild.

wirelees card=linksys wmp54g
slackware=12.1
router=linksys
driver=ndiswrapper


Quote:
error for wireless request "set Nickname" (8B1C)
set faild on device wlan0 ; operation not supported
My configurations
wpa_supplicant.conf
Code:
 # WPA protected network, supply your own ESSID and 
WPAPSK here:
network={

  scan_ssid=0
  
  ssid="linksys"
  
  proto=WPA
  
  key_mgmt=WPA-PSK
  
  pairwise=CCMP TKIP
  
  group=CCMP TKIP WEP104 WEP40
  
  psk="mykey"
}
rc.wireless.conf
Quote:
## Pick up any Access Point, should work on most 802.11 cards
*)

INFO="linksys"
ESSID="linksys"
;;
## ---------- END SECTION TO REMOVE ------------
rc.inet1.conf
Quote:
IFNAME[4]="wlan0"
#IPADDR[4]="192.168.1.5"
NETMASK[4]="255.255.255.0"
#SE_DHCP[4]="no"
DHCP_HOSTNAME[4]=""
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]="linksys"
WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4$
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="ndiswrapper"
messages log
Quote:
May 17 17:59:15 server logger:/etc/rc.d/rc.inet1:
/sbin/route add default gw 192.168.1.1 metric 1
May 17 17:59:15 server logger: SIOCADDRT: No such process
May 17 17:59:19 server logger: /etc/rc.d/rc.inet1: /sbin/iwconfig wlan0 mode Managed
May 17 17:59:19 server logger: /etc/rc.d/rc.inet1: /sbin/iwconfig wlan0 nick server
May 17 17:59:19 server logger: /etc/rc.d/rc.inet1: /sbin/iwconfig wlan0 essid "linksys"

May 17 17:59:19 server logger: /etc/rc.d/rc.inet1: wpa_supplicant -Bw -c/etc/wpa_supplicant.conf -Dndiswrapp$
May 17 18:00:20 server logger: WPA authentication did not complete, try running '/etc/rc.d/rc.inet1 wlan0_sta$
May 17 18:00:23 server logger: /etc/rc.d/rc.inet1: /sbin/route add default gw 192.168.1.1 metric 1
May 17 18:00:23 server logger: SIOCADDRT: No such process
May 17 18:00:23 server logger: /etc/rc.d/rc.inet1: /sbin/ifconfig lo 127.0.0.1
May 17 18:00:23 server logger: /etc/rc.d/rc.inet1: /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
May 17 18:00:26 server logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 mode Managed
May 17 18:00:26 server logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 nick server
May 17 18:00:26 server logger: /etc/rc.d/rc.M: /sbin/iwconfig wlan0 essid "linksys"
May 17 18:00:26 server logger: /etc/rc.d/rc.M: wpa_supplicant found running already
May 17 18:01:27 server logger: WPA authentication did not complete, try running '/etc/rc.d/rc.inet1 wlan0_sta$
May 17 18:01:30 server logger: /etc/rc.d/rc.inet1: /sbin/route add default gw 192.168.1.1 metric 1
May 17 18:01:30 server logger: SIOCADDRT: No such process
May 17 18:01:31 server kernel: NET: Registered protocol family 10
May 17 18:01:31 server kernel: lo: Disabled Privacy Extensions
May 17 18:01:31 server kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Last edited by hellasyoda; 05-18-2008 at 12:59 PM.
 
Old 05-18-2008, 05:11 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I think you need to concentrate on getting the ndiswrapper module loaded earlier in the boot process. I don't run slackware, but I think there is a file in /etc/ of the drivers to load first. (It might be called preload) Another option is to include ndiswrapper in your initrd file.

Here is a Ubuntu link using ndiswrapper on the Acer. Some translation to slackware may be necessary. Note the acpi stuff, which may be Acer specific, however you could have a similar issue on your computer. This poster created a startup/shutdown script in /etc/init.d/ that modprobes ndiswrapper.
http://ubuntuforums.org/showthread.php?t=145701
 
Old 05-18-2008, 05:46 PM   #3
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 926

Rep: Reputation: 96
That warning about nickname isn't that important, I have it too with my Broadcom chip but the connection is working.
 
Old 05-19-2008, 05:39 AM   #4
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
I think you need to concentrate on getting the ndiswrapper module loaded earlier in the boot process. I don't run slackware, but I think there is a file in /etc/ of the drivers to load first. (It might be called preload) Another option is to include ndiswrapper in your initrd file.
i installed the package from linuxpackage.I remove it and install it from source.Now the module is load at startup but the same error.

if i restore the old rc.inet1.conf without changes and run these commands
the wireless working.

Quote:
iwconfig wlan0 essid linksys
ifconfig wlan0 192.168.1.5 netmask 255.255.255.0
route add -net default gw 192.168.1.1
route add -net default gw 192.168.1.1
wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf &
 
Old 05-19-2008, 06:30 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
I see several things wrong in your configuration.

First off, the ndiswrapper no longer requires the use of the "ndiswrapper" driver of wpa_supplicant, instead with modern releases of the kernel and ndiswrapper you should use the "wext" driver. Read my info at http://alien.slackbook.org/dokuwiki/...reless_network

Second, the line
Code:
#IPADDR[4]="192.168.1.5"
will prevent the card from getting an IP address even if you would get the WPA configuration to work.

What I would do:
  1. Delete /etc/rc.d/rc.wireless.conf (it is not needed and you can keep all your settings in /etc/rc.d/rc.inet1.conf)
  2. Have this in your /etc/wpa_supplicant.conf file:
    Code:
    # This line enables the use of wpa_cli which is used by rc.wireless
    # if possible (to check for successful association)
    ctrl_interface=/var/run/wpa_supplicant
    # By default, only root (group 0) may use wpa_cli
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    
    # WPA protected network, supply your own ESSID and WPAPSK here:
    network={
      scan_ssid=0
      ssid="linksys"
      proto=WPA
      key_mgmt=WPA-PSK
      pairwise=CCMP TKIP
      group=CCMP TKIP WEP104 WEP40
      psk=your_psk_here
    }
  3. Have this as your network configuration for card number [4] in /etc/rc.d/rc.inet1.conf:
    Code:
    IFNAME[4]="wlan0"
    IPADDR[4]="192.168.1.5"
    NETMASK[4]="255.255.255.0"
    USE_DHCP[4]=""
    DHCP_HOSTNAME[4]=""
    WLAN_ESSID[4]="linksys"
    WLAN_MODE[4]=Managed
    WLAN_WPA[4]="wpa_supplicant"
    WLAN_WPADRIVER[4]="wext"
  4. And don't forget to set the default gateway in /etc/rc.d/rc.inet1.conf:
    Code:
    # Default gateway IP address:
    GATEWAY="192.168.1.1"

Eric
 
1 members found this post helpful.
Old 05-19-2008, 07:35 AM   #6
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Original Poster
Rep: Reputation: 15
ok thanks for replys.I will try but before that i have create another problem.When i try to access to my router through browser (192.168.1.1) i see it works! from my localhost apache server and if i try
Quote:
route add -net default gw 192.168.1.1
it return no such process
 
Old 05-19-2008, 12:26 PM   #7
hellasyoda
Member
 
Registered: Oct 2006
Location: HELLAS
Distribution: Slackware 12.1
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
What I would do:
ok thanks it works!!Also for my last problem, it solved after restart
 
Old 05-19-2008, 01:12 PM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
Good to see that it all works using only the Slackware configuration scripts ;-)

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error for wireless request "Set Mode" (8B06) wgp80 Linux - Wireless Networking 4 07-26-2010 04:18 PM
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 01:16 PM
Error for wireless request "Set Mode" on Linksys WPC11 v 3 army180 Linux - Wireless Networking 2 09-04-2006 06:32 PM
Error for wireless request "Set Bit Rate" (8B20) king_scott_2 Linux - Wireless Networking 3 06-26-2006 05:27 PM
Startup Errors with wireless networking Error for wireless request "Set Encode" Cryptoniks Linux - Wireless Networking 1 03-21-2006 07:06 AM


All times are GMT -5. The time now is 01:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration