LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2012, 02:09 PM   #1
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Rep: Reputation: 0
Wireless atheros AR5007G & network manager not connecting -current x86_64 multilib


Hi all, just installed my new tp-link WN350GD wireless card, tp-link WR340GD router & network manager with KDE plasmoid included . After reboot the card gets detected and scan the near wifi spots. Router is set to security "none".
Network manager detects my router, connects and gets IP. Shows status connected. Switch to firefox and nothing. ifconf and iwconf shows the card is detected and connected with IP assigned trough dhcpcd. Tried alienBob's wiki to the letter and same result.
Any help is welcome.

Some text follows
Code:
root@cesarion:/home/cesar# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications Inc. AR5007G Wireless Network Adapter (rev 01)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Code:
root@cesarion:/home/cesar# lsmod
Module                  Size  Used by
snd_seq_dummy           1455  0 
snd_seq_oss            29048  0 
snd_seq_midi_event      5620  1 snd_seq_oss
snd_seq                51265  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5228  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            39183  0 
snd_mixer_oss          15404  1 snd_pcm_oss
ipv6                  279499  18 
xt_limit                2065  2 
xt_pkttype              1083  1 
ipt_REJECT              2305  2 
xt_tcpudp               2495  19 
ipt_LOG                 7258  11 
xt_state                1287  6 
iptable_mangle          1576  0 
iptable_nat             4016  0 
iptable_filter          1480  1 
nf_conntrack_irc        3475  0 
nf_nat_ftp              1660  0 
nf_nat                 15280  2 iptable_nat,nf_nat_ftp
nf_conntrack_ftp        6085  1 nf_nat_ftp
nf_conntrack_ipv4      11604  9 iptable_nat,nf_nat
nf_conntrack           52529  7 xt_state,iptable_nat,nf_conntrack_irc,nf_nat_ftp,nf_nat,nf_conntrack_ftp,nf_conntrack_ipv4
nf_defrag_ipv4          1331  1 nf_conntrack_ipv4
ip_tables              17202  3 iptable_mangle,iptable_nat,iptable_filter
x_tables               16914  10 xt_limit,xt_pkttype,ipt_REJECT,xt_tcpudp,ipt_LOG,xt_state,iptable_mangle,iptable_nat,iptable_filter,ip_tables
lp                      9787  0 
fuse                   66562  5 
ath5k                 138817  0 
i915                  414582  2 
ath                    14691  1 ath5k
mac80211              227411  1 ath5k
snd_intel8x0           27231  5 
drm_kms_helper         26069  1 i915
cfg80211              168812  3 ath5k,ath,mac80211
snd_ac97_codec        113139  1 snd_intel8x0
uhci_hcd               23236  0 
drm                   187389  3 i915,drm_kms_helper
ac97_bus                1198  1 snd_ac97_codec
8139too                19512  0 
ppdev                   5958  0 
snd_pcm                72864  4 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
rfkill                 15428  1 cfg80211
ehci_hcd               40968  0 
parport_pc             19423  1 
i2c_algo_bit            5319  1 i915
i2c_i801                8044  0 
mii                     3987  1 8139too
video                  11378  1 i915
button                  4529  1 i915
intel_agp              10832  1 i915
intel_gtt              13833  3 i915,intel_agp
agpgart                27372  3 drm,intel_agp,intel_gtt
sg                     25470  0 
psmouse                61672  0 
evdev                   9574  7 
snd_timer              18798  3 snd_seq,snd_pcm
snd                    57796  17 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore               5474  1 snd
parport                31427  3 lp,ppdev,parport_pc
processor              25314  0 
serio_raw               4389  0 
i2c_core               19978  5 i915,drm_kms_helper,drm,i2c_algo_bit,i2c_i801
thermal_sys            14578  2 video,processor
snd_page_alloc          7081  2 snd_intel8x0,snd_pcm
shpchp                 26337  0 
hwmon                   1329  1 thermal_sys
loop                   18192  0 
ext4                  409225  2 
mbcache                 5777  1 ext4
jbd2                   66290  1 ext4
Code:
root@cesarion:/home/cesar# uname -a    
Linux cesarion 3.2.13 #1 SMP Fri Mar 23 22:44:58 CDT 2012 x86_64 Intel(R) Pentium(R) 4 CPU 3.06GHz GenuineIntel GNU/Linux
Code:
root@cesarion:/home/cesar# ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:13:8f:a3:37:1c  
          inet6 addr: fe80::213:8fff:fea3:371c/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:83682 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78895 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:90157006 (85.9 MiB)  TX bytes:10516482 (10.0 MiB)
          Interrupt:22 Base address:0xb800 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:200 (200.0 B)  TX bytes:200 (200.0 B)

wlan0     Link encap:Ethernet  HWaddr f4:ec:38:fd:24:49  
          inet addr:192.168.1.100  Bcast:255.255.255.255  Mask:255.255.255.0
          inet6 addr: fe80::f6ec:38ff:fefd:2449/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1268 (1.2 KiB)  TX bytes:1654 (1.6 KiB)
Code:
root@cesarion:/home/cesar# iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"pancho"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: F4:EC:38:F6:61:94   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0
 
Old 04-28-2012, 07:47 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

What do you have in '/etc/resolv.conf'? What does the kernel route table show: 'route -n'?
 
Old 04-28-2012, 09:05 AM   #3
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

What do you have in '/etc/resolv.conf'? What does the kernel route table show: 'route -n'?
Hi, and thanks for the reply.

/etc/resolv.conf shows:
Code:
# Generated by NetworkManager
nameserver 10.0.0.2
nameserver 192.168.1.1
And route -n this
Code:
bash-4.2# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0
 
Old 04-28-2012, 09:29 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

You should use the ISP DNS if possible. If '192.168.1.1' is a valid DNS then it could be a problem there. I suspect '192.168.1.1' is your router/modem that is the Gateway. 'nameserver 10.0.0.2' not valid with the kernel routing you show.

You could try from the cli to 'ping 67.215.65.132' and if that is valid then 'ping opendns'. If the latter fails then your DNS is not setup properly.
Quote:
nameserver 67.215.65.132 #OpenDNS
nameserver 8.8.8.8 #Google
nameserver 4.2.2.1 #Verizon Third level
nameserver 4.2.2.2 #
nameserver 4.2.2.3
nameserver 4.2.2.4
You could select a few from the above for your '/etc/resolv.conf' file but it would be best to at least use one of your ISP provided DNS. Unless of course you wish to setup a DNS server for your LAN.
 
Old 04-28-2012, 10:24 AM   #5
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

You should use the ISP DNS if possible. If '192.168.1.1' is a valid DNS then it could be a problem there. I suspect '192.168.1.1' is your router/modem that is the Gateway. 'nameserver 10.0.0.2' not valid with the kernel routing you show.

You could try from the cli to 'ping 67.215.65.132' and if that is valid then 'ping opendns'. If the latter fails then your DNS is not setup properly.
You could select a few from the above for your '/etc/resolv.conf' file but it would be best to at least use one of your ISP provided DNS. Unless of course you wish to setup a DNS server for your LAN.
10.0.0.2 is my ISP adsl modem
192.168.1.1 is my wireless router

Code:
root@cesarion:/home/cesar# ping 67.215.65.132
PING 67.215.65.132 (67.215.65.132) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
Should I change the DNS? How to do it?
TX
 
Old 04-28-2012, 11:01 AM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

How is the LAN configured? How do you have the router configured to comm with the modem? Which port on the router to the port on the modem?

It would be easier to stay with a range rather than having two different levels. Why have the modem on a different range of the class?

A lot easier to setup with the modem local IP in the same range. Set the modem to '192.168.1.1' with the router to say '192.168.1.2'. Set either the modem as the dhcp server or the router. No need to worry about the modems Internet IP, just set the local IP.

Look at: Linux Home Networking or Linux Networking HOWTO
 
Old 04-28-2012, 01:01 PM   #7
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
Hi,
How do I set the local IP? Do I 've got to enter modem/router config?
thx
 
Old 04-29-2012, 07:41 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,292
Blog Entries: 3

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
Member response

Hi,

You can use the wired device on your computer (Internet) plugged into the router/modem to enter the web admin page. Be sure to restart 'inet' as root at command line(cli) with '/etc/rc.d/rc.inet1 restart' to get a new IP from the router/modem device. Then open a browser and in the address bar enter the IP that is currently set for the device. For the router you would use '192.168.1.1' then enter the assigned username & password. Most router will have a basic configuration page. You would then change the IP and save the settings.

Same with the modem, you would use '10.0.0.2' for the address entry(after cycling inet with a restart). Enter the username & password. You can get that information from the manual. Depending on the manufacture the username may be 'admin' and password could be 'password'. Look at both modem & router manuals for setup information. Sometimes you will find setup examples & procedures for the router/modem in their manuals.

For the modem you will need to connect & get a new IP from the dhcp for that range by using the '/etc/rc.d/rc.inet1 restart'.

You can use the links that I provided earlier to get some helpful background information. I like to provide a scope of my address assignments in written form for future reference(s).

For a 'SOHO' LAN your dhcp pool will not be that big nor will static IP assignments.
 
Old 04-29-2012, 11:50 PM   #9
cesarion76
Member
 
Registered: Nov 2009
Location: Rosario, Argentina
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 0
The problem was that I had the rc.firewall pointing at eth0. just chmod -x /etc/rc.d/rc.firewall do the job. Commented out /etc/rc.d/rc.inet1.conf and config all through Networ Manager, WPA2 included. Can't be more happy and tiered I checked the links you suggested and clarified some dark spots for me. thanx for the help
 
  


Reply

Tags
atheros, network manager


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 11.10 Network Manager issues connecting to wireless network after restart depam Linux - Software 2 01-22-2012 08:39 PM
no option of connecting to network, network card doesnt appear (Atheros AR5B93) mkohler Debian 2 08-15-2011 06:29 PM
[SOLVED] Slackware-13.0 x86_64 : Multilib, Nvidia & Wine pokipoki08 Slackware 3 02-01-2010 10:20 AM
wireless connection problems & now lost lan connection & network manager wont work Rainbowserpant Linux - Wireless Networking 2 09-02-2009 04:00 AM
atheros 5006eg wireless does not work in ANY distro current gusty gibbon ubuntu people Linux - Newbie 2 09-21-2008 11:32 PM


All times are GMT -5. The time now is 03:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration