LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-13-2008, 11:00 PM   #1
madwida
LQ Newbie
 
Registered: Oct 2008
Posts: 25

Rep: Reputation: 15
wired/wireless down after successfully setting them up


Hi

I recently got my wired and wireless networks up and running. I followed the instructions in Alien Bob's wiki, loaded wicd, and found the proper drivers. All was well. I received a lot of helpful advice in this thread: http://www.linuxquestions.org/questi...n-.tgz-674709/

Then I went away for five days, came home and this is what now happens: while booting the process halts here for a at least a minute: Triggering udev events: /sbin.udevtrigger –retry failed;

and then repeatedly scrolling down the screen is the following:

failed to connect to wpa_supplicant-wpa_ctrl_open: No such file or
directory;

and then: polling for dhcp server on interface wlan0 no carrier detected

Neither my wired network nor my wireless now works. Wicd appears when KDE loads. I can open it and see the wireless networks but cannot connect to them nor can I connect to the wired network.

I have read the following thread w/o much luck http://www.linuxquestions.org/questi...ectory-611577/

I am happy to post the output of whatever commands would be best or contents of particular files. I did not do so now as I wanted to wait and see what advice I got--and most importantly i cannot get online on the Slackware machine. I did go into rc.inet1.conf to try and see if I could fix things; I may have made them worse.

So, any help would be appreciated. I really do not what cold have happened--especially with the wired network as it was working just fine.

I can type in relevant portions of ifconfig if that would help.

Many thanks!!

EDIT:

Hi

In another thread (http://www.linuxquestions.org/questi...=wired+network) I found the following advice: Once you run the 'netconfig' be sure to '/etc/rc.d/rc.inet1 restart'.

I did that in a terminal and was connected via my wired network. Then I tried to connect via wireless and it would not connect (though wicd sees all the networks around me). Then I had to rerun /etc/rc.d/rc.inet1 restart to get back on the wired network. But at least now I can post my outputs.

Thanks

Last edited by madwida; 10-14-2008 at 12:03 AM. Reason: more info
 
Old 10-14-2008, 05:09 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled
Once you switch to wicd you need to remove all network configuration from /etc/rc.d/rc.inet1.conf . And using "/etc/rc.d/rc.inet1 restart" is no longer an option. It will interfere with wicd and you will suffer.

Pick one or the other means of network configuration. Not both at the same time.

Eric
 
Old 10-14-2008, 07:45 AM   #3
madwida
LQ Newbie
 
Registered: Oct 2008
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Alien Bob View Post
Once you switch to wicd you need to remove all network configuration from /etc/rc.d/rc.inet1.conf . And using "/etc/rc.d/rc.inet1 restart" is no longer an option. It will interfere with wicd and you will suffer.

Pick one or the other means of network configuration. Not both at the same time.

Eric
Hi Eric

Thanks for the quick reply. May I ask: How do I do what you suggest? What do I comment out in the file? "/etc/rc.d/rc.inet1 restart" did work to get me on the wired network so I am concerned that I will do something wrong in the file and knock out wired too

Many thanks

Christian
 
Old 10-14-2008, 09:06 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled
If you want to use wicd, you need to configure it to manage the wired as well as the wireless card. Then, you need to remove all the values in /etc/rc.d/rc.inet1.conf that you (or netconfig) added for your wired and/or wireless card.
If you are unsure what to remove, post the entire file here and I can show you what to edit.

Eric
 
Old 10-14-2008, 10:20 AM   #5
madwida
LQ Newbie
 
Registered: Oct 2008
Posts: 25

Original Poster
Rep: Reputation: 15
Hi Eric

Here's the file. Now I cannot get online at--restart is not working any longer.

I put the file a USB drive and then pasted it here. I hope I did the code tags properly; my apologies if not.

I really appreciate the help

Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
#DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="ath0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=LYNKSYS
WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
 
Old 10-14-2008, 11:02 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,334

Rep: Reputation: Disabled
These are the lines
Code:
USE_DHCP[0]="yes"

IFNAME[4]="ath0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]=LYNKSYS
WLAN_MODE[4]=Managed
WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
WLAN_WPADRIVER[4]="ndiswrapper"
that you have to change into
Code:
USE_DHCP[0]=""

#IFNAME[4]="ath0"
USE_DHCP[4]=""
#WLAN_ESSID[4]=LYNKSYS
#WLAN_MODE[4]=Managed
#WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
#WLAN_WPADRIVER[4]="ndiswrapper"
That way, rc.inet1 will no longer try to interfere with wicd. Do not forget to create a wired profile in wicd and tell it to try and use the wired interface by default on boot (I assume that is what you want).

Eric
 
Old 10-14-2008, 11:36 AM   #7
madwida
LQ Newbie
 
Registered: Oct 2008
Posts: 25

Original Poster
Rep: Reputation: 15
Hi again

Thanks for the tips. I did what you said and still nothing. Wicd appears, all the wifi networks appear, I can connect quite easily to several or the wired networ, but then simply cannot get online--firefox won't load. I know I am probably driving you crazy with this! Here's the file one more time just to see if there's something I missed. Or do you have any other ideas? I'm tryinh hard to follow your directions.

Thanks!

Code:
# /etc/rc.d/rc.inet1.conf
=============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]=""
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=LYNKSYS
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
 
Old 10-14-2008, 08:49 PM   #8
madwida
LQ Newbie
 
Registered: Oct 2008
Posts: 25

Original Poster
Rep: Reputation: 15
Problem solved! Thanks for the superb help once again. I got it all working after your help--don't know why it did not work right away, but it does now. I've since had a chance to download Conky from SlackBuild and am playing around with it thanks to your help getting online

Best wishes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A few questions regarding setting up wired and wireless interfaces. okos Slackware 11 09-04-2008 06:47 AM
Wireless and Wired connection on Belkin wireless G F5D7230 not working together ernie79 Linux - Hardware 1 02-10-2008 07:50 AM
netgear ma311 wireless card will not talk to actiontec wired/wireless router tzonga1 Linux - Wireless Networking 2 02-10-2007 06:52 PM
Wireless Laptop to Wired ethernet via Linux PC (wired/wireless) sambartle Linux - Wireless Networking 0 01-30-2005 05:37 AM
Wired to Wireless back to Wired The_Nerd Linux - Hardware 5 09-15-2004 10:20 PM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration