LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Wired network doesn't reconnect after suspend (http://www.linuxquestions.org/questions/slackware-14/wired-network-doesnt-reconnect-after-suspend-4175476041/)

mattca 09-05-2013 10:10 AM

Wired network doesn't reconnect after suspend
 
Hi all, I use pm-suspend to put my work laptop to sleep at the end of the day. When it resumes, I have to manually tell the wired network to reconnect.

It connects as expected while booting, and wicd automatically reconnects to known wireless networks when resuming. I've told wicd to "Always switch to wired connection when available" and "Automatically reconnect on connection loss", but still it does not.

Manually telling wicd to connect to the wired network connects as expected.

Any ideas?

guanx 09-05-2013 04:39 PM

Do you have the link down after resume? (= buggy driver?)

Do you use dhcp and your dhcp client terminated running after suspend? (= buggy dhcpcd setup?)

jostber 09-05-2013 04:55 PM

Can this help you out?

http://www.linuxquestions.org/questi...hy-4175473429/

mattca 09-06-2013 08:49 AM

Quote:

Originally Posted by guanx (Post 5022616)
Do you have the link down after resume? (= buggy driver?)

Do you use dhcp and your dhcp client terminated running after suspend? (= buggy dhcpcd setup?)

The link appears to still be up after resuming, although admittedly I'm not 100% sure how to check. ifconfig recognizes eth0, however it shows an inet6 IP address only.

However, after resume it appears that dhcpcd is not running anymore. After reconnecting via wicd it has been started again. Any ideas as to why it might not start after resume?

Thanks!

---------- Post added 09-06-13 at 09:50 ----------

Quote:

Originally Posted by jostber (Post 5022632)

Thanks for the reply, but that appears to be about wireless connections, not wired.

guanx 09-06-2013 10:08 AM

Quote:

Originally Posted by mattca (Post 5023056)
...
However, after resume it appears that dhcpcd is not running anymore. After reconnecting via wicd it has been started again. Any ideas as to why it might not start after resume?
...

I have the same problem with dhcpcd. When my link goes down briefly, dhcpcd terminates. The author of dhcpcd says I must have explicitly told dhcpcd to exit on link down. Because the word "told" is non-technical, I can't figure out what he means.

So now I'm running dhcpcd with the "-K" option. Not an elegant solution but it works.

mattca 09-06-2013 10:19 AM

Quote:

Originally Posted by guanx (Post 5023098)
I have the same problem with dhcpcd. When my link goes down briefly, dhcpcd terminates. The author of dhcpcd says I must have explicitly told dhcpcd to exit on link down. Because the word "told" is non-technical, I can't figure out what he means.

So now I'm running dhcpcd with the "-K" option. Not an elegant solution but it works.

Thanks for the tip. Where would be the appropriate place to do that? I'm assuming I should edit one of the files in /etc/rc.d. Which one? It appears rc.inet1, rc.6 and rc.0 all start dhcpcd. Is it possible to do this as an option in one of the conf files, or do I actually need to edit a script?

guanx 09-06-2013 10:59 AM

Because you are using wicd, the rc.inet1 stuff has no effect. Probably you can try the "/etc/dhcpcd.conf" file. Please "man dhcpcd.conf" and search for "nolink" (without quotes).

If you choose to use rc.inet1 instead of wicd, then with the patch here you can add options to dhcpcd.

mattca 09-10-2013 03:48 PM

Quote:

Originally Posted by guanx (Post 5023125)
Because you are using wicd, the rc.inet1 stuff has no effect. Probably you can try the "/etc/dhcpcd.conf" file. Please "man dhcpcd.conf" and search for "nolink" (without quotes).

If you choose to use rc.inet1 instead of wicd, then with the patch here you can add options to dhcpcd.

Thanks for the tip. I've added "nolink" to dhcpcd.conf and it doesn't seem to have helped :(

Also, if the issue is with dhcpcd, wouldn't it affect all networking? Why does it reconnect to wireless networks, but not wired?

guanx 09-10-2013 05:48 PM

Quote:

Originally Posted by mattca (Post 5025475)
Thanks for the tip. I've added "nolink" to dhcpcd.conf and it doesn't seem to have helped :(

Sorry, I've been away from wicd for quite some time. Looks like the wicd deamon killed dhcpcd.

Did you set "Always switch to wired connection when available" in wicd Preference?

jostber 09-11-2013 02:47 AM

Quote:

Originally Posted by guanx (Post 5025512)
Sorry, I've been away from wicd for quite some time. Looks like the wicd deamon killed dhcpcd.

Did you set "Always switch to wired connection when available" in wicd Preference?

This setting works for me.

mattca 09-11-2013 08:45 AM

Quote:

Originally Posted by guanx (Post 5025512)
Sorry, I've been away from wicd for quite some time. Looks like the wicd deamon killed dhcpcd.

Did you set "Always switch to wired connection when available" in wicd Preference?

Yes, but upon rechecking my settings I noticed the "Wired Autoconnect Settings" section. "Use default profile on wired autoconnect" was selected. I switched it to "Use last used profile on wired autoconnect", and it appears to work now! :D

Thanks for your help!


All times are GMT -5. The time now is 04:38 AM.