LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-05-2013, 10:10 AM   #1
mattca
Member
 
Registered: Jan 2009
Distribution: Slackware 14.1
Posts: 316

Rep: Reputation: 49
Wired network doesn't reconnect after suspend


Hi all, I use pm-suspend to put my work laptop to sleep at the end of the day. When it resumes, I have to manually tell the wired network to reconnect.

It connects as expected while booting, and wicd automatically reconnects to known wireless networks when resuming. I've told wicd to "Always switch to wired connection when available" and "Automatically reconnect on connection loss", but still it does not.

Manually telling wicd to connect to the wired network connects as expected.

Any ideas?
 
Old 09-05-2013, 04:39 PM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Do you have the link down after resume? (= buggy driver?)

Do you use dhcp and your dhcp client terminated running after suspend? (= buggy dhcpcd setup?)
 
Old 09-05-2013, 04:55 PM   #3
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Can this help you out?

http://www.linuxquestions.org/questi...hy-4175473429/
 
Old 09-06-2013, 08:49 AM   #4
mattca
Member
 
Registered: Jan 2009
Distribution: Slackware 14.1
Posts: 316

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by guanx View Post
Do you have the link down after resume? (= buggy driver?)

Do you use dhcp and your dhcp client terminated running after suspend? (= buggy dhcpcd setup?)
The link appears to still be up after resuming, although admittedly I'm not 100% sure how to check. ifconfig recognizes eth0, however it shows an inet6 IP address only.

However, after resume it appears that dhcpcd is not running anymore. After reconnecting via wicd it has been started again. Any ideas as to why it might not start after resume?

Thanks!

---------- Post added 09-06-13 at 09:50 ----------

Quote:
Originally Posted by jostber View Post
Thanks for the reply, but that appears to be about wireless connections, not wired.
 
Old 09-06-2013, 10:08 AM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by mattca View Post
...
However, after resume it appears that dhcpcd is not running anymore. After reconnecting via wicd it has been started again. Any ideas as to why it might not start after resume?
...
I have the same problem with dhcpcd. When my link goes down briefly, dhcpcd terminates. The author of dhcpcd says I must have explicitly told dhcpcd to exit on link down. Because the word "told" is non-technical, I can't figure out what he means.

So now I'm running dhcpcd with the "-K" option. Not an elegant solution but it works.
 
Old 09-06-2013, 10:19 AM   #6
mattca
Member
 
Registered: Jan 2009
Distribution: Slackware 14.1
Posts: 316

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by guanx View Post
I have the same problem with dhcpcd. When my link goes down briefly, dhcpcd terminates. The author of dhcpcd says I must have explicitly told dhcpcd to exit on link down. Because the word "told" is non-technical, I can't figure out what he means.

So now I'm running dhcpcd with the "-K" option. Not an elegant solution but it works.
Thanks for the tip. Where would be the appropriate place to do that? I'm assuming I should edit one of the files in /etc/rc.d. Which one? It appears rc.inet1, rc.6 and rc.0 all start dhcpcd. Is it possible to do this as an option in one of the conf files, or do I actually need to edit a script?
 
Old 09-06-2013, 10:59 AM   #7
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Because you are using wicd, the rc.inet1 stuff has no effect. Probably you can try the "/etc/dhcpcd.conf" file. Please "man dhcpcd.conf" and search for "nolink" (without quotes).

If you choose to use rc.inet1 instead of wicd, then with the patch here you can add options to dhcpcd.
 
Old 09-10-2013, 03:48 PM   #8
mattca
Member
 
Registered: Jan 2009
Distribution: Slackware 14.1
Posts: 316

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by guanx View Post
Because you are using wicd, the rc.inet1 stuff has no effect. Probably you can try the "/etc/dhcpcd.conf" file. Please "man dhcpcd.conf" and search for "nolink" (without quotes).

If you choose to use rc.inet1 instead of wicd, then with the patch here you can add options to dhcpcd.
Thanks for the tip. I've added "nolink" to dhcpcd.conf and it doesn't seem to have helped

Also, if the issue is with dhcpcd, wouldn't it affect all networking? Why does it reconnect to wireless networks, but not wired?
 
Old 09-10-2013, 05:48 PM   #9
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by mattca View Post
Thanks for the tip. I've added "nolink" to dhcpcd.conf and it doesn't seem to have helped
Sorry, I've been away from wicd for quite some time. Looks like the wicd deamon killed dhcpcd.

Did you set "Always switch to wired connection when available" in wicd Preference?
 
Old 09-11-2013, 02:47 AM   #10
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Quote:
Originally Posted by guanx View Post
Sorry, I've been away from wicd for quite some time. Looks like the wicd deamon killed dhcpcd.

Did you set "Always switch to wired connection when available" in wicd Preference?
This setting works for me.
 
Old 09-11-2013, 08:45 AM   #11
mattca
Member
 
Registered: Jan 2009
Distribution: Slackware 14.1
Posts: 316

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by guanx View Post
Sorry, I've been away from wicd for quite some time. Looks like the wicd deamon killed dhcpcd.

Did you set "Always switch to wired connection when available" in wicd Preference?
Yes, but upon rechecking my settings I noticed the "Wired Autoconnect Settings" section. "Use default profile on wired autoconnect" was selected. I switched it to "Use last used profile on wired autoconnect", and it appears to work now!

Thanks for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Have to reload wifi module to make Wicd reconnect after suspend. Why? Kallaste Slackware 3 08-15-2013 10:50 PM
Script to reconnect the wired network automatically tinymark Linux - Networking 2 05-06-2009 04:50 AM
bridging a wireless and wired network causes wired to stop working royce2020 Linux - Networking 0 04-21-2009 04:48 PM
GUI network-manager-vpnc doesn't connect over wired connection only jhernandez1270 Linux - Newbie 1 02-04-2009 03:14 PM
How to reconnect to wifi on resume from hibernate/suspend? Slackware 12.1, madwifi thesk8ingtoad Slackware 1 08-22-2008 07:15 AM


All times are GMT -5. The time now is 04:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration