LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-09-2009, 03:27 PM   #1
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Rep: Reputation: 50
wine opengl issue with neverwinter nights 2 on slackware 64


Normally I'd post this on the Bioware forum, but I get much better answers on this forum. After installing wine 1.1.29 on my Slackware 64 system and following the appdb instructions to the letter, I can't get the game to run. I can bring up the launcher, update Neverwinter Nights 2 via the updater, but not run the game. I get an X server error, with mention of GL:
Major opcode of failed request: 136
Minor opcode of failed request: 7

I have the proprietary ATI 9.8 drivers installed and I've been able to run other 32-bit openGL apps like Neverwinter Nights with this fix: export LIBGL_DRIVERS=/usr/lib. That didn't work for me in this case. Any help would be appreciated, as I really don't want to run Windows just for this game.

Last edited by vik; 09-09-2009 at 03:30 PM.
 
Old 09-09-2009, 04:27 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
I do not believe that LIBGL_DRIVERS is the correct variable or that /usr/lib is the correct value for the variable you want. Even on the previous thread where we talked about this, it just didn't seem right.

Can you do me a favor and run:

LIBGL_DEBUG=verbose LIBGL_DRIVERS=/usr/lib /usr/bin/32/glinfo
 
Old 09-09-2009, 04:29 PM   #3
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Original Poster
Rep: Reputation: 50
I'll do it first thing when I get home. Thanks for your input.
 
Old 09-09-2009, 10:08 PM   #4
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Original Poster
Rep: Reputation: 50
Code:
LIBGL_DEBUG=verbose LIBGL_DRIVERS=/usr/lib /usr/bin/32/glinfo
/usr/bin/32/glinfo: error while loading shared libraries: libGLEW.so.1.5: cannot open shared object file: No such file or directory
Doing a find / -name "libGLEW*":
Code:
/usr/lib64/libGLEW.so.1.5.1             
/usr/lib64/libGLEW.so.1.5               
/usr/lib64/libGLEW.a                    
/usr/lib64/libGLEW.so

Last edited by vik; 09-09-2009 at 10:18 PM.
 
Old 09-09-2009, 10:31 PM   #5
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Original Poster
Rep: Reputation: 50
Here's the full output:
Code:
wine nwn2.exe
fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x175e50,0x176318): stub
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x175e50,0x176318): stub
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x175e50,0x176318): stub
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  479
  Current serial number in output stream:  479
 
Old 09-09-2009, 10:46 PM   #6
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Original Poster
Rep: Reputation: 50
OK, so I built a glew compatibility package from the Slackware 32-bit CD and installed it. Now I'm getting this error:
Code:
libGL: XF86DRIGetClientDriverName: 8.64.3 fglrx (screen 0)
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/fglrx_dri.so
libGL error: dlopen /usr/lib/xorg/modules/dri/fglrx_dri.so failed (/usr/lib/xorg/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory)
libGL error: unable to load driver: fglrx_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so
GLUT: Fatal Error in glinfo: visual with necessary capabilities not found.
I get the same error running /usr/bin/32/glewinfo.

Looking at the fglrx-x740-64a-8.64-x86_64-1 package, I see that there's a
/usr/lib64/xorg/modules/dri/fglrx_dri.so, but not a /usr/lib version. I've been trying to fool the ATI installer into thinking it's a 32-bit system with export ARCH=i486 and export ARCH=486 so I can build a 32-bit package, but it still creates files in the /usr/lib64 directory.

Last edited by vik; 09-09-2009 at 11:41 PM.
 
Old 09-09-2009, 11:55 PM   #7
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
If wine uses 32 bit OpenGL Drivers, Do you have the 32bit drivers for your graphics card installed?
I don't think that the SlackBuild for Nvidia is installed by default
 
Old 09-10-2009, 12:00 AM   #8
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 8

Original Poster
Rep: Reputation: 50
I'm not sure if they are or not. Looking at the fglrx X libraries, there are only 3 installed in /usr/lib: libaticalcl, libaticaldd, and libaticalrt. I'm wondering if installing the ati driver manually (instead of using Slackware packages) will fix this.

Another thing: I have Neverwinter Nights Linux client running (32-bit) and I believe it requires OpenGL. So I can't tell you one way or the other...

I uninstalled the Slackware packages and ran the installer manually. Now I get the same output with /usr/bin/32/glinfo as /usr/bin/glinfo. I think I'm on the right track...

Success! I get some warnings about Wine not being able to render certain effects, but the game runs. It's jerky, but I think I can fix it with some fine-tuning. Who would've thought the Slackpackages didn't have 32-bit compatibility built-in? Anyway, thank you for your help.

Last edited by vik; 09-10-2009 at 02:16 AM.
 
Old 09-10-2009, 04:43 AM   #9
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Yeah, that's what I thought. The 32-bit 3D library wasn't installed. NWN worked simply because it was falling back to indirect rendering. Now NWN should actually perform noticeably better, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Neverwinter Nights 2 in Linux rachel_reveley Linux - Games 1 12-10-2006 12:22 PM
NeverWinter Nights GML3G0 Linux - Games 8 06-27-2006 02:08 PM
Neverwinter Nights wont work in im Slackware current b3rx Linux - Games 4 04-05-2006 02:11 PM
Neverwinter Nights problem jaakkop Linux - Games 0 09-01-2005 02:33 PM
Neverwinter Nights Comarez Linux - Games 9 02-07-2004 07:11 AM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration