LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   WINE and Slackware64. Programs Only Run in a Terminal. (http://www.linuxquestions.org/questions/slackware-14/wine-and-slackware64-programs-only-run-in-a-terminal-756442/)

cwizardone 09-19-2009 03:38 PM

WINE and Slackware64. Programs Only Run in a Terminal.
 
Once again, I would like to say a word of Thanks to Mr. Volkerding, Alien BOB, and the entire Slackware team for a job very well done on Slackware64. :hattip:
Alien BOB's work on Slackware64, his "True Multilib"* files, and his latest creation, a 64 bit package of WINE, is truly outstanding and way beyond "the call of duty."
*You should copyright that Alien BOB and/or make it a registered trademark. :)

I did a search of the last month's posts and didn't see anything about this problem (in the Slackware forum).

After installing Slackware64 and the "True Multilib" files, I installed the same version of WINE that worked so well with Slackware 12.2. Unfortunately, I found that while a windows application would run if it was fired it up from the prompt in a terminal (Konsole), it would not work, using the same command, as an item from the menu.

Thinking perhaps a new version was in order I looked around and found Alien BOB's recent 64 bit package of WINE. BTW, it runs better than any previous
version of WINE I've used. Thanks, again. However, the above outlined problem remains.

Anyone know a fix?

Many Thanks.
:)

Alien Bob 09-19-2009 04:00 PM

Hi!

I thought I could run my Wine-installed programs from their installed menus in Slackware64, but now I am not so sure.. I'll have to wait until I can boot into 64bit to test that (I only have one 64bit computer and that is compiling VLC in 32bit now.)

Eric

samac 09-20-2009 02:28 AM

I have quicken starting from the menu here, however the menu item is one I created not one added by wine. I can start from menu, panel, command line or clicking on an icon. This works in both KDE and XFCE on Slackware64-13.0 (multi-lib) with a stock kernel and wine-1.1.24-x86_64-1_SBo.

samac

cwizardone 09-20-2009 09:29 PM

Quote:

Originally Posted by samac (Post 3690337)
I have quicken starting from the menu here, however the menu item is one I created not one added by wine. I can start from menu, panel, command line or clicking on an icon. This works in both KDE and XFCE on Slackware64-13.0 (multi-lib) with a stock kernel and wine-1.1.24-x86_64-1_SBo.
samac

What are you doing differently with your commands?

If I enter this command at the prompt in a console,

wine /home/nai/.wine/drive_c/ahdw/ahd3.exe

the program will run. However, if I put that same command in a command line box using the KDE Menu Editor, the program won't run.
I've been trying different options, but no success as of the moment.
BTW, the above command line worked perfectly with WINE in Slackware 12.2.
Thanks.

samac 09-21-2009 02:42 AM

wine '/home/nai/.wine/drive_c/ahdw/ahd3.exe'

samac

cwizardone 09-21-2009 10:23 AM

Quote:

Originally Posted by samac (Post 3691312)
wine '/home/nai/.wine/drive_c/ahdw/ahd3.exe'
samac

Thanks for the effort, but no joy.
:(

cwizardone 09-22-2009 11:12 AM

Now What?
 
Well, this morning when I ran,

/home/nai/.wine/drive_c/ahdw/ahd3.exe

in a konsole it returned the error:

wine: cannot find '/home/hai/.wine/drive_c/ahdw/ahd3.exe'

It is there, I checked, and the permissions are correct, i.e., they are set for my user name and the group, "users."

Just for chuckles I deleted the /drive_c/ahdw directory and re-installed the program from scratch via WINE. Didn't change a thing, still the same problem.
So, I then copied the ahdw directory to my home directory and ran,

wine /home/hai/ahdw/ahd3.exe

in a konsole and it did work. However, it still won't work if ran from a menu entry using the KDE Menu Editor.

It is probably something simple, but none of the tweaks I've tried so far have worked. I've been running this same old windows program, "The American Heritage Talking Dictionary" for years under wine and have always been able to make it work, i.e., until now, for whatever reasons.
I've never been able to get the audio to work, but I'm happy just to have the dictionary and thesaurus at my fingertips.
Anymore suggestions on how to make this work from the menu would be greatly appreciated.
Many Thanks.
:hattip:

samac 09-22-2009 11:28 AM

A couple of thoughts which probably have already been done. Is this a newly compiled wine or one that you had lying about? Have you tried wincfg?

samac

tobyl 09-22-2009 12:33 PM

try doing what samac said, except use double quotes, not single

tobyl

cwizardone 09-22-2009 12:45 PM

Quote:

Originally Posted by samac (Post 3693067)
A couple of thoughts which probably have already been done. Is this a newly compiled wine or one that you had lying about? Have you tried wincfg?
samac

Yep. Tried both, old and new, but the result is the same.

cwizardone 09-22-2009 12:46 PM

Quote:

Originally Posted by tobyl (Post 3693120)
try doing what samac said, except use double quotes, not single
tobyl

Thanks, but quotes, single, double, or none at all, the result is the same. no joy.

tobyl 09-22-2009 01:39 PM

Curious. I have 64 bit current with multilib and just installed alien's wine package. It worked for me with double quotes for the path (although i used the notepad.exe)

tobyl

cwizardone 09-24-2009 01:14 PM

wine /home/username/.wine/drive_c/ahdw/ahd3.exe

wine /home/username/ahdw/ahd3.exe

Just FYI, neither of the above worked from a menu with KDE, but the second of the two,

wine /home/username/ahdw/ahd3.exe

does work as a menu item with Xfce.

As with KDE the first one only works within a console.

vik 09-25-2009 08:33 PM

This might be super obvious, but did you try giving the full path to wine in the menu command?
1) Please post the menu command you're using.
2) In the menu editor advanced tab, select run in terminal. Hopefully you'll get some output if things aren't working OK.

cwizardone 09-25-2009 11:52 PM

Quote:

Originally Posted by vik (Post 3697281)
This might be super obvious, but did you try giving the full path to wine in the menu command?
1) Please post the menu command you're using.

It is all in the previous posts.


Quote:

Originally Posted by vik (Post 3697281)
2) In the menu editor advanced tab, select run in terminal. Hopefully you'll get some output if things aren't working OK.

Already tried that. No joy.


All times are GMT -5. The time now is 12:10 AM.