LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2008, 04:49 AM   #1
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Rep: Reputation: 31
windows decorations, compiz


I know this topic become annoying..but
Can anybody tell how to make compiz and emerald show windows decorations?
 
Old 04-30-2008, 05:05 AM   #2
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
There is now Emerald in Slackware by default. You may compile it yourself.
Instead of Emerald you could try
Code:
gtk-window-decorator
or
Code:
kde-window-decorator
 
Old 04-30-2008, 06:09 AM   #3
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
well I tryed this combination - kde-window-decorator + window manager compiz = no deco
Any other ideas?
 
Old 04-30-2008, 05:29 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,291

Rep: Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708
If you're using KDE, kde-window-decorator WILL work with the compiz that is shipped by default (or any newer version I would assume -- but I've only tried up to 0.5.2 before getting too frustrated). Compiz is a very finicky app, so it may not work the first time you try and may work perfectly fine another time. It's seriously messed up.

What version of compiz are you using? Did you compile it yourself or is it the one that comes with Slackware? What command do you use to start compiz?

Usually, after starting compiz, you can try `kde-window-decorator &` in a terminal and it will restore your window decoration-goodness while still running compiz. However, I found that sometimes when starting compiz I completely lost the ability to type in any textbox or terminal, which prevented me from being able to enter that command -- but this only happened sometimes (finicky). Your best bet would be to create a compiz startup script like the following:
Code:
#!/bin/sh
compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
kde-window-decorator &
Note that you should change the compiz line to whatever command you use to start compiz. If you use CCSM (again, I'm talking out of my ass here since the last compiz version I used was 0.5.2) you could use `compiz --ignore-desktop-hints --replace ccp &` instead and use CCSM to configure the plugins that you want (the --ignore-desktop-hints thing attempts to fix the terrible mess that is the KDE pager when used with compiz -- I don't know if they've [KDE or compiz] done anything to work with that better or not).
 
Old 05-01-2008, 06:08 AM   #5
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
Compiz version is 0.7.4 with all the other stuff like:
ccsm-0.7.4-noarch-1as.tgz
compiz-bcop-0.7.4-noarch-1as.tgz
compizconfig-backend-kconfig-0.7.4-i486-1as.tgz
compizconfig-python-0.7.4-i486-1as.tgz
compiz-fusion-plugins-extra-0.7.4-i486-1as.tgz
compiz-fusion-plugins-main-0.7.4-i486-1as.tgz
compiz-fusion-plugins-unsupported-0.7.4-i486-1as.tgz
emerald-0.7.4-i486-1as.tgz
fusion-icon-20080312-noarch-1as.tgz
libcompizconfig-0.7.4-i486-1as.tgz

and deps:

fuse-2.7.3-i486-1as.tgz
libsexy-0.1.11-i686-4as.tgz
libsexymm-0.1.9-i486-1mch.tgz
libwnck-2.18.3-i486-1sl.tgz
pycairo-1.4.12-i686-1as.tgz
pygobject-2.14.1-i486-1sl.tgz
pygtk-2.12.1-i486-1sl.tgz
pyrex-0.9.6.4-i486-1as.tgz
sexy-python-0.1.9-i686-4as.tgz

I've downloaded from slacky.it

I'm starting compiz simply running fusion-icon then choosing compiz as window manager and emerald as window decorator. No deco though.

When I run this script -
compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
kde-window-decorator &

I'm getting
compiz (core) - Error: Another window manager is already running on screen: 0
compiz (core) - Fatal: No manageable screens found on display :0

The same error with
compiz --ignore-desktop-hints --replace ccp &

Any ideas\advices\thoughts?

Xorg conf:

Section "ServerLayout"
Option "AIGLX" "on"

Section "Module"
Load "type1"
Load "freetype"
#Load "speedo"
Load "glx"
Load "dri"

Section "Device"
Identifier "VESA Framebuffer"
Driver "nvidia"
Option "AllowGLXWithComposite" "true"
# Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "true"
# Option "TripleBuffer" "true"

Section "Screen"
Option "XAANoOffscreenPixmaps"
Option "AddARGBGLXVisuals" "true"

Section "DRI"
Mode 0666

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"

Last edited by STARHARVEST; 05-01-2008 at 06:25 AM. Reason: add error output
 
Old 05-01-2008, 10:50 PM   #6
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,291

Rep: Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708
Interesting xorg.conf. At first glance you have an awful lot of weird, restrictive options for an nVidia card (like 'Option "AllowGLXWithComposite" "true"' etc., which I admittedly know nothing about). It's also very short. And I don't think I've ever seen 'Option "AIGLX" "on"' with an nVidia card -- but that may just be my inexperience. It is worth noting that 'Option "Composite" "Enable"' is 'Option "Composite" "enable"' in my xorg.conf, but I'm not sure if that makes a difference.

If I were you (which I'm not) I would back up my xorg.conf, run `xorgconfig` (which I think sets up the most complete xorg.conf, in my opinion), then run the nVidia installer to update your xorg.conf (choosing to compile the kernel module instead of downloading it) and then trying. You should make sure DRI is enabled when you start X (`glxinfo | grep rendering` should show "direct rendering: Yes"). You may have to manually add the following to the new xorg.conf if it's not already there (it's there in your existing one, but I don't know if you added it yourself or not):
Code:
Section "Extensions"
    Option         "Composite" "enable"
EndSection
My (slightly messy) xorg.conf is posted below (note that the ServerFlags section was added by me, I think, to prevent the screen from turning off every 15 or so minutes -- it got really annoying when watching videos). The rest was generated by xorgconfig and the nVidia installer, with the exception of the ModeLine, which I needed to add to get full resolution for my monitor.
Code:
Section "ServerLayout"

    Identifier     "Simple Layout"
    Screen         "Screen 1" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"

    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/OTF"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/misc/"
    FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/Speedo/"
    FontPath        "/usr/lib/X11/fonts/Type1/"
    FontPath        "/usr/lib/X11/fonts/TTF/"
    FontPath        "/usr/lib/X11/fonts/OTF/"
    FontPath        "/usr/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/lib/X11/fonts/75dpi/"
    FontPath        "/usr/lib/X11/fonts/100dpi/"
EndSection

Section "Module"

    SubSection     "extmod"
    EndSubSection
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "blank time" "0"
    Option         "standby time" "0"
    Option         "suspend time" "0"
    Option         "off time" "0"
EndSection

Section "InputDevice"

    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "logiaccess"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"

    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Device" "/dev/psaux"
    Option         "ZAxisMapping" "4 5"
    Option         "Buttons" "5"
EndSection

Section "Monitor"

    Identifier     "al2223w"
    HorizSync       31.0 - 81.0
    VertRefresh     56.0 - 75.0
    ModeLine       "1680x1050" 146.2 1680 1784 1960 2240 1050 1053 1059 1089
    Option         "DPMS"
EndSection

Section "Device"

    Identifier     "Standard VGA"
    Driver         "vga"
    VendorName     "Unknown"
    BoardName      "Unknown"
EndSection

Section "Device"

    Identifier     "NVIDIA GeForce"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Screen 1"
    Device         "NVIDIA GeForce"
    Monitor        "al2223w"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       8
        Modes      "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
        Modes      "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "enable"
EndSection

Last edited by T3slider; 05-01-2008 at 10:52 PM.
 
Old 05-02-2008, 03:07 AM   #7
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
Problem is partly solved. Compiz is running but with black windows inside apps. In other case it shows the windows contents but only shows, you can't, say, type in term.
 
Old 05-02-2008, 03:58 AM   #8
STARHARVEST
Member
 
Registered: Nov 2005
Location: Russia, republic of Bashkiria
Distribution: Slackware 12.1
Posts: 294

Original Poster
Rep: Reputation: 31
And one more thing. Where, exactly, to put, say, Option "RenderAccel" "true"? In Section "Screen" or in Section "Device"? E.g. guys on en.opensuse.org advise to put all options in Screen section. Can anybody explain the difference?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz on Ubuntu(Studio) - Resizing windows causes Compiz to crash! lostinpurdy Linux - Desktop 1 03-27-2008 11:02 PM
ubuntu compiz window decorations PatrickNew Linux - Software 6 10-10-2007 07:48 AM
how do I remove windows decorations in metacity? Simon Bridge Linux - Desktop 3 12-28-2006 06:29 PM
How to Import KDE Styles and Windows Decorations? edwin11 Linux - Software 3 10-21-2006 03:58 AM
Can't install windows decorations odiseo77 Linux - Software 2 04-16-2005 10:45 AM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration