LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-10-2010, 08:37 AM   #1
jdoe@
LQ Newbie
 
Registered: Nov 2010
Posts: 10

Rep: Reputation: 0
Window manager unresponsive after startx


I'm running Slackware 12.2 with wmii-3.9.2 as my window manager. My problem is that after startx wmii sometimes becomes unresponsive i.e., can't open xterm or any other program or even quit. have to use Ctrl+Alt+BkSpc. I have no clue what causes the problem.

"$ cat /var/log/Xorg.0.log | grep \(EE\)" returns nothing. Though after quitting X I often see XIO error 11 (resource temporarily unavailable) but I don't know if this was caused by killing X. Graphics card is nVidia ION. I'm using the latest and recommended driver from nvidia.com (260.19.12). //for xorg.conf see at the bottom

It doesn't seem to be a hardware issue as all the hardware is working properly (dmesg reports nothing suspicious). /var/log/messages reports nothing unusual (except for some acpid messages but that's probably another story).

I suspect it's something to do with my xorg.conf and/or the DISPLAY variable and/or wmii (because Xfce4 does not freeze). echo $DISPLAY returns :0.0 but this value is set by startx/xinit anyway. So I'm lost at this point. Any ideas?

Thanks in advance

My xorg.conf is:
---------- BEGIN ----------
Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Xinerama" "0"
EndSection

Section "Files"
// RgbPath and FontPath's
EndSection

Section "Module"
Load "dbe"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
Option "XkbOptions" "ctrl:swapcaps"
Identifier "Keyboard1"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "ACER G205H"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "ION"
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1600x900 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
---------- END ----------
 
Old 11-10-2010, 11:11 AM   #2
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
1. Try to use default nVidia driver instead of closed source one.

2. Try to backup your current xorg.conf and generate a new one. In order to do it you could use xorgconfig program -- not easy one but very reliable.

3. Try to use some other window manager or desktop environment. In order to achieve that you could run xwmconfig command.

4. Take into consideration installing the newest Slackware 13.1.

Report the results here.
 
Old 11-10-2010, 11:33 AM   #3
jdoe@
LQ Newbie
 
Registered: Nov 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by w1k0 View Post
1. Try to use default nVidia driver instead of closed source one.
I'm running an ION based graphics card (onboard) which a fairly new and I need proper video output. The problem has become somewhat superfluous anyway (see answer to 3.)

Quote:
Originally Posted by w1k0;41548842.
Try to backup your current xorg.conf and generate a new one. In order to do it you could use xorgconfig program -- not easy one but very reliable.
I reconfigured X through "X -configure" and tested the server with "X -config <new xorg.conf>" to no avail as it seems to be a problem with the newest version of wmii-3.9.2 and my esoteric hardware(?).

Quote:
Originally Posted by w1k0;41548843.
Try to use some other window manager or desktop environment. In order to achieve that you could run xwmconfig command.
As I may have reported in my first post, the problem is only persistent with wmii. Xfce4 works fine yet I didn't want to jump to conclusions since Xfce4 is a DE and brings along its own stuff. So I tested dwm which works (so far) i.e., it's a problem with wmii-3.9.2 I guess.

Quote:
Originally Posted by w1k0;41548844.
Take into consideration installing the newest Slackware 13.1.
Tried it, disliked it. Hald really tempered with my X. 12.2 has at least an xorg.conf. I didn't like the idea that Slackware 13.1 uses the hald so exclusively on default (I read CHANGES_AND_HINTS.TXT on how to revert to xorg.conf) and I especially dislike the hald configuration. This seems quite extravagant for a conservative distribution like Slackware but that's just me.
 
Old 11-10-2010, 12:40 PM   #4
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Using Slackware 13.1 doesn't prevent you from using xorg.conf. To generate it use the well known command X -configure. I don't know about your needs but I use four simple files with HAL: to disable or enable TouchPad, to define keyboard layout, to make usable mouse wheel (TrackPoint in my case) and to make possible TouchPad emulation of mouse wheel. If you're interested in such configuration I can publish these files here.
 
Old 11-10-2010, 02:07 PM   #5
jdoe@
LQ Newbie
 
Registered: Nov 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
I don't know about your needs but I use four simple files with HAL: to disable or enable TouchPad, to define keyboard layout, to make usable mouse wheel (TrackPoint in my case) and to make possible TouchPad emulation of mouse wheel. If you're interested in such configuration I can publish these files here.
Thanks, I'd be interested in your keyboard layout config. I was unable to make hal recognize the ctrl:swapcaps switch. After that I disabled hal and configured everything through xorg.conf. Still, the option ctrl:swapcaps was not recognized (while everything else was). So I assumed hal and xorg.conf don't play nicely together and I blamed it all on hal. I'm not big fan of configuring .
 
Old 11-10-2010, 03:24 PM   #6
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Bad news is my HAL configuration for X Window keyboard concerns only national keyboard layout so it wouldn’t helpful in your situation. Good news is I played with the keyboard configuration in the past because I use two different keyboard configurations in X Window so I have some experience and I can help you.

1. Look at /etc/X11/xkb/symbols/ directory and determine the file containing your keyboard layout.

2. Copy ctrl file to ctrl0 one.

3. Remove from ctrl0 file everything except the section:

Code:
// swap the caps lock key with the left control key
partial modifier_keys 
xkb_symbols "swapcaps" {
    replace key <CAPS>  {  [ Control_L ] };
    replace key <LCTL>  {  [ Caps_Lock ] };
};
4. Insert at the beginning of the file determined in the first step the line:

Code:
    include "ctrl0"
5. Restart X Window.

I wrote the present post using keyboard layout using that switched configuration and it was nightmare. So assuming you’re accustomed to such a configuration it was nightmare for you to use the standard one configuration.

Last edited by w1k0; 11-10-2010 at 03:29 PM. Reason: grammar and style
 
Old 11-10-2010, 03:45 PM   #7
jdoe@
LQ Newbie
 
Registered: Nov 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Thank you very much w1k0, I'll definitely try this as soon as I can bring myself to upgrade to 13.1 or any later version.
 
Old 11-10-2010, 03:57 PM   #8
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
It should work with Slackware 12.2 as well.

Last edited by w1k0; 11-11-2010 at 11:18 AM. Reason: typo
 
Old 11-11-2010, 09:25 AM   #9
stojadinovic
LQ Newbie
 
Registered: Feb 2009
Posts: 7

Rep: Reputation: 0
I am not sure if I have the same problem, but every time I boot up my system and login, my Window Manager is unresponsive. If I move the mouse I can see the cursor moving, but I can't click anywhere, the keyboard though functions ok so I can do ctrl-alt-bckspace, and after I logout and login again everything is ok. I use Slackware 13.1 and GNOME, but I had the exactly same problem in KDE. Thanks in advance.
Also, I see there was some mentioning of xorg.conf, I had some problems trying to configure xorg.conf, I wanted to disable loading dri module but I couldn't, in Xorg.0.log I always see that dri module is loaded:

Code:
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
I am kind of a noob, so any help would be much appreciated.
 
Old 11-11-2010, 11:06 AM   #10
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
stojadinovic, I’m not sure but I suppose in your case it’s enough to:

1) exit X Window

2) next generate as root new xorg.conf with the command:

X -configure

3) then copy xorg.conf in the appropriate place with the command:

cp /root/xorg.conf.new /etc/X11/xorg.conf

4) next change in /etc/X11/xorg.conf the lines:

Code:
	Load  "dri2"
	Load  "dri"
into the lines:

Code:
	Disable  "dri2"
	Disable  "dri"
5) and finally run X Window.

Last edited by w1k0; 11-11-2010 at 11:15 AM. Reason: updates
 
Old 11-11-2010, 06:25 PM   #11
stojadinovic
LQ Newbie
 
Registered: Feb 2009
Posts: 7

Rep: Reputation: 0
But there are no
Code:
Load "dri2"
Load "dri2"
lines in xorg.conf at all, there is only
Code:
Load "glx"
so the question actually was, because it says "will be loaded by default", where is this "default" specified?
But this is another problem, do you have any idea why the Window Manager becomes unresponsive to the mouse clicks until I logout and login, and this happens every time I boot up the system? Thanks.

Last edited by stojadinovic; 11-11-2010 at 06:29 PM.
 
Old 11-11-2010, 07:39 PM   #12
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
I disabled DRI in the past and as I remember I modified these two lines of Module section of xorg.conf. Now I tried it but when I run startx command it replied:

Code:
Fatal server error:
no screens found
So now you need some other customization to disable DRI. Unfortunately I don't know what could you do in order to achieve that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beryl Window Manager / Emerald Theme Manager Not Changing With ATi Drivers. Z3R0o Linux - Desktop 2 01-06-2007 11:23 PM
What's the best X-Window System window manager in your opinion? t3gah Linux - Software 9 12-16-2006 10:10 PM
Change/add window manager to login manager kunalagon Debian 3 06-04-2006 03:33 AM
changing desktop manager and window manager Tux Red Hat 4 04-04-2006 01:56 PM
startx with window manager ... supermatt Linux - Newbie 4 11-24-2003 09:57 PM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration