LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-27-2004, 01:29 AM   #1
fcaraballo
Member
 
Registered: Feb 2004
Location: WA
Distribution: Slackware
Posts: 230

Rep: Reputation: 31
Will keyboard volume keys work while playing a CD?


While listening to a CD with XMMS, my volume keys on my M$ Natural Keyboard Pro do not work. They do, however, work fine while listen to Shoutcast with XMMS. Does anyone know of a way to get them to work while listening to a CD?

The following is the entry for my volume controls:
Code:
None XF86AudioLowerVolume :ExecCommand amixer -q set PCM 2- &
None XF86AudioRaiseVolume :ExecCommand amixer -q set PCM 2+ &
MagicMan

P.S. I have my key bindings/xmodmap file setup already so please don't suggest I use a program to do this, thanks.
 
Old 11-27-2004, 07:53 AM   #2
nukkel
Member
 
Registered: Mar 2003
Location: Belgium
Distribution: Hardened gentoo
Posts: 323

Rep: Reputation: 30
Use "Master" instead of "PCM" in the amixer command. PCM only applies to sound generated by the sound card's pcm chip, whereas the cd drive is usually hooked to Line In or something. Using "Master" will control all sources at once.

have fun
nukkel
 
Old 11-28-2004, 07:24 PM   #3
fcaraballo
Member
 
Registered: Feb 2004
Location: WA
Distribution: Slackware
Posts: 230

Original Poster
Rep: Reputation: 31
I had tried that in the past, but it did not work correctly with my surround sound. When I would turn the volume down it would just turn down the front speakers and make the back speakers louder. I went ahead and tried it again and found that if I made both the Master and Surround settings go up/down at the same time it worked. I also set my mute to do the same and now the volume/mute keys work like they should.

This is what they are set to now:
Code:
None XF86AudioMute :ExecCommand amixer -q set Master toggle &&  amixer -q set Surround toggle &
None XF86AudioLowerVolume :ExecCommand amixer -q set Master 2- &&  amixer -q set Surround 2- &
None XF86AudioRaiseVolume :ExecCommand amixer -q set Master 2+ &&  amixer -q set Surround 2+ &
Thanks for the help

MagicMan
 
Old 11-29-2004, 12:42 PM   #4
nukkel
Member
 
Registered: Mar 2003
Location: Belgium
Distribution: Hardened gentoo
Posts: 323

Rep: Reputation: 30
Ah ok its a surround thingy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some keys in keyboard do NOT work bmccorm2 Linux - Newbie 1 11-08-2005 10:16 AM
New keyboard with Volume keys, etc. vbguru12000 Debian 6 02-02-2005 10:13 AM
Will Microsoft Internet Keyboard Quick Keys work? Borg Swarm Linux - Hardware 3 05-05-2004 08:43 PM
Microsoft keyboard function keys don't work psilos Linux - Hardware 0 10-19-2003 12:01 PM
Logitech Elite Keyboard, F# keys don't work? jstn Linux - Hardware 4 05-21-2003 01:29 PM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration