LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-25-2009, 10:49 AM   #1
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Rep: Reputation: 32
Will a 'slackpkg upgrade-all overwrite my wireless config?


Hiya,
As the title says really. By wireless config i mean /etc/rc.d/rc.inet1.conf (i think - i'm a n00b i'm afraid).
During the upgrade, I was half expecting a message saying something like "this file has changed, do you want to overwrite, keep the old one, use the new one etc", as it did this the last time i updated, but it didn't. In fact it said "No .new files found." at the end of the process.
I will check the files tonight when i'm home from work, but was just wondering if anyone knew the answer the answer to this?

I'm guessing this means another few hours with alien bob's page about getting my wireless working again

Thank you again in advance,

mute
 
Old 08-25-2009, 10:58 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
If it hasn't asked, it's likely that it hasn't made any changes. Though, yes, definitely check when you get home and I would suggest keeping a "known good" copy somewhere in your /home directory in case it ever does get overwritten.
 
Old 08-25-2009, 11:01 AM   #3
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
No new files simply means it did not update any config files in /etc. You rc.inet1.conf should remain untouched.
 
Old 08-25-2009, 11:57 AM   #4
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
OOohh ok thanks both. I'm leaving for home now, so i'll check when i get back.

Thanks again,
mute
 
Old 08-25-2009, 12:36 PM   #5
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
i'm home, and now weirdly my wireless is working again. However, when i do a iwconfig as root, i get this:
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"NETGEAR"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1B:2F:76:99:32   
          Bit Rate=24 Mb/s   Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Power Management:off
          Link Quality=54/100  Signal level:-76 dBm  Noise level=-127 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
this does not reflect what's in my rc.inet1.conf:
Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=muteXeNet
WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
any ideas? does this mean as my wireless is working at the moment i'm leaching a neighbour's internet??

thanks,

mute
 
Old 08-25-2009, 12:48 PM   #6
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
oh and here's my wpa_supplicant file sorry:
Code:
# See /usr/doc/wpa_supplicant-0.5.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="muteXeNet"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk= my big wpa string is here
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
 
Old 08-25-2009, 01:25 PM   #7
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
You are definitely leeching. You don't need the wifi setting in your inet1.conf file since you already have them in the wpa_supplicant.conf file. Keeping it in one place minimize maintenance. You can remove everything after USE_DHCP[4]="yes".

As for your connection, add priority=99 to your network setting in wpa_supplicant.conf. This will give you network priority over free, unprotected networks.

Code:
# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="muteXeNet"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk= my big wpa string is here
  priority=99
}
 
Old 08-25-2009, 01:58 PM   #8
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
Cheers for the help mate. I made your changes, but unfortunately my iwconfig output remains the same, i.e. it's showing ESSID:"NETGEAR", when my wpa_supplicant file shows ssid="muteXeNet".

Would any errors be sent to any log files for me to have a look at?

Thanks again,

mute
 
Old 08-25-2009, 02:01 PM   #9
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
Did you restart wpa_supplicant? Run:
Code:
/etc/rc.d/rc.inet1 wlan0_restart
 
Old 08-25-2009, 02:07 PM   #10
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
i restarted my machine. would that have done it?

Code:
root@DELL01:~# /etc/rc.d/rc.inet1 wlan0_restart
/etc/rc.d/rc.inet1:  wlan0 information: 'Any ESSID'
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
Broadcasting DHCP_DISCOVER
broadcastAddr option is missing in DHCP server response. Assuming 192.168.0.255
dhcpIPaddrLeaseTime=86400 in DHCP server response.
dhcpT1value is missing in DHCP server response. Assuming 43200 sec
dhcpT2value is missing in DHCP server response. Assuming 75600 sec
DHCP_OFFER received from  (192.168.0.1)
Broadcasting DHCP_REQUEST for 192.168.0.26
dhcpIPaddrLeaseTime=86400 in DHCP server response.
dhcpT1value is missing in DHCP server response. Assuming 43200 sec
dhcpT2value is missing in DHCP server response. Assuming 75600 sec
DHCP_ACK received from  (192.168.0.1)
Broadcasting ARPOP_REQUEST for 192.168.0.26

Last edited by mutexe; 08-25-2009 at 02:10 PM. Reason: added output
 
Old 08-25-2009, 02:13 PM   #11
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
Restarting the pc should have done it. What is the result of:
Code:
iwlist wlan0 scan
Also, what's the mac for your access point?

Last edited by tux_dude; 08-25-2009 at 02:15 PM.
 
Old 08-25-2009, 02:16 PM   #12
mutexe
Member
 
Registered: May 2009
Location: Malvern, UK
Distribution: Slackware 13.0
Posts: 225

Original Poster
Rep: Reputation: 32
Code:
wlan0     Scan completed :
          Cell 01 - Address: 00:1B:2F:76:99:32
                    ESSID:"NETGEAR"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=52/100  Signal level:-77 dBm  Noise level=-127 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=000003dded046a19
                    Extra: Last beacon: 52ms ago
          Cell 02 - Address: 00:24:2B:CD:6B:44
                    ESSID:"BTHomeHub2-W2CC"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=42/100  Signal level:-84 dBm  Noise level=-127 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2D1A0C181AFFFF000000000000000000000000000000000000000000
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=000000459813a186
                    Extra: Last beacon: 1160ms ago
          Cell 03 - Address: 02:24:2B:CD:6B:45
                    ESSID:"BTOpenzone"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=42/100  Signal level:-84 dBm  Noise level=-127 dBm
                    Encryption key:off
                    IE: Unknown: 2D1A0C181AFFFF000000000000000000000000000000000000000000
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=000000459813ab81
                    Extra: Last beacon: 1156ms ago
          Cell 04 - Address: 02:24:2B:CD:6B:46
                    ESSID:"BTFON"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=43/100  Signal level:-83 dBm  Noise level=-127 dBm
                    Encryption key:off
                    IE: Unknown: 2D1A0C181AFFFF000000000000000000000000000000000000000000
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:tsf=000000459813b395
                    Extra: Last beacon: 1156ms ago
no idea what's going on. I feel very stupid i'm afraid
 
Old 08-25-2009, 02:21 PM   #13
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
There's your problem. You AP is not showing up. Looks like your wifi is down. Unless your ssid is not "muteXeNet".
 
Old 08-25-2009, 02:23 PM   #14
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
Quote:
Originally Posted by mutexe View Post
no idea what's going on. I feel very stupid i'm afraid
No need to be afraid. This is just scanning for the list of networks that are visible. Also "man" is your friend.
Code:
man iwlist
 
Old 08-25-2009, 02:23 PM   #15
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Did someone reset your router? If your router is calling itself "Netgear", it may have been reset or changed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error when using slackpkg to upgrade-all vdemuth Slackware 4 04-28-2009 05:02 PM
how to prevent overwrite particular config file when using rpm --replacefile option amit_pansuria Linux - General 2 07-17-2008 05:56 AM
Upgrade with slackpkg STARHARVEST Slackware 11 05-17-2008 07:07 PM
dist upgrade with slackpkg cb951303 Slackware 7 06-20-2005 08:59 PM
slackpkg upgrade _mu_ Slackware 9 01-29-2004 08:28 PM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration