LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-31-2013, 03:08 AM   #1
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Rep: Reputation: 30
WiFi with rc.inet1 script only


Slackkware 14 x86 installation
Wlan0 with "ath5k"

I can connect my Slackware 14 installation to my home WiFi (WPA and WPA2) with NetworkManager.
Because of my curiosity , I have disabled NetworkManager and tried to connect using /etc/rc.d/rc.inet1 script.

This is my:
/etc/rc.d/rc.inet1.conf
Code:
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]="MyHomeWiFi"
WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=MySecretPasswd"
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
/etc/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
With that configuration it doesnt work and apparently Im missing something.
Can anyone please help me figure out what is wrong in this config ?
 
Old 03-31-2013, 07:06 AM   #2
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
Hi there,

Your wpa_supplicant.conf file is missing a network block. At home my family uses a basic WPA2-PSK with an SSID, so my network blocked was created by using the wpa_passphrase command. Then it generates a network block for you which you can append to your /etc/wpa_supplicant.conf file:

Code:
wpa_passphrase "Home AP" "SuperSecretPassword" >> /etc/wpa_supplicant.conf
Here is the relevant information in my /etc/rc.d/rc.inet1.conf file:

Code:
# Config information for wlan0[1]:
IFNAME[1]="wlan0"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_KEEPRESOLV[1]="yes"
DHCP_HOSTNAME[1]=""
WLAN_ESSID[1]="Home AP"
WLAN_MODE[1]="Managed"
WLAN_WPA[1]="wpa_supplicant"
Also, don't be afraid to add more to the rc.inet1.conf file or the wpa_supplicant.conf file for more than one location. access point.

Code:
man wpa_supplicant.conf
Shows many other types of setups too beyond that of just a WEP/WPA/WPA2-PSK in case you run into those situations.
 
1 members found this post helpful.
Old 03-31-2013, 06:23 PM   #3
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 602

Original Poster
Rep: Reputation: 30
Hey Tommy, that works!
Thank you very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
script to connect to wifi with various configurations dgallig Slackware 3 07-03-2008 07:10 AM
Running a script to start WiFi on boot nanodano Linux - Hardware 3 11-06-2005 10:00 PM
rc.inet1 and rc.inet1.conf edafe Slackware 0 02-16-2005 10:51 AM
WiFi Problem: Host AP driver and rc.inet1 edafe Slackware 2 02-16-2005 10:18 AM
Slackware 8.1 rc.inet1 shell script problems matruschka Linux - Networking 3 07-22-2002 03:37 AM


All times are GMT -5. The time now is 09:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration