LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-10-2008, 05:33 AM   #1
ljubak
LQ Newbie
 
Registered: Apr 2006
Location: Belgrade, Serbia
Distribution: Slackware
Posts: 26

Rep: Reputation: 15
Question Wierd sound problem on ASUS F5SL based laptop


I have the following problem with sound on my ASUS F5SL based laptop.

The first time when I installed slackware, the sound worked with following hack:
options snd-hda-intel position_fix=1
added to /etc/modprobe.d/sound.

In the meantime i had to reinstall Slackware and now i have a problem. The sound no longer works with given hack?!!

I wonder if someone has an idea where to start with the analysis of this problem, or maybe an solution?
 
Old 12-10-2008, 05:47 AM   #2
ljubak
LQ Newbie
 
Registered: Apr 2006
Location: Belgrade, Serbia
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 15
I forgot to mention it is Slackware 12.1. And only thing that might be different from previous installation is running alsaconf before alsamixer (I can`t remember whether I did the same the first time).

One more thing, first time i did config with huge-smp kernel. Next time i did it with generic-smp kernel.

Last edited by ljubak; 12-10-2008 at 08:12 AM.
 
Old 12-10-2008, 08:25 AM   #3
agentc0re
Member
 
Registered: Apr 2007
Location: SLC, UTAH
Distribution: Slackware
Posts: 200

Rep: Reputation: 32
I believe that just because you've set options for snd-hda-intel doesn't mean that it's loaded as a module. I would check and make sure that it is. I bet if you switch to the huge-smp kernel it will work again.
 
Old 12-10-2008, 09:19 AM   #4
ljubak
LQ Newbie
 
Registered: Apr 2006
Location: Belgrade, Serbia
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by agentc0re View Post
I believe that just because you've set options for snd-hda-intel doesn't mean that it's loaded as a module. I would check and make sure that it is. I bet if you switch to the huge-smp kernel it will work again.
I agree, but lsmod seys that snd-hda-intel is present. Tried switching to huge kernel. Same thing again. Although I'm not sure that I did everything well. I used the following procedure:
1. alsaconf
2. edit /etc/modprobe.d/sound
3. alsamixer
4. alsactl store
5. restart alsa

I wonder if somthing was written to some configuration file besides /etc/.../sound during first setup (with generic kernel) that should be undone?
 
Old 12-10-2008, 11:53 AM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,252

Rep: Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631
You may need to pass an option to the snd-hda-intel module. See this post (or search for 'snd-hda-intel' in these forums for others -- I have posted in a lot of threads about sound cards, and I explained a possible solution better in some threads than in others). Note that the possible options for the snd-hda-intel module depend on your sound card. You should be able to see what chipset your sound card is with either
Code:
/sbin/lspci -vv
or
Code:
aplay -l
You should only need to try the options available for your chipset.
 
Old 12-10-2008, 04:58 PM   #6
ljubak
LQ Newbie
 
Registered: Apr 2006
Location: Belgrade, Serbia
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by T3slider View Post
You may need to pass an option to the snd-hda-intel module. See this post (or search for 'snd-hda-intel' in these forums for others -- I have posted in a lot of threads about sound cards, and I explained a possible solution better in some threads than in others). Note that the possible options for the snd-hda-intel module depend on your sound card. You should be able to see what chipset your sound card is with either
Code:
/sbin/lspci -vv
or
Code:
aplay -l
You should only need to try the options available for your chipset.
Thnx, I will check out this.

What's bugs me the most is it worked, now it doesn't
 
Old 12-10-2008, 06:29 PM   #7
ljubak
LQ Newbie
 
Registered: Apr 2006
Location: Belgrade, Serbia
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 15
I solved it! But it still confuses me.

The story goes like this:

After the first Slackware installation i added the following line to /etc/modprobe.d/cound:

Code:
options snd-hda-intel position_fix=1 model=lenovo
and it worked. After that I decided to check which parameters are necessary so I tried following:

Code:
options snd-hda-intel position_fix=1
and it worked again. So without any further investigation, I concluded that option model=lenovo is unnecessary. Following notes that I made after the first installation, after second installation i did:

Code:
options snd-hda-intel position_fix=1
and it didn't work, and you know the rest of the story. Finaly after trying model=lenovo again the sound works, but... Just to be sure I excluded model option and it works without it. Also I tried just model=lenovo without position_fix and it works!

Strange, isn't it?

Thank you guys.

Last edited by ljubak; 12-10-2008 at 06:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Realtek ALC880 sound card on ASUS A3AC laptop MadOldBloke Linux - Newbie 0 11-07-2008 06:39 AM
No sound, Asus VX1 Laptop - AD1986A BeePee007 Linux - Hardware 15 11-05-2007 08:58 AM
Sound problem with Kubuntu 6.06 on Asus laptop exman Ubuntu 2 08-07-2006 01:56 AM
Wierd sound problem ian_hopkins Linux - Software 0 12-11-2005 02:02 PM
Wierd Laptop Fan Problem Paul_assheton Linux - General 2 04-04-2002 01:03 AM


All times are GMT -5. The time now is 08:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration