LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   wicd wpa (http://www.linuxquestions.org/questions/slackware-14/wicd-wpa-756021/)

rssn6 09-17-2009 05:18 PM

wicd wpa
 
I have an issue regarding wicd (using 1.6.2.2).
At school they use wpa.
the configuration is
Code:

eapol_version=2
    ap_scan=1
    fast_reauth=1
    network={
          ssid="University"
          key_mgmt= WPA-EAP IEEE8021X
          eap=TTLS
          identity="yourNetname"
          password="yourPassword"
          phase2="auth=PAP"
    }

Therefore I created a template for wicd like this
Code:

    name = CONU
        author = rssn6
        version = 2

        require identity *Identity password *Password
        -----
        ctrl_interface=/var/run/wpa_supplicant
        eapol_version=2
        ap_scan=1
        fast_reauth=1
        network={
        ssid="$_ESSID"
        key_mgmt= WPA-EAP IEEE8021X
        eap=TTLS
        identity=$_IDENTITY
        password=$_PASSWORD
        phase2="auth=PAP"
        }

with some help from the wicd's forum.
But the problem is it doesn't work.
At wicd's forum there was no replies for while...

Please help me out.

jhwilliams 09-17-2009 09:43 PM

Yea I'll believe that, there were bugs even with nm-applet with IEEE8201X until just recently. I personally found that wicd sucked, and so my solution was to use nm-applet. It sucks a little bit too, but so long as you don't need VPN or anything like that, recent versions seem to have been sufficient.

BrZ 09-17-2009 10:46 PM

Look at /etc/wicd/encryption/templates, create a file named rssn6 (it will be 'your' template, name it at your pleasure), put your wpa_supplicant information directly on 'your' template, add 'your' template name to '/etc/wicd/encryption/templates/active'.

Try something like:

Quote:

author = rssn6
version = 2

require identity *Identity password *Password
-----
ctrl_interface=/var/run/wpa_supplicant
eapol_version=2
ap_scan=1
fast_reauth=1
network={
ssid="University"
key_mgmt= WPA-EAP IEEE8021X
eap=TTLS
identity=yourname
password=yourgeneratedpassword
phase2="auth=PAP"
}
Don't remember if you'll need to restart the daemon. You should have 'your' template listed. Try connecting. If it fails, enable verbose debug log (prefs/advsettings/enabledebuglog) and adjust 'your' template if needed, like adding quotes to name and password, etc.

rssn6 09-18-2009 11:23 PM

I will try this Monday and will post the result.

rssn6 09-22-2009 02:58 PM

I had the chance to test it and the error was present because the quotation marks should be applied in the user/password.


Code:


identity="$_IDENTITY"
password="$_PASSWORD"

the rest is good.
Thank you all for replying.


All times are GMT -5. The time now is 01:30 AM.