LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-07-2009, 11:31 PM   #1
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Rep: Reputation: 26
wicd won't let me use static ip on wireless card [SOLVED]


i'm having problems with wicd 1.5.9 in slackware 12.2

i have all dhcp disabled in every config file (even in inet1.conf just for good measure), and static ip addresses set up for both the wired card and the wireless card. when i hit the connect button for the wired connection, the message at the bottom of the wicd-client window says "Setting Static IP". when i click on a wireless network connect button, it says "obtaining IP address) and the wicd.log file has this in it for messages:

2009/06/07 21:07:52 :: Connecting to wireless network jed2
2009/06/07 21:07:52 :: Putting interface down
2009/06/07 21:07:52 :: ifconfig wlan0 down
2009/06/07 21:07:52 :: Releasing DHCP leases...
2009/06/07 21:07:52 :: Setting false IP...
2009/06/07 21:07:52 :: ifconfig wlan0 0.0.0.0
2009/06/07 21:07:52 :: ifconfig eth0 0.0.0.0
2009/06/07 21:07:52 :: Stopping wpa_supplicant and any DHCP clients
2009/06/07 21:07:52 :: killall wpa_supplicant
2009/06/07 21:07:52 :: Flushing the routing table...
2009/06/07 21:07:52 :: ip route flush dev wlan0
2009/06/07 21:07:52 :: ip route flush dev eth0
2009/06/07 21:07:52 :: Putting interface up...
2009/06/07 21:07:52 :: ifconfig wlan0 up
2009/06/07 21:07:52 :: iwconfig wlan0 mode managed
2009/06/07 21:07:52 :: ['iwconfig', 'wlan0', 'essid', 'jed2', 'channel', '6', 'ap', '00:23:69:56:3E:46']
2009/06/07 21:07:52 :: Running DHCP
2009/06/07 21:07:52 :: /sbin/dhclient wlan0
2009/06/07 21:07:52 :: Internet Systems Consortium DHCP Client V3.0.6
2009/06/07 21:07:52 :: Copyright 2004-2007 Internet Systems Consortium.
2009/06/07 21:07:52 :: All rights reserved.
2009/06/07 21:07:52 :: For info, please visit http://www.isc.org/sw/dhcp/
2009/06/07 21:07:52 ::
2009/06/07 21:07:52 :: wmaster0: unknown hardware address type 801
2009/06/07 21:07:53 :: wmaster0: unknown hardware address type 801
2009/06/07 21:07:53 :: Listening on LPF/wlan0/00:d0:41:b5:18:f3
2009/06/07 21:07:53 :: Sending on LPF/wlan0/00:d0:41:b5:18:f3
2009/06/07 21:07:53 :: Sending on Socket/fallback
2009/06/07 21:07:55 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
2009/06/07 21:07:56 :: iwconfig wlan0
2009/06/07 21:07:59 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
2009/06/07 21:08:08 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
2009/06/07 21:08:18 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
2009/06/07 21:08:38 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
2009/06/07 21:08:51 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
2009/06/07 21:08:56 :: No DHCPOFFERS received.
2009/06/07 21:08:56 :: No working leases in persistent database - sleeping.
2009/06/07 21:08:56 :: DHCP connection failed
2009/06/07 21:08:56 :: exiting connection thread


and so i had to resort to the wired interface which is working:

2009/06/07 21:09:00 :: iwlist wlan0 scan
2009/06/07 21:09:01 ::
2009/06/07 21:09:01 :: {}
2009/06/07 21:09:01 :: scanning done
2009/06/07 21:09:01 :: found 4 networks:
2009/06/07 21:09:01 :: 00:23:69:56:3E:46
2009/06/07 21:09:01 :: 00:1CF9:01:0D
2009/06/07 21:09:01 :: 00:22:3F3:A9:A8
2009/06/07 21:09:01 :: 00:1E:2A:75:14:C2
2009/06/07 21:09:01 :: Putting interface down
2009/06/07 21:09:01 :: ifconfig eth0 down
2009/06/07 21:09:01 :: Attempting to autoconnect with wired interface...
2009/06/07 21:09:01 :: Releasing DHCP leases...
2009/06/07 21:09:01 :: Setting false IP...
2009/06/07 21:09:01 :: ifconfig wlan0 0.0.0.0
2009/06/07 21:09:01 :: ifconfig eth0 0.0.0.0
2009/06/07 21:09:01 :: Stopping wpa_supplicant and any DHCP clients
2009/06/07 21:09:01 :: killall wpa_supplicant
2009/06/07 21:09:01 :: Flushing the routing table...
2009/06/07 21:09:01 :: ip route flush dev wlan0
2009/06/07 21:09:01 :: ip route flush dev eth0
2009/06/07 21:09:01 :: Putting interface up...
2009/06/07 21:09:01 :: ifconfig eth0 up
2009/06/07 21:09:01 :: Setting static IP : 192.168.0.9
2009/06/07 21:09:01 :: ifconfig eth0 192.168.0.9 netmask 255.255.255.0
2009/06/07 21:09:01 :: Setting default gateway : 192.168.0.1
2009/06/07 21:09:01 :: route add default gw 192.168.0.1 dev eth0
2009/06/07 21:09:01 :: Executing post-connection script
2009/06/07 21:09:03 :: iwconfig wlan0
2009/06/07 21:09:04 :: iwconfig wlan0
2009/06/07 21:09:10 :: Connecting thread exiting.
2009/06/07 21:09:10 :: ifconfig eth0
2009/06/07 21:09:10 :: IP Address is: 192.168.0.9



here's the etc/wicd/wired-settings.conf:

[wired-default]
afterscript = /etc/rc.d/rc.inet1
broadcast = None
dns3 = None
ip = 192.168.0.9
dns1 = 205.171.3.65
use_static_dns = False
default = True
netmask = 255.255.255.0
dns2 = 205.171,2,65
beforescript = None
disconnectscript = None
gateway = 192.168.0.1
use_global_dns = False


here's the wireless-settings.conf:

[wireless-default]
bssid + 00:23:69:56:3e:45
afterscript = None
broadcast = 192.168.0.255
mode = Master
automatic = True
channel = 6
dns3 = None
ip = 192.168.0.29
dns1 = 205.171.3.65
use_static_dns = True
default = True
netmask = 255.255.255.0
dns2 = 205.171,2,65
beforescript = None
disconnectscript = None
gateway = 192.168.0.1
use_global_dns = True


and the manager-settings.conf:

[Settings]
wireless_interface = wlan0
link_detect_tool = 1
flush_tool = 0
signal_display_type = 1
dhcp_client = 0
window_height = 400
wired_connect_mode = 1
pref_width = 491
wired_interface = eth0
wpa_driver = ralink legacy
debug_mode = 1
pref_height = 590
global_dns_1 = 205.171.3.65
global_dns_2 = 205.171.2.65
global_dns_3 = 205.171.3.25
use_global_dns = True
window_width = 605
always_show_wired_interface = True
auto_reconnect = True


and as i said, i even set the inet1.conf settings, just to be sure:


# Config information for eth0:
IPADDR[0]="192.168.0.9"
NETMASK[0]="255.255.255.0"
DHCP_HOSTNAME[0]=""



IFNAME[4]="wlan0"
IPADDR[4]="192.168.0.29"
NETMASK[4]="255.255.255.0"
GATEWAY[4]="192.168.0.1"
USE_DHCP[4]=""
#DHCP_HOSTNAME[4]=""
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]="jed2"
WLAN_MODE[4]="auto"
WLAN_RATE[4]="auto"
WLAN_CHANNEL[4]="6"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set ##WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"



i am running a network with static IP's and the wireless card is a RaLink RT2561. the card is there and wicd lists 4 and sometimes 5 access points and their signal strengths and MAC addresses, so i know the radio works. i can also ping my access point at 192.168.0.1, but cannot ping any of the DNS servers (after opening a term window and doing : ifconfig wlan0 192.168.0.29 and ifconfig wlan0 up)

why, if i have turned DHCP off in the config files, does wicd still tell the wireless card to do a DHCP request?

Last edited by unclejed613; 06-09-2009 at 01:10 AM.
 
Old 06-07-2009, 11:47 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
If you use wicd, you must have an unedited /etc/rc.d/rc.inet1.conf file.
 
Old 06-07-2009, 11:54 PM   #3
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Original Poster
Rep: Reputation: 26
so i should comment out all of the wireless settings in rc.inet1.conf?

just tried it..... still tries to do a dhcp request when i try connecting the wireless. it's got to be something buried in wicd somewhere. or another .conf file i haven't found yet.


also, what's this wmaster0 interface? i haven't seen it before i installed the wireless card and started trying to get it to work.

Last edited by unclejed613; 06-08-2009 at 12:02 AM.
 
Old 06-07-2009, 11:56 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
No, you should return the file to it's original state.
 
Old 06-08-2009, 12:08 AM   #5
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Original Poster
Rep: Reputation: 26
when i do a ifconfig wmaster0 down wlan0 no longer shows up when i do a ifconfig. if i do ifconfig wlan0 up, the wmaster0 comes back up..... it's a side effect, there's a ghost in the machine
 
Old 06-08-2009, 12:11 AM   #6
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Original Poster
Rep: Reputation: 26
ok, returned to original state, with even the eth0 settings returned to ""

nope, no changes...
 
Old 06-08-2009, 12:17 AM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Did you restart the wicd daemon? Might need to stop some
interfaces, also. Just reboot and it will all get done.

Since we don't see the contents of /etc/rc.d/rc.inet1.conf
it's rather difficult to tell if it's correct. Here's the
proper contents from Slackware-12.2:
Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
You can save that as something like original.rc.inet1.conf and then check it
against yours by running "diff -y /etc/rc.d/rc.inet1.conf original.rc.inet1.conf"

Please use code tags like that when you post output, so that
it's easier to read, and the little smiley icons go away.
 
Old 06-08-2009, 12:43 AM   #8
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Original Poster
Rep: Reputation: 26
nope.... reboot brought no change. something somewhere is calling dhcpcd and there's no way to stop it.


here's the /var/log/wicd/wicd.log up to the point where i went back to the wired card after trying the wireless card again.

Code:
2009/06/07 22:35:07 :: ---------------------------
2009/06/07 22:35:07 :: wicd initializing...
2009/06/07 22:35:07 :: ---------------------------
2009/06/07 22:35:07 :: Automatically detected wireless interface wlan0
2009/06/07 22:35:07 :: found wireless_interface in configuration wlan0
2009/06/07 22:35:07 :: setting wireless interface wlan0
2009/06/07 22:35:07 :: automatically detected wired interface eth0
2009/06/07 22:35:07 :: found wired_interface in configuration eth0
2009/06/07 22:35:07 :: setting wired interface eth0
2009/06/07 22:35:07 :: found wpa_driver in configuration ralink legacy
2009/06/07 22:35:07 :: setting wpa driver ralink legacy
2009/06/07 22:35:07 :: found always_show_wired_interface in configuration True
2009/06/07 22:35:07 :: found use_global_dns in configuration True
2009/06/07 22:35:07 :: setting use global dns to True
2009/06/07 22:35:07 :: setting use global dns to boolean True
2009/06/07 22:35:07 :: found global_dns_1 in configuration 205.171.3.65
2009/06/07 22:35:07 :: found global_dns_2 in configuration 205.171.2.65
2009/06/07 22:35:07 :: found global_dns_3 in configuration 205.171.3.25
2009/06/07 22:35:07 :: setting global dns
2009/06/07 22:35:07 :: global dns servers are 205.171.3.65 205.171.2.65 205.171.3.25
2009/06/07 22:35:07 :: found auto_reconnect in configuration True
2009/06/07 22:35:07 :: setting automatically reconnect when connection drops
2009/06/07 22:35:07 :: found debug_mode in configuration 1
2009/06/07 22:35:07 :: found wired_connect_mode in configuration 1
2009/06/07 22:35:07 :: found signal_display_type in configuration 1
2009/06/07 22:35:07 :: found dhcp_client in configuration 0
2009/06/07 22:35:07 :: Setting dhcp client to 0
2009/06/07 22:35:07 :: found link_detect_tool in configuration 1
2009/06/07 22:35:07 :: found flush_tool in configuration 0
2009/06/07 22:35:07 :: Wireless configuration file found...
2009/06/07 22:35:07 :: Wired configuration file found...
2009/06/07 22:35:07 :: chmoding configuration files 0600...
2009/06/07 22:35:07 :: chowning configuration files root:root...
2009/06/07 22:35:07 :: Using wired interface...eth0
2009/06/07 22:35:07 :: Using wireless interface...wlan0
2009/06/07 22:35:07 :: autoconnecting... wlan0
2009/06/07 22:35:07 :: scanning start
2009/06/07 22:35:07 :: ifconfig wlan0 up
2009/06/07 22:35:16 :: iwlist wlan0 scan
2009/06/07 22:35:17 :: 
2009/06/07 22:35:17 :: {}
2009/06/07 22:35:17 :: scanning done
2009/06/07 22:35:17 :: found 4 networks:
2009/06/07 22:35:17 :: 00:23:69:56:3E:46
2009/06/07 22:35:17 :: 00:1C:DF:D9:01:0D
2009/06/07 22:35:17 :: 00:22:3F:D3:A9:A8
2009/06/07 22:35:17 :: 00:1E:2A:75:14:C2
2009/06/07 22:35:17 :: ifconfig eth0 up
2009/06/07 22:35:19 :: Putting interface down
2009/06/07 22:35:19 :: ifconfig eth0 down
2009/06/07 22:35:19 :: Attempting to autoconnect with wired interface...
2009/06/07 22:35:19 :: Releasing DHCP leases...
2009/06/07 22:35:20 :: Setting false IP...
2009/06/07 22:35:20 :: ifconfig wlan0 0.0.0.0 
2009/06/07 22:35:20 :: ifconfig eth0 0.0.0.0 
2009/06/07 22:35:20 :: Stopping wpa_supplicant and any DHCP clients
2009/06/07 22:35:20 :: killall wpa_supplicant
2009/06/07 22:35:20 :: Flushing the routing table...
2009/06/07 22:35:20 :: ip route flush dev wlan0
2009/06/07 22:35:20 :: ip route flush dev eth0
2009/06/07 22:35:20 :: Putting interface up...
2009/06/07 22:35:20 :: ifconfig eth0 up
2009/06/07 22:35:20 :: Setting static IP : 192.168.0.9
2009/06/07 22:35:20 :: ifconfig eth0 192.168.0.9 netmask 255.255.255.0 
2009/06/07 22:35:21 :: Setting default gateway : 192.168.0.1
2009/06/07 22:35:21 :: route add default gw 192.168.0.1 dev eth0
2009/06/07 22:35:21 :: Executing post-connection script
2009/06/07 22:35:25 :: Connecting thread exiting.
2009/06/07 22:35:25 :: ifconfig eth0
2009/06/07 22:35:25 :: IP Address is: 192.168.0.9
2009/06/07 22:35:27 :: ifconfig eth0
2009/06/07 22:35:27 :: ifconfig eth0
2009/06/07 22:35:31 :: ifconfig eth0
2009/06/07 22:35:35 :: ifconfig eth0
2009/06/07 22:35:39 :: ifconfig eth0
2009/06/07 22:35:43 :: ifconfig eth0
2009/06/07 22:35:47 :: ifconfig eth0
2009/06/07 22:35:51 :: ifconfig eth0
2009/06/07 22:35:55 :: ifconfig eth0
2009/06/07 22:35:59 :: ifconfig eth0
2009/06/07 22:36:03 :: ifconfig eth0
2009/06/07 22:36:07 :: ifconfig eth0
2009/06/07 22:36:11 :: ifconfig eth0
2009/06/07 22:36:15 :: ifconfig eth0
2009/06/07 22:36:19 :: ifconfig eth0
2009/06/07 22:36:23 :: ifconfig eth0
2009/06/07 22:36:24 :: iwconfig wlan0
2009/06/07 22:36:24 :: iwconfig wlan0
2009/06/07 22:36:24 :: iwconfig wlan0
2009/06/07 22:36:24 :: iwconfig wlan0
2009/06/07 22:36:24 :: iwconfig wlan0
2009/06/07 22:36:26 :: ifconfig eth0
2009/06/07 22:36:27 :: ifconfig eth0
2009/06/07 22:36:27 :: Connecting to wireless network jed2
2009/06/07 22:36:27 :: Putting interface down
2009/06/07 22:36:27 :: ifconfig wlan0 down
2009/06/07 22:36:27 :: Releasing DHCP leases...
2009/06/07 22:36:27 :: Setting false IP...
2009/06/07 22:36:27 :: ifconfig wlan0 0.0.0.0 
2009/06/07 22:36:27 :: ifconfig eth0 0.0.0.0 
2009/06/07 22:36:27 :: Stopping wpa_supplicant and any DHCP clients
2009/06/07 22:36:27 :: killall wpa_supplicant
2009/06/07 22:36:27 :: Flushing the routing table...
2009/06/07 22:36:27 :: ip route flush dev wlan0
2009/06/07 22:36:27 :: ip route flush dev eth0
2009/06/07 22:36:27 :: Putting interface up...
2009/06/07 22:36:27 :: ifconfig wlan0 up
2009/06/07 22:36:27 :: iwconfig wlan0 mode managed
2009/06/07 22:36:27 :: ['iwconfig', 'wlan0', 'essid', 'jed2', 'channel', '6', 'ap', '00:23:69:56:3E:46']
2009/06/07 22:36:27 :: Running DHCP
2009/06/07 22:36:27 :: /sbin/dhclient wlan0
2009/06/07 22:36:27 :: Internet Systems Consortium DHCP Client V3.0.6
2009/06/07 22:36:27 :: Copyright 2004-2007 Internet Systems Consortium.
2009/06/07 22:36:27 :: All rights reserved.
2009/06/07 22:36:27 :: For info, please visit http://www.isc.org/sw/dhcp/
2009/06/07 22:36:27 :: 
2009/06/07 22:36:27 :: wmaster0: unknown hardware address type 801
2009/06/07 22:36:29 :: wmaster0: unknown hardware address type 801
2009/06/07 22:36:29 :: Listening on LPF/wlan0/00:d0:41:b5:18:f3
2009/06/07 22:36:29 :: Sending on   LPF/wlan0/00:d0:41:b5:18:f3
2009/06/07 22:36:29 :: Sending on   Socket/fallback
2009/06/07 22:36:31 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
2009/06/07 22:36:31 :: iwconfig wlan0
2009/06/07 22:36:31 :: iwconfig wlan0
2009/06/07 22:36:35 :: iwconfig wlan0
2009/06/07 22:36:35 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
2009/06/07 22:36:39 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
2009/06/07 22:36:39 :: iwconfig wlan0
2009/06/07 22:36:42 :: canceling connection attempt
2009/06/07 22:36:42 :: DHCP connection failed
2009/06/07 22:36:42 :: exiting connection thread
2009/06/07 22:36:43 :: ifconfig eth0
2009/06/07 22:36:43 :: ifconfig wlan0
2009/06/07 22:36:43 :: returning automatically reconnect when connection drops True
2009/06/07 22:36:43 :: iwconfig wlan0
2009/06/07 22:36:43 :: ifconfig eth0
2009/06/07 22:36:43 :: ifconfig wlan0
2009/06/07 22:36:44 :: ifconfig eth0
2009/06/07 22:36:44 :: ifconfig wlan0
2009/06/07 22:36:45 :: ifconfig eth0
2009/06/07 22:36:45 :: ifconfig wlan0
2009/06/07 22:36:46 :: ifconfig eth0
2009/06/07 22:36:46 :: ifconfig wlan0
2009/06/07 22:36:47 :: ifconfig eth0
2009/06/07 22:36:47 :: ifconfig wlan0
2009/06/07 22:36:47 :: returning automatically reconnect when connection drops True
2009/06/07 22:36:47 :: ifconfig eth0
2009/06/07 22:36:47 :: ifconfig wlan0
2009/06/07 22:36:47 :: Putting interface down
2009/06/07 22:36:47 :: ifconfig eth0 down
2009/06/07 22:36:47 :: Releasing DHCP leases...
2009/06/07 22:36:47 :: Setting false IP...
2009/06/07 22:36:48 :: ifconfig wlan0 0.0.0.0 
2009/06/07 22:36:48 :: ifconfig eth0 0.0.0.0 
2009/06/07 22:36:48 :: Stopping wpa_supplicant and any DHCP clients
2009/06/07 22:36:48 :: killall wpa_supplicant
2009/06/07 22:36:48 :: Flushing the routing table...
2009/06/07 22:36:48 :: ip route flush dev wlan0
2009/06/07 22:36:48 :: ip route flush dev eth0
2009/06/07 22:36:48 :: Putting interface up...
2009/06/07 22:36:48 :: ifconfig eth0 up
2009/06/07 22:36:48 :: Setting static IP : 192.168.0.9
2009/06/07 22:36:48 :: ifconfig eth0 192.168.0.9 netmask 255.255.255.0 
2009/06/07 22:36:48 :: Setting default gateway : 192.168.0.1
2009/06/07 22:36:48 :: route add default gw 192.168.0.1 dev eth0
2009/06/07 22:36:48 :: Executing post-connection script
2009/06/07 22:36:50 :: Connecting thread exiting.
2009/06/07 22:36:50 :: ifconfig eth0
2009/06/07 22:36:50 :: IP Address is: 192.168.0.9
2009/06/07 22:36:51 :: ifconfig eth0
2009/06/07 22:36:51 :: iwconfig wlan0
2009/06/07 22:36:51 :: ifconfig eth0
2009/06/07 22:36:52 :: ifconfig eth0
2009/06/07 22:36:53 :: ifconfig eth0
 
Old 06-08-2009, 06:57 PM   #9
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Original Poster
Rep: Reputation: 26
ok, just to see whether it would work, i temporarily turned on the DHCP server on the router....... now it connects up no problem. so why can't i set a static ip for it? i'm going to post on wicd.org's forum as well, if i get an answer there, i'll post it here as an FYI. if i get an answer here, i'll post it there.....
 
Old 06-09-2009, 01:07 AM   #10
unclejed613
Member
 
Registered: Mar 2009
Posts: 326

Original Poster
Rep: Reputation: 26
solution to the problem!!!!!!!!

there are hidden config buttons that are accessible by clicking the small arrow just above the connect buttons. this brings up configuration buttons for each network.

Code:
Did you edit wireless-settings.conf by hand?  You need to open up the GUI and edit the properties for the specific network you're trying to connect to (in this case it looks like jed2).  That'll save an entry in wireless-settings.conf with the bssid of that network.  The [wireless-default] entry doesn't do anything, profiles like that are only used for wired networks.

Code:
ah! found it. by clicking on the arrow above the connect/disconnect button, the preferences for that network came up...... now it works, and connects immediately. tnx..... i guess i needed a tiny bit of info to get there...... one last question, if i were to remove the rc.inet1 script from the afterscript parameter, that shouldn't change anything, should it? from what i've seen, inet1 conflicts with wicd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn wireless card off with wicd grissiom Slackware 10 10-08-2010 03:36 PM
Wicd / wireless can't get IP address Innervision Slackware 23 06-05-2009 12:29 PM
Cannot connect to wireless network with wicd on Zenwalk Kenny_C Linux - Wireless Networking 1 04-07-2009 03:11 PM
Does wicd support multiple connections (one wired and one wireless)? guanx Slackware 2 03-22-2009 06:03 AM
LXer: Managing wireless connections seamlessly with wicd LXer Syndicated Linux News 1 07-31-2007 06:10 PM


All times are GMT -5. The time now is 06:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration