LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-20-2017, 11:46 AM   #1
igadoter
Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: slackware 12.2, scientific linux 6.4, knoppix 7.2, salix 14.1
Posts: 910

Rep: Reputation: Disabled
wicd does not allow eth and wlan being up


It is true. When I rising up wired interface wicd is putting down wifi interface. And vice versa. No idea what to do. I tried to manage with wicd client applet, but I can not figure out configuration for both eth and wlan being up.
 
Old 04-20-2017, 01:41 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,589

Rep: Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842
Works as designed...
 
Old 04-20-2017, 03:40 PM   #3
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,223

Rep: Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710
Quote:
Originally Posted by igadoter View Post
It is true. When I rising up wired interface wicd is putting down wifi interface. And vice versa. No idea what to do. I tried to manage with wicd client applet, but I can not figure out configuration for both eth and wlan being up.
I would disable wicd and configure the two interfaces in rc.inet1.conf instead.

See here to configure your wireless network in rc.inet1.conf. Don't use the old method - rc.wireless.conf.

I've been following a thread on the Scientific Linux forum about Network Manager, specifically its command-line interface nmcli. It seems to have been giving these enterprise Linux admins numerous headaches. (Not the fault of Scientific Linux, of course.)

I doubt that the wicd developer is as useless as the Red Hat developers who put NM together but sometimes it's much easier to do things the way they were intended to be done, without all the garbage on top. That's why Slackware lets you configure your system the hard way, which nearly always ends up the easy way.
 
2 members found this post helpful.
Old 04-21-2017, 07:41 AM   #4
igadoter
Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: slackware 12.2, scientific linux 6.4, knoppix 7.2, salix 14.1
Posts: 910

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Works as designed...
Had no idea. But Network Manager can keep both interfaces, does it?
 
Old 04-21-2017, 08:22 AM   #5
igadoter
Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: slackware 12.2, scientific linux 6.4, knoppix 7.2, salix 14.1
Posts: 910

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Gerard Lally View Post
That's why Slackware lets you configure your system the hard way, which nearly always ends up the easy way.
Well said. Great motto for Slackware. Maybe we should ask Volkerdi to put in some visible place. Let good news spread all the world. I think so. I am as husband (or wife) which always come back.
 
Old 04-21-2017, 05:06 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,589

Rep: Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842Reputation: 3842
Quote:
Originally Posted by igadoter View Post
Had no idea. But Network Manager can keep both interfaces, does it?
Yep.
 
Old 04-22-2017, 07:10 AM   #7
igadoter
Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: slackware 12.2, scientific linux 6.4, knoppix 7.2, salix 14.1
Posts: 910

Original Poster
Rep: Reputation: Disabled
I configured network vi /etc/rc.d/rc.inet1.conf there is issue however. Computer always boots with hardware lock for wifi, I managed this by setting in rc.local
Code:
rfkill unblock all
but it does not work with script /etc/rc.d/rc.inet1 cause this script is executed earlier than rc.local, so during execution wifi is locked by hardware and cannot be raised by rc.inet1. What is elegant solution? I mean something different than hacking rc.inet1. What comes to my mind is to set in rc.local
Code:
rfkill unblock all
/etc/rc.d/rc.inet2 wlan2_restart
but is inot very elegant. I mean to start twice the same interface during boot. It should be enough only one attempt.
Wicd is also causing troubles. Even if I changed /etc/rc.d/rc.wicd to non-executable wicd anyway starts.

The last issue solved. It was due to desktop settings.

Last edited by igadoter; 04-26-2017 at 01:12 PM.
 
Old 04-22-2017, 09:57 AM   #8
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,108

Rep: Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079Reputation: 2079
You could add the rfkill command before rc.inet1 is called in /etc/rc.d/rc.M

In 14.2, you'd want to add it before line 97. Or, actually, you could add it in the if/then statement for rc.inet1 so it is run only when rc.inet1 is run (not that it likely matters).
 
Old 04-26-2017, 12:17 PM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 4,370
Blog Entries: 7

Rep: Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815
Although not ideal, sometimes replacing rc.inet1 with an implementation of your own is the cleanest approach.

I'm currently trying this out on a wifi only laptop:
/etc/rc.d/rc.inet1:
Code:
#!/bin/sh

case "${1:-start}" in
        start)  ip -batch - <<-EOF
                        address flush dev lo
                        address add 127.0.0.1 dev lo
                        link set lo up
                EOF

                if [ ! -e /var/run/wpa_supplicant/wlan0 ]; then
                        iw reg set GB
                        wpa_supplicant -B -c /etc/wpa_supplicant/wlan0.conf -i wlan0 >/dev/null
                fi
                dhcpcd -q -b -L -M wlan0
                ;;
        stop)   dhcpcd -q -k
                ip link set wlan0 down
                if [ -e /var/run/wpa_supplicant/wlan0 ]; then 
                        /usr/sbin/wpa_cli -i wlan0 terminate >/dev/null
                        # Note: PATH doesn't contain /usr/sbin/ when invoked from rc.6
                        # so we have to use the fullpath to wpa_cli here.
                fi
                ;;
esac
If you were to try something like this you could stick your rfkill command in where I've got the 'iw reg set'.


Before this, I was using a wpa_cli "action" script to run dhclient when supplicant connected, which also seemed to be working well, but I wanted to try out dhcpcd's 'master' mode to see if it worked any better this way.

I've never had need of a front end like wicd or network-mangler. The underlying components seem to work just fine without them once you learn to use them, but maybe that's because my needs are pretty simple.

Last edited by GazL; 04-26-2017 at 12:19 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change wlan name to eth ocsev Linux - Newbie 3 06-11-2012 04:13 PM
eth -> wlan and vice versa issues ravedog Linux - Networking 2 10-14-2011 01:55 AM
wlan to eth bridge Jaws21 Linux - Networking 0 08-22-2008 04:25 AM
which eth# or wlan# is connected? adamruss Linux - Hardware 4 03-14-2008 04:13 PM
wlan instead of eth jimjamjahaa Linux - Wireless Networking 2 06-12-2005 02:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration