LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-12-2011, 10:01 PM   #1
ecoslacker
LQ Newbie
 
Registered: Feb 2011
Location: Mexico
Distribution: Slackware
Posts: 17

Rep: Reputation: 0
Wicd Connection Failed: Unable to Gei IP Address in Slackware 13.37


Hello

I'm using Slackware 13.37 and installed Wicd from the Slack DVD with the instructions in the README file but I don't know how to remove any references to interfaces from /etc/rc.d/rc.inet1.conf.
Anyway Wicd runs and the scan get several wifi networks so when I try connecting to wifi network it get this:

Connection Failed:Unable to Gei IP Address

The authentication is perfect and I can get a successful connection to wifi doing this:

bash-4.1# ifconfig wlan0 up
bash-4.1# iwconfig wlan0 essid INFINITUM0000 key 0000000000 channel 3
bash-4.1# dhclient wlan0
but ONLY doing this two times or more!!

I try to change the DHCP client in the options of Wicd to Automatic and dhcpcd... dhclient was default and nothing happens. I don't know if I need edit the file /etc/rc.d/rc.inet1.conf or what?
Using WEP, in the options Route Table Flushing> Automatic, Graphical Sudo Ap> kdesu and WPA supplicant driver> wext

Thanks...
 
Old 06-13-2011, 01:12 AM   #2
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Rep: Reputation: 31
I have not found the answer to this problem, but I can confirm that I have experienced it too. I have really disabled wicd now and am just relying on a series of iwconfig and dhcpcs commands similar to those you posted.

wicd seems to work best for me when I am in some new wifi environment (airport, train etc) when it seems to ususlly connect well. But here at home, where it used to connect easily it now always seems to have the "cannot get IP address" problem.

Advice has been frequently posted that if you want to use wicd you not modify any of the other network conf files - so playing with rc.inet1.conf would seem to be exactly the wrong thing to do. However, as mentioned I am not a good person to give advice on this since I have not been able to fix it for myself...
 
Old 06-13-2011, 07:27 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,201
Blog Entries: 3

Rep: Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427
Hi,

Just return the '/etc/rc.d/rc.inet1.conf' file to the original state or make sure that all device references/assignments are commented out within '/etc/rc.d/rc.inet1.conf'.
 
Old 06-13-2011, 04:47 PM   #4
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Rep: Reputation: 31
@Onebuck - At the risk of sounding really stupid - does that include the place where you define IFNAME[4]="wlan0" - I thought that this one entry should still be there as this sets up a wlan0 for wicd to use. Does wicd set this up itself ?
 
Old 06-14-2011, 08:43 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,201
Blog Entries: 3

Rep: Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427Reputation: 1427
Hi,

Quote:
Originally Posted by bogzab View Post
@Onebuck - At the risk of sounding really stupid - does that include the place where you define IFNAME[4]="wlan0" - I thought that this one entry should still be there as this sets up a wlan0 for wicd to use. Does wicd set this up itself ?
Doesn't sound 'stupid' to me!
'wicd' will use 'wicd.conf' file. There is a known potential conflict when '/etc/rc.d/rc.inet1.conf' is setup either manually or via 'netconfig'. That is why it is recommended to have '/etc/rc.d/rc.inet1.conf' set to the original state when using 'wicd';
Quote:
excerpt from '/etra/wicd/README.Slackware';
After installing this package, make sure the /etc/rc.d/rc.wicd
script is executable; if necessary, do:
chmod +x /etc/rc.d/rc.wicd

Results have varied, but you will probably need/want to remove
any references to interfaces from /etc/rc.d/rc.inet1.conf - in
other words, make that file look as if netconfig has never been
run.


When you start X, you should see a wicd icon in the system tray;
click on it to open the gui interface and configure as desired.
Your user account will need to be a member of the 'netdev' group
in order to use wicd.

Note that urwid will need to be installed if you want to use the
curses client.

Also, if you don't have kde installed, you won't have a graphical
sudo client available; you might wish to consider ktsuss from
SlackBuilds.org.
Plus do not forget;
Quote:
excerpt from 13.37 CHANGES_AND_HINTS.TXT
3. User accounts with permission to use network devices, such as with the wicd package in /extra, should be in the "netdev" group.
HTH!
 
Old 06-14-2011, 10:35 AM   #6
ecoslacker
LQ Newbie
 
Registered: Feb 2011
Location: Mexico
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
Wink

Ok I read the file README.SLACKWARE and doing almost everything but really I don't know how to do this: "to remove any references to interfaces from /etc/rc.d/rc.inet1.conf - in other words, make that file look as if netconfig has never been run."

Maybe that is the solution, and I really need help to do this... thanks to everyone.
 
Old 06-14-2011, 10:54 AM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,029
Blog Entries: 52

Rep: Reputation: Disabled
Open it as root, then select and delete everything relevant:
Code:
kdesu kwrite /etc/rc.d/rc.inet1.conf

Last edited by brianL; 06-14-2011 at 10:55 AM.
 
Old 06-14-2011, 04:03 PM   #8
Ignotum Per Ignotius
Member
 
Registered: Sep 2009
Location: Wales, UK
Distribution: Slackware
Posts: 67
Blog Entries: 1

Rep: Reputation: 40
Quote:
Originally Posted by eddojh View Post
Ok I read the file README.SLACKWARE and doing almost everything but really I don't know how to do this: "to remove any references to interfaces from /etc/rc.d/rc.inet1.conf - in other words, make that file look as if netconfig has never been run."
Hi there @eddojh.

...I've just installed 13.37 myself and finally got my old b43 wireless card working --- using wicd (after faffing around unsatisfactorily with iwconfig, rc.inet1.conf etc.). It was a breeze. Prior to installing and running wicd I returned my rc.inet1.conf to its original state --- here's what it should look like...

Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IFNAME[1]=""
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
You can copy the contents of the above window and simply save it as (or paste it over) /etc/rc.d/rc.inet1.conf --- then install wicd (if you haven't already done so), and run it (the wicd daemon will run automatically when you boot up).

Good luck!
 
Old 06-14-2011, 04:21 PM   #9
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 509

Rep: Reputation: Disabled
I have experienced the same problem as the OP, with rc.inet1.conf in its original state. It happens with one of the wifi cards I own but not with a second one, and I haven't investigated the problem yet, so I have no idea what's causing the problem.
 
Old 07-04-2011, 02:32 PM   #10
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
I had the same with a WEP hotel network. I changed "WEP Passphase" to "WEP Shared/restricted" then it worked. (I'm using Intel 2915ABG card.)

Last edited by guanx; 07-05-2011 at 02:07 PM.
 
Old 07-04-2011, 02:50 PM   #11
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 48
For what it is worth, I just did a fresh install of Slackware 13.37 (and did not fiddle with any config files as that is beyond me) and then installed Wicd from the DVD - I had to set the encryption to: WEP (HEX[0-9/A-F]) and enter my key.

It works fine.
 
Old 07-05-2011, 02:03 AM   #12
linuxs64
Member
 
Registered: Jun 2010
Posts: 93

Rep: Reputation: 39
Encountered the exact problem, using manual ip address solved it.

To achieve "return the '/etc/rc.d/rc.inet1.conf' file to the original state", do NOT choose to configure the network during slackware setup during system installation.
 
Old 07-05-2011, 09:39 AM   #13
prol
Member
 
Registered: May 2008
Posts: 47

Rep: Reputation: 18
What wireless card do you have? I had this problem, too. It was to do with the broadcom-sta driver. I had to reload the driver each time I reconnected.

I don't use wicd anymore, just do a directly through wpa_supplicant and dhcpcd.

Last edited by prol; 07-05-2011 at 09:41 AM.
 
Old 07-17-2011, 04:15 AM   #14
iphigenie
Member
 
Registered: Aug 2009
Location: IDLE, UK
Distribution: Slackware
Posts: 30

Rep: Reputation: 9
Talking

Quote:
Originally Posted by prol View Post
What wireless card do you have? I had this problem, too. It was to do with the broadcom-sta driver. I had to reload the driver each time I reconnected.

I don't use wicd anymore, just do a directly through wpa_supplicant and dhcpcd.
Interestingly enough on my HP2133 which has a broadcom card, ended up removing wicd and using iwconfig / wpa_gui (i find having to generate encoded keys just 1 step too much on the command line, wpa_gui does it for me)

For years I had to faff about with the broadcom drivers with quite a lot of trial and error - but with 13.37 it just worked - from the command line, but not wicd. All in all it is better than the times where it didnt work from the command line but only from wicd
 
Old 07-17-2011, 09:55 AM   #15
prol
Member
 
Registered: May 2008
Posts: 47

Rep: Reputation: 18
I have a broadcom card too. What you need to do is reload the kernel module. For me, its
rmmod wl
modprobe wl

and then it connects. You have to do it each time you reconnect to your network. To automate this, put the above to lines in a bash script and put it in the directory "/etc/wicd/scripts/preconnect/".

Hope it helps.
 
  


Reply

Tags
wicd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wicd unable to get ip address Ehlyah Linux - Wireless Networking 7 12-22-2011 12:04 AM
[SOLVED] I broke my wireless connection... Unable to get IP address Robert.Thompson Slackware 4 02-15-2011 03:32 PM
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-14-2009 11:58 PM
Wicd / wireless can't get IP address Innervision Slackware 23 06-05-2009 11:29 AM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover Suse/Novell 8 02-22-2005 07:57 AM


All times are GMT -5. The time now is 05:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration