LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2009, 01:00 AM   #1
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
wicd 1.6.2.2 - the old ESSID still show up and cannot connect?


Hi,

A few days ago, I have changed ESSID for my Access point.

From this topic, I have uninstalled wicd 1.6.2.1 by using slackpkg and reinstall it with new version (1.6.2.2) from source code (moved ~/.wicd and /etc/wicd to another location). But, the OLD ESSID still shows up in wicd network manager and I cannot connect to it. The error message is "Cannot obtain IP address". (I am sure about encryption type and Preshared key).

On the other hand, "iwlist wlan0 scan" still show the NEW ESSID normally, but I always get "wlan0 no private ioctls." when try connecting to it from command line:
Code:
iwconfig wlan0 essid "MY_ESSID"
iwpriv wlan0 set AuthMode=WPAPSK
I completly deleted the OLD ESSID from /etc/wicd/wireless-settings.conf.

How can I get the new ESSID in wicd network manager window?

Last edited by quanta; 09-24-2009 at 11:19 PM.
 
Old 09-23-2009, 03:08 AM   #2
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
I have tried using the 'wicd-curses' from command line, and it displays the OLD ESSID too. Press 'C' to connect and I get link-local address 169.254.x.x. I don't think DHCP server on my Access Point has problem because the other Windows computers in LAN still get IP from it normally.
 
Old 09-23-2009, 06:27 AM   #3
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Quote:
iwpriv wlan0 set AuthMode=WPAPSK
wlan0 no private ioctls.
What's that mean? I have searched Google but didn't find anything.

More details: I can always get Internet connection with WEP key by using:
Code:
iwconfig wlan0 essid ...
iwconfig wlan0 key restricted ...
but only rarely with WPA:
Code:
iwconfig wlan0 essid ...
iwpriv wlan0 set AuthMode=WPAPSK
iwpriv wlan0 set WPAPSK=...
My wireless card:
Code:
$ lspci | grep Wireless
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Last edited by quanta; 09-23-2009 at 08:45 AM.
 
Old 09-24-2009, 07:23 AM   #4
rvdboom
Member
 
Registered: Jul 2007
Distribution: Slackware
Posts: 186

Rep: Reputation: 23
wicd uses /var/lib/wicd/configurations to store its settings for various ESSID.
Try moving the contents somewhere else.
 
Old 09-24-2009, 07:34 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,397
Blog Entries: 3

Rep: Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483
Hi,

You can also try the new '1.6.2.2' release.

OOPs!

Last edited by onebuck; 09-24-2009 at 07:36 AM. Reason: sorry
 
Old 09-24-2009, 11:16 AM   #6
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
It also may be your card's driver. My laptop has a Broadcom card that uses b43legacy. While this module 'works' it does not allow me to force a change of the ESSID or other select functions like turning off the card. The ESSID takes more than 5 minutes to change if I tell it too.

This was all fixed by using ndiswrapper and a windows driver. All operations now function. I did have to tweak my setup however. For whatever reason I have to blacklist the b43 and b43legacy modules. Manually load them. Bring up the device with 'ifconfig wlan0 up'. Unload the module then load the ndiswrapper. I'm sure there is something I'm missing but it works consistently and I stopped caring.
 
Old 09-24-2009, 11:31 PM   #7
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Yesterday, I have changed it back to old ESSID and of course, it works.

Quote:
Originally Posted by rvdboom View Post
wicd uses /var/lib/wicd/configurations to store its settings for various ESSID.
Try moving the contents somewhere else.
Thank you very much. That's exactly where I am finding. I will move the old essid somewhere and try again. I think it will works.
Quote:
Originally Posted by onebuck View Post
Hi,

You can also try the new '1.6.2.2' release.

OOPs!
Sorry about my first post not clearly, I am using 1.6.2.2.
 
Old 09-25-2009, 07:35 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,397
Blog Entries: 3

Rep: Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483
Hi,

Quote:
Originally Posted by quanta View Post
Yesterday, I have changed it back to old ESSID and of course, it works.


Thank you very much. That's exactly where I am finding. I will move the old essid somewhere and try again. I think it will works.

Sorry about my first post not clearly, I am using 1.6.2.2.
It was my mistake not yours.
 
Old 10-12-2009, 11:47 AM   #9
gavian
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
I had the same problem.

In the config file /etc/wicd/wireless-settings.conf I have changed my old essid for the new one.

It works for me.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WICD cannot connect . garrydog Linux - Newbie 30 09-22-2009 01:38 PM
Atheros ath9k and wicd in Slackware64...can not connect em21701 Slackware 13 09-01-2009 02:18 AM
problem using wicd to connect to a hidden wep network JazzItSelf Slackware 4 08-22-2009 04:46 PM
Wicd on Fedora 10 will not connect to WPA/WPA2 network after install Mikazo Linux - Wireless Networking 2 04-11-2009 01:38 PM
Cannot connect to wireless network with wicd on Zenwalk Kenny_C Linux - Wireless Networking 1 04-07-2009 03:11 PM


All times are GMT -5. The time now is 07:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration