LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-20-2012, 12:51 AM   #16
_ZeD_
LQ Newbie
 
Registered: May 2012
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 1

Quote:
Originally Posted by willysr View Post
It's now released on -Current
Wow!
 
Old 06-13-2012, 09:10 PM   #17
Thom1b
Member
 
Registered: Mar 2010
Posts: 70

Rep: Reputation: 30
MPlayer-1.1 is out
 
Old 06-19-2012, 06:08 AM   #18
D1ver
Member
 
Registered: Jan 2010
Distribution: Slackware 13.37
Posts: 527
Blog Entries: 3

Rep: Reputation: 126Reputation: 126
Quote:
Originally Posted by ill323 View Post
OK, just noticed the HTML docs not compiled.

Update MPlayer.SlackBuild:

Code:
--- MPlayer.SlackBuild.orig 2012-05-16 00:03:00.000000000 +0800
+++ MPlayer.SlackBuild      2012-05-16 15:01:28.000000000 +0800
@@ -271,7 +271,6 @@
             --confdir=/etc/mplayer \
             --enable-gui \
             --enable-menu \
-            --enable-largefiles \
             --disable-arts \
             --codecsdir=${CODECSDIR} \
             --language="${LANGUAGES}" \
@@ -280,15 +279,15 @@
             2>&1 | tee $OUTPUT/configure-${PRGNAM}.log
 # So that MPlayer does not report "UNKNOWN" as it's version:
 echo $VERSION > VERSION
-make 2>&1 | tee $OUTPUT/make-${PRGNAM}.log
+make -j2 2>&1 | tee $OUTPUT/make-${PRGNAM}.log
 make DESTDIR=$PKG install 2>&1 |tee $OUTPUT/install-${PRGNAM}.log
 
 # Build the html documentation (not all languages are available):
-( cd DOCS/xml
+#( cd DOCS/xml
   for i in $(echo $LANGUAGES | tr , ' ') ; do 
-    [ -d $i ] && make html-single-$i ;
+    [ -d DOCS/xml/$i ] && make html-single-$i ;
   done
-)
+#)
 
 # Prepare the configfile:
 mkdir -p $PKG/etc/mplayer

Thank you for this, I just rebuilt MPlayer 20120619 with vdpau support and now I can watch 1080p mkv files with no stuttering, <10% CPU.

Cheers
 
Old 06-19-2012, 09:40 AM   #19
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
<10% CPU !!! I will get that too
 
Old 06-19-2012, 06:21 PM   #20
D1ver
Member
 
Registered: Jan 2010
Distribution: Slackware 13.37
Posts: 527
Blog Entries: 3

Rep: Reputation: 126Reputation: 126
Quote:
Originally Posted by honeybadger View Post
<10% CPU !!! I will get that too
Well, the CPU usage has gone down because it's offloading processing to my 1gig GTX460, so if you've got a nice Nvidia graphics card you should build libvdpau and rebuild MPlayer too
 
Old 06-20-2012, 06:00 AM   #21
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Quote:
Originally Posted by D1ver View Post
Well, the CPU usage has gone down because it's offloading processing to my 1gig GTX460, so if you've got a nice Nvidia graphics card you should build libvdpau and rebuild MPlayer too
You don't need a high power card for that, any card from the 8000-series upwards (except the G80-based, like the 8800GTS) will do that, even a simple 8400GS.

Last edited by TobiSGD; 06-20-2012 at 09:15 PM.
 
1 members found this post helpful.
Old 06-20-2012, 08:38 PM   #22
major.tom
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Slackware (current); Gentoo (newbie)
Posts: 142

Rep: Reputation: 15
Just an "fyi", the latest version of Mplayer appears to require libglut.so, which is now installed with freeglut from the /x/ packages.

m.t
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] MPlayer fails to compile on -current Daedra Slackware 8 08-18-2011 10:07 PM
Slack64-Current / Mplayer slackass Slackware 4 04-02-2011 10:42 AM
[SOLVED] Does mplayer scale in current with radeon? AGer Slackware 4 03-08-2010 12:28 PM
MPlayer crash in -current vinegaroon Slackware 1 06-18-2009 08:12 PM
MPlayer in -current niels.horn Slackware 11 05-20-2009 09:38 AM


All times are GMT -5. The time now is 12:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration