Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 09-10-2009, 08:56 PM   #16
Senior Member
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540

Do you happen to have a record of that 'long, weird-looking string?' so we'll know what to watch out for?
Well, I have a copy now:


Height 1050=267
Width 1680=420

Height 1050=737
Width 1680=1426
I don't know what the problem is the past day. Almost every time I use krunner as normal user the thing crashes and I have to exit KDE to get krunner functioning again. The only way I can stave off the problem for a while is to delete the krunnerrc file.
Old 09-10-2009, 09:07 PM   #17
LQ Guru
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
That's really bizarre.. Here's my krunnerrc:

Height 1050=499
Width 1680=399


Height 1050=255
Width 1680=420
And also, for the heck of it, incase this helps *anyone* sort out any of this, here's what I see in a console, if I run `krunner` from a console in my Xfce session:

bash-3.1$ krunner #first attempt to run it, which dies/aborts
"/usr/bin/krunner(12744)" Error in thread 140150017808288 : "org.freedesktop.DBus.Error.ServiceUnknown - The name was not provided by any .service files"
"/usr/bin/krunner(12744)" Error in thread 140150017808288 : "QLocalSocket::connectToServer: Invalid name"
bash-3.1$ krunner #second attempt to run it, which runs cleanly & forks off from the console

Last edited by GrapefruiTgirl; 09-10-2009 at 09:10 PM.
Old 09-11-2009, 08:39 PM   #18
LQ Newbie
Registered: Nov 2005
Distribution: Slackware64 13.1
Posts: 7

Rep: Reputation: 0
I can trigger this bug on my system (Sony VGN-NR laptop) by pressing non-functioning Fn key combos, and S1 button. Pressing a Fn combo that is working, Fn+F4 (volume up) for example, does not trigger the bug.

Logging out and in from the system (not just out of KDE) makes everything go back to normal, as in krunner starts when Alt+F2 is pressed. If I just restart KDE instead, krunner will also start after pressing Alt+F2 but only for a short span of time (maybe 3 seconds?), after which xfrun4 will "replace" krunner.

In System Settings - Autostart, I have the following two entries (they are disabled, though):



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No TTY when pressing Alt+F1 - 7 tribalmasters Fedora 10 08-15-2005 10:02 AM
windowmaker restarts when pressing Alt-Tab sohmc Linux - Software 0 02-23-2005 07:40 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Pressing 'alt 1' key twantrd Linux - General 2 01-07-2005 12:05 AM
Slack 9, no Run Command upon pressing Alt+F2 VioLaToR Slackware 4 06-12-2003 01:08 PM

All times are GMT -5. The time now is 07:09 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration