LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-21-2007, 03:24 AM   #1
efranz
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Rep: Reputation: 0
Why does eth0 disappear (on VMware) ?


I have made a fresh (slim) installation of Slackware 12.0 with VMware on my Windows XP notebook. I use only one network interface card on my VMware host (eth0). Everything works fine as expected, but I have a problem when I create a VMware clone from my VMware image.

When I boot the cloned image I have lost the eth0 interface. Restarting with "rc.inet1 start" results in "SIOCADDRT: no such process".

ifconfig -a shows the eth0 interface but ifconfig does not because eth0 it is not active.

I have seen another thread on this issue (why does eth0 disappear, by nyloc) but could not find any solution. Are there any news or ideas?

I now compared the log-files (/var/log/dmesg and /var/log/messages) of both boot processes (original host and cloned host). The only difference is at starting the interfaces in /var/log/messages.

In the original host /var/log/messages I find the two lines:
- sip logger: /etc/rc.d/rc.inet1: /sbin/ifconfig eth0 192.168.0.5 broadcast 192.168.0.255 netmask 255.255.255.0
- sip kernel: eth0: link up

In the cloned hosts /var/log/messages the above two lines are missing, and there is a line instead
- sip logger: SIOCADDRT: No such process

Why does this process not start from a cloned image?
Does anyone have an idea? Or how to repair the situation on the cloned host?

Any help highly appreciated!

regards
Franz

Last edited by efranz; 08-22-2007 at 03:36 PM. Reason: Further analysis of boot process
 
Old 08-21-2007, 03:32 AM   #2
efranz
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Original Poster
Rep: Reputation: 0
additional info: kernel 2.6.21.5-smp

I used the default kernel (2.6.21.5-smp).
 
Old 05-29-2008, 01:51 AM   #3
Lx4l720
LQ Newbie
 
Registered: May 2008
Posts: 9

Rep: Reputation: 0
I know this is WAY late, but I had a similar problem with ubuntu and debian, and I found the solution.

I'll post the url in my next post.
 
Old 05-29-2008, 01:51 AM   #4
Lx4l720
LQ Newbie
 
Registered: May 2008
Posts: 9

Rep: Reputation: 0
Here's the url:
http://www.twoideas.org/wordpress/category/ubuntu/
 
Old 05-30-2008, 12:22 AM   #5
efranz
LQ Newbie
 
Registered: Apr 2006
Posts: 4

Original Poster
Rep: Reputation: 0
an even more simple solution

Meanwhile I already use a more simple solution:
Delete delete the file “/etc/udev/rules.d/z25_persistent-net.rules” and reboot the VM.
 
Old 05-31-2008, 02:17 AM   #6
Lx4l720
LQ Newbie
 
Registered: May 2008
Posts: 9

Rep: Reputation: 0
Oh yeah that's the instructions in that url. This problem really had me for a while!
 
Old 09-08-2008, 07:28 AM   #7
zeroberto
Member
 
Registered: Aug 2008
Location: Serbia
Distribution: Slackware-current
Posts: 39

Rep: Reputation: 1
I removed the /etc/udev/rules.d/70_persistent-net.rules, but it is being created every time I start the VM, and the eth0 is still not visible in ifconfig.
Any hints?
I'm using slackware 12.1 on vmware.

Last edited by zeroberto; 09-08-2008 at 07:36 AM.
 
Old 09-08-2008, 11:58 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,460
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

Try 'ifconfig -a' to see what is recognized. 'man ifconfig' to get a better understanding.
 
Old 09-08-2008, 12:12 PM   #9
zeroberto
Member
 
Registered: Aug 2008
Location: Serbia
Distribution: Slackware-current
Posts: 39

Rep: Reputation: 1
ifconfig -a gives:

Code:
eth0      Link encap:Ethernet  HWaddr 00:0c:29:1b:50:bb
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1041 (1.0 KiB)  TX bytes:4130 (4.0 KiB)
          Interrupt:16 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Last edited by zeroberto; 09-08-2008 at 12:14 PM.
 
Old 09-09-2008, 06:16 AM   #10
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: Slackware®
Posts: 11,460
Blog Entries: 4

Rep: Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505Reputation: 1505
Hi,

If that is after the vm boot then the eth0 device is known to the kernel but does not have a IP assigned. What does your '/etc/rc.d/rc.inet1.conf show for the eth0 device. You did run 'netconfig' or physically setup the eth0 in the 'etc/rc.d/rc.inet1.conf' file?
 
Old 09-09-2008, 09:23 AM   #11
zeroberto
Member
 
Registered: Aug 2008
Location: Serbia
Distribution: Slackware-current
Posts: 39

Rep: Reputation: 1
/etc/rc.d/rc.inet1.conf

Polling for DHCP server on interface eth0:
dhcpd: MAC address = 00:0c:29:1b:50:bb

and I have to wait half minute until prompt appears.

I did a netconfig during the install, and I selected dhcp from the list.
 
Old 09-10-2008, 02:58 AM   #12
zeroberto
Member
 
Registered: Aug 2008
Location: Serbia
Distribution: Slackware-current
Posts: 39

Rep: Reputation: 1
Solved. I changed bridged to nat in vmware network configuration, and now it works.
 
Old 09-11-2008, 01:10 AM   #13
Lx4l720
LQ Newbie
 
Registered: May 2008
Posts: 9

Rep: Reputation: 0
I wonder what would happen if you switched back.
 
  


Reply

Tags
disappears, eth0, vmware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RH9 on VMWare Eth0 "No Link Present" GGSpike Linux - Networking 11 04-01-2008 08:32 AM
eth0 disappear when parallel enable! jorasmi Linux - Hardware 0 02-08-2005 11:04 PM
Wireless network on eth1 diabled Ethernet eth0 and eth0 never comes back tadatoshi Linux - Wireless Networking 4 09-23-2004 06:57 PM
eth0 not working on fedora running in VMware 4 on WinXP pro machine ratgod Linux - Networking 14 06-25-2004 05:45 PM
VMWare Networking -- eth0 vs. wlan0 martin426 Linux - Software 0 11-28-2003 04:01 PM


All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration