LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-10-2012, 08:17 PM   #1
Miranden
Member
 
Registered: May 2012
Posts: 188

Rep: Reputation: 19
Why can I not access this forum under Slackware?


Hi everybody! I am very new to Slackware and Im trying to get everything working properly. I started a month or so ago, but I ran into a few problems and had to put it on the back burner for a while. Now I'm back and would like to sort everything out, So maybe I will post a few threads in the next few days. I hope somebody will be kind enough to answer them.

The first thing is, why is it I cannot get to this forum while using Slackware? I have a dual boot setup on my laptop and the wireless is working fine with wicd. I can access plenty of other sites, but when I try to come to Linux Questions it will not connect. Connection always times out. I had to reboot into Windows to make this post. It is the only site it has happened with so far. I tried many times on many different days, so I know it is not a coincidence with the site being down or something.

This is Slackware 13.37. Also using whatever Firefox comes with the install, with no updates, because I have not learned how to do that yet. Thank you.
 
Old 09-10-2012, 08:33 PM   #2
Lirey
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 34

Rep: Reputation: 6
Hi Miranden,

I've never had a problem with LQ, but I've had problems with other sites. The issues that I've had are not the fault of Slackware, but due to IPv6 and how my ISP is doing 6to4 translation.

You may want to run a test on your system through http://test-ipv6.com/, although the test suite doesn't detect all problems.

I solved most (all?) of my problems by decreasing the MTU for my system to 1280 from the default 1500. You can do this by editing the rc.inet1.conf file in /etc/rc.d and adding a like:

MTU[YYY]=1280

for the appropriate configuration, where YYY is the configuration number (probably 0 for a wired connection, maybe something else if you are using wireless). You'll generally want to use the largest MTU value that works reliably.

Another simple, but more severe solution is to blacklist IPv6 altogether in the kernel module configuration. I don't recommend that, but it may be useful for debugging the problem.

Lirey
 
Old 09-11-2012, 02:13 AM   #3
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
Also, try different DNS provider. Many ISP DNS are notoriously bad (esp. with IPv6) and for some odd reason seem Microsoft-centric.

In Wicd, or in your wifi router, you can change the default DNS to, say, OpenDNS
Code:
208.67.222.222
208.67.220.220
Say wnat you will, but OpenDNS solved a lot of issues of slow, timed out, or not found errors for me.
 
Old 09-11-2012, 03:20 AM   #4
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
Also disable ipv6
Code:
# echo "blacklist ipv6" > /etc/modprobe.d/ipv6.conf
Reboot
 
Old 09-11-2012, 04:37 AM   #5
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,039

Rep: Reputation: 163Reputation: 163
...aaaand, try another browser: firefox and I have had a long and rocky relationship. There are invisible firefox urchins who randomly invade and disrupt ff installations, only to just-as-mysteriously vanish, and all is well again...
 
Old 09-11-2012, 09:28 PM   #6
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Thank you for the replies! Also I didn't mean to post and run but my internet was not working today (on the ISP end).

I tried the ipv6 test from Lirey's post, and it says several things related to ipv6 are bad. I wanted to take a screen shot of all the information it gave me, so I finally figured out how to install xfce-screenshooter, but even though it says it installed and it put a shortcut on the application menu, nothing happens when I try to run it. So I have not been able to take a screen shot.

I added the MTU[YYY]=1280 line to the very end of the rc.inet1.conf file, but now I cannot get online at all. It says it cannot obtain an IP address. And my other computer can get a connection now so I know it isn't my ISP again.

I can move on and try to disable ipv6 now as suggested, but first I wanted to check and see if I did this part right. All I did was take the rc.inet1.conf file I had by default, add the line

MTU[YYY]=1280

to the very end, and that's it. Is that right?

Thanks!

added in: I put the rc.inet1.conf file back the way it was and I blacklisted ipv6 with the instructions given by el chapulin. It did not change anything after reboot. I also looked at wicd to try to change the default DNS address but I am not seeing where to put it. In the Global DNS area? Id so, what about the other feilds there that need to be filled in? Sorry, I am learning to program, but networking is definitely not my area.

Last edited by Miranden; 09-11-2012 at 09:58 PM. Reason: more information
 
1 members found this post helpful.
Old 09-11-2012, 09:52 PM   #7
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by Miranden View Post
All I did was take the rc.inet1.conf file I had by default, add the line

MTU[YYY]=1280

to the very end, and that's it. Is that right?
It isn't. Assuming you use the configuration number 4 in your /etc/rc.d/rc.inet1.conf file the valid entry is:

MTU[4]=1280
 
1 members found this post helpful.
Old 09-12-2012, 09:22 PM   #8
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by w1k0 View Post
It isn't. Assuming you use the configuration number 4 in your /etc/rc.d/rc.inet1.conf file the valid entry is:

MTU[4]=1280
Thanks for that. Unfortunate, it did not work. I still cannot access many sites and everything is very slow. Takes three or four minutes to load a page.

Here is my rc.inet1.conf file now.

Code:
#/etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="edited out"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=edited out"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name instead of
                                # the default 'eth4'
#IFNAME[4]="eth0:1"             # Set up an IP alias.
#HWADDR[4]="edited out"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_TIMEOUT[4]=15             # The default timeout for the DHCP client to
                                # wait for server resonse is 10 seconds, but
                                # you might want a shorter or longer wait.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#DHCP_DEBUG[4]="yes"            # Make dhcpcd show verbose diagnostics
#DHCP_NOIPV4LL[4]="yes"         # Do not assign an ipv4ll address when a DHCP
                                # server is not found (ipv4ll link-local
                                # adresses in the IP range 169.254.0.0/16 are
                                # also known as "zeroconf" addresses)
#WLAN_ESSID[4]=DARKSTAR         # An example of how you can override _any_
                                # parameter defined in rc.wireless.conf, by
                                # prepending 'WLAN_' to the parameter's name.
                                # Useful with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
#WLAN_WPA[4]="wpa_supplicant"   # Run wpa_supplicant for WPA support
#WLAN_WPADRIVER[4]="ndiswrapper"# Tell wpa_supplicant to specifically use the
                                # ndiswrapper driver (if you leave this empty
                                # the 'wext' driver is used by default)
#WLAN_WPAWAIT[4]=30             # In case it takes long for the WPA association
                                # to finish, you can increase the wait time
                                # (defaults to 10 seconds)

MTU[4]=1280
I put the new line at the bottom. Is it right now? I ask because near the top there is a commented out line that says MTU[4]="", and I wondered if the 1280 should be inside those quotes. I don't know this syntax.

If it is right this way (without quotes) I will install another browser and see. Thank you to everyone who responded.

Last edited by Miranden; 09-12-2012 at 09:54 PM.
 
Old 09-12-2012, 10:09 PM   #9
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
It isn’t enough to put the setting such as:

Code:
MTU[4]=1280
into /etc/rc.d/rc.inet1.conf file.

Your configuration number four doesn’t work. The sample configuration looks like:

Code:
IPADDR[0]="192.168.1.1"
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
GATEWAY=""
DEBUG_ETH_UP="no"
IFNAME[4]="wlan0"
MTU[4]=1280
USE_DHCP[4]="yes"
WLAN_ESSID[4]=ISP_Provider
WLAN_MODE[4]=Managed
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
You should also edit /etc/wpa_supplicant.conf file:

Code:
.
.
.
ssid=ISP_Provider
proto=WPA
psk=put some psk key here
.
.
.
I order to generate some psk key run the following command:

psktool --keysize 32

and inspect /etc/passwd.psk file.
 
1 members found this post helpful.
Old 09-13-2012, 11:52 AM   #10
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by w1k0 View Post
It isn’t enough to put the setting such as:

Code:
MTU[4]=1280
into /etc/rc.d/rc.inet1.conf file.

Your configuration number four doesn’t work.
Thank you. Yes, I was wondering about that. Because I read the Alien wiki article here about setting up the network and at the end it says

Quote:
If you want to use wicd, you will have to remove any network interface configuration information from /etc/rc.drc.inet1.conf in order to prevent a struggle for power between wicd and Slackware's rc.inet1 script.
Like I said in my first post, I am using wicd. So I did not put any configuration the in rc.inet1.conf. I did see that the array element 4 was not associated with anything. But since people knew I was using wicd and still gave those instructions I thought maybe something else was going on. But, since you told me to configure rc.inet1.conf, I did that and removed wicd and it worked! So thanks!

A couple of things though. First I did not configure wpa_supplicant.conf because I am not sure I need it with my type of access. Also I wanted to get everything working without encryption first. Anyway, the way I access my network is a little strange. I live in a housing community that provides wireless internet through several access points around the neighborhood. They are all unencrypted public access points. Anyone can log on. But when you do log on, you get redirected to a site for the wireless company where you enter your password. It is just like accessing internet at a hospital or a hotel.

For this type of network, do I need to WPA encryption? If so I will do it with the instruction you gave (thanks).

Also I have one more question. Right after I removed wicd, I put the rc.inet1.conf file back to the way it was as default--with everything commented out. Then I rebooted. At that time, I could still access the internet (I guess because of my unsecured network that I described), but I could still not get to this forum or many other sites. However, the internet was really, really fast--ten times faster than it had bee on wicd. In fact, it was even faster than it is now, with the rc.inet.conf file configured the way it is now like this

Code:
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]=""
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]="BlueFire #2 - West"
WLAN_MODE[4]=Managed
MTU[4]=1280
Do you know why this would be? Why was it so much slower with wicd than with the rc.inet1.conf defaults, and also why is it slower now with these values? Is there anything I can do to speed it up and have everything still work? Thank you again.

Last edited by Miranden; 09-13-2012 at 12:29 PM. Reason: typo in code
 
Old 09-16-2012, 10:56 AM   #11
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Nobody knows if I need WPA encryption with this sort of network? Or why wicd would be ten times slower than rc.inet1.conf? Sorry for the newbie questions. I just really don't know. Thanks.
 
Old 09-16-2012, 07:29 PM   #12
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Nevermind. I learned the answer to these questions. Thanks anyway.
 
Old 09-17-2012, 01:43 AM   #13
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
I couldn't reply to your questions from the post #10 because I don't know enough the network protocols and the valid network configuration settings. I always manage to configure the network but that doesn't mean I understand that. Your questions were very detailed and too difficult for me. It seems they were too difficult for the other people too, because nobody answered your questions. If you found some solution of your problems, please share it with us.
 
Old 09-17-2012, 12:44 PM   #14
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Thanks for letting me know. I thought I was just being ignored. Well, I have learned a great deal about WPA encryption and how it works, but all I think is really important to the question I asked earlier is that it encrypts data from the network card to the access point. Therefore, regardless of what happens when I hit the access point and am redirected to a server so that I can be authenticated (by means of the hospital-type password on the unsecured network), I need WPA encryption just as much as anyone else. Up until that point, my network is no different. This is what I believe to be true anyway.

About wicd being slower than rc.inet1.conf, I am not really sure about this. But I think it could possibly also have to do with wpa_supplicant. Wicd invokes wpa_supplicant as part of its operations. If something were going wrong there with the wpa_supplicant configuration, I think it could possibly cause my network to become slower. Of course this is really just a guess. There could be other things wicd does that I don't know about (probable). All I know is that now that I am only using rc.inet1.conf and have not configured wpa_supplicant yet, my network is lightning fast. When I do configure it myself (which I will do before I do any more browsing under Slackware) I might try to configure it wrong a few different ways and see if it slows things down, or just breaks everything completely.

Last edited by Miranden; 09-17-2012 at 12:49 PM.
 
Old 10-21-2012, 05:34 AM   #15
red_hax0r
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Rep: Reputation: 0
Thumbs up To be more specific

I believe all that he did was set the driver for the wireless to 'wext' in rc.inet1.conf. That worked for me. Apparently wicd's setting isn't as high a priority.


Last edited by red_hax0r; 10-21-2012 at 06:59 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
which forum for help with enabling write access on my different drives? please lynnsbomb Linux - Newbie 9 07-16-2012 01:46 AM
[SOLVED] A Slackware forum from the slackware linux project. stf92 Slackware 1 06-10-2010 12:37 AM
Copying a phpbb3 forum contents to a different forum; no admin access on source forum Maligree General 1 08-11-2008 11:45 AM
ACCESS DENIED to this forum. Please help. f1l3t0f1sh Linux - Security 3 06-02-2005 02:18 PM
No remote access (from Security forum) twhunt Linux - Networking 0 03-20-2002 12:43 AM


All times are GMT -5. The time now is 01:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration