LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-23-2013, 06:54 AM   #1
everal
Member
 
Registered: Nov 2004
Location: Zona Leste, Sao Paulo, Brazil, South America, Milk Way
Distribution: Slackware 10.1
Posts: 139

Rep: Reputation: 16
Where is kcontrol in KDE 4.8.2 slack 14?


Hey,

new slack 14 install, lots of problems.


1- Where is kcontrol? KDE is getting worse and worse and worse ... did they kill this app too?



2- Sound. Almost ANY sound app works after fresh install. Xmms is ok, but others like Amarok or Juk open but can't play anything. I create a list from a directory in Juk, click play and... no sound! It doesn't even start playing. Not that it doesn't have sound while playing, it just doesn't star playing...


Interaction between apps is also terrible. Like you will open a link from one e-mail BUT it is not related with any browser, and then you have that stupid box to select one, that doesn't give you the apps, give you the filesystem and then you must go searching for it... would it be so difficult? Isn't it so obvious?

I got a new Dell with that terrible ubuntu-thing. First thing was use Gparted and space for a new slack install, since one can't be working with that. In the end, I am still with ubuntu, almost nothing works in slack. Not even Qt... error messages all over the install... Ok, I knew it would be a time to configure, it is better blah blah blah, but not even sound in select apps? Not even e-mail-browser connection?

Anyway, could anyone help me about sound and kcontrol? serious stuff later... After years I will probably say by and try a Debian in the free space, but it is not easy.
 
Old 02-23-2013, 07:23 AM   #2
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Quote:
Originally Posted by everal View Post
Where is kcontrol in KDE 4.8.2 slack 14?
kcontrol is System Settings in KDE4. Now was that so difficult to find?

Can't help you with the audio as I don't use KDE.
 
Old 02-23-2013, 09:36 AM   #3
audriusk
Member
 
Registered: Mar 2011
Location: Klaipėda, Lithuania
Distribution: Slackware
Posts: 248

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by everal View Post
Hey,
2- Sound. Almost ANY sound app works after fresh install. Xmms is ok, but others like Amarok or Juk open but can't play anything. I create a list from a directory in Juk, click play and... no sound! It doesn't even start playing. Not that it doesn't have sound while playing, it just doesn't star playing...
KDE apps use Phonon library to play audio. Phonon is capable of using different backends. By default gstreamer backend is used. And here lies the problem you're most likely experiencing: Slackware only has gst-plugins-base and gst-plugins-good, which do not cover MP3 and some other proprietary audio formats (although Ogg Vorbis and FLAC do work). You need to make and install gst-plugins-bad and gst-plugins-ugly packages. If you're not sure how to do that, see SlackBuilds.org HOWTO.

Alternatively you can try switching to Phonon mplayer backend (System Settings -> Multimedia -> Backends; sorry if it's not exactly like that, my KDE is localized).
 
1 members found this post helpful.
Old 03-04-2013, 07:22 PM   #4
everal
Member
 
Registered: Nov 2004
Location: Zona Leste, Sao Paulo, Brazil, South America, Milk Way
Distribution: Slackware 10.1
Posts: 139

Original Poster
Rep: Reputation: 16
Thankx audriusk, I will see that.

Brox, it is easy to find System Settings in KDE4, what is impossible is to find all the other functions that disappeared. Because of that I asked, in some kind of crazy dream where KDE is not going to nothingness and they are not destroying it all.


There is a lot of stuff that just disappeared. Do you meed me to make you a graphic?
 
Old 03-05-2013, 07:37 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,379

Rep: Reputation: Disabled
Quote:
Originally Posted by everal View Post
There is a lot of stuff that just disappeared. Do you meed me to make you a graphic?
If you came from Slackware 10.1 (like your signature suggests) and recently moved to Slackware 14 then a lot has changed.
Things in KDE usually do not disappear. What version of KDE did you use before the KDE 4.8.5 in Slackware 14.0?
Tell us what you can not find and we will try to point you to the correct location.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to gain authorization for org.kde.kcontrol.kcmkdm.save (KDE 4.6.3) robertjinx Slackware 3 05-19-2011 04:03 PM
[SOLVED] Which kde package for kcontrol? hyperfluid Slackware 2 03-06-2011 04:31 PM
KDE 3.2.3 KControl: missing colordepth option? markj99 Slackware - Installation 0 11-12-2004 12:57 AM
kde kcontrol problem afrodocter Linux - Software 1 05-04-2004 02:11 AM
can't prind using CUPS/kde kcontrol bit7 Linux - Hardware 0 02-18-2003 04:37 PM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration