LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Where is kcontrol in KDE 4.8.2 slack 14? (http://www.linuxquestions.org/questions/slackware-14/where-is-kcontrol-in-kde-4-8-2-slack-14-a-4175451378/)

everal 02-23-2013 05:54 AM

Where is kcontrol in KDE 4.8.2 slack 14?
 
Hey,

new slack 14 install, lots of problems.


1- Where is kcontrol? KDE is getting worse and worse and worse ... did they kill this app too?



2- Sound. Almost ANY sound app works after fresh install. Xmms is ok, but others like Amarok or Juk open but can't play anything. I create a list from a directory in Juk, click play and... no sound! It doesn't even start playing. Not that it doesn't have sound while playing, it just doesn't star playing...


Interaction between apps is also terrible. Like you will open a link from one e-mail BUT it is not related with any browser, and then you have that stupid box to select one, that doesn't give you the apps, give you the filesystem and then you must go searching for it... would it be so difficult? Isn't it so obvious?

I got a new Dell with that terrible ubuntu-thing. First thing was use Gparted and space for a new slack install, since one can't be working with that. In the end, I am still with ubuntu, almost nothing works in slack. Not even Qt... error messages all over the install... Ok, I knew it would be a time to configure, it is better blah blah blah, but not even sound in select apps? Not even e-mail-browser connection?

Anyway, could anyone help me about sound and kcontrol? serious stuff later... After years I will probably say by and try a Debian in the free space, but it is not easy.

BroX 02-23-2013 06:23 AM

Quote:

Originally Posted by everal (Post 4898071)
Where is kcontrol in KDE 4.8.2 slack 14?

kcontrol is System Settings in KDE4. Now was that so difficult to find?

Can't help you with the audio as I don't use KDE.

audriusk 02-23-2013 08:36 AM

Quote:

Originally Posted by everal (Post 4898071)
Hey,
2- Sound. Almost ANY sound app works after fresh install. Xmms is ok, but others like Amarok or Juk open but can't play anything. I create a list from a directory in Juk, click play and... no sound! It doesn't even start playing. Not that it doesn't have sound while playing, it just doesn't star playing...

KDE apps use Phonon library to play audio. Phonon is capable of using different backends. By default gstreamer backend is used. And here lies the problem you're most likely experiencing: Slackware only has gst-plugins-base and gst-plugins-good, which do not cover MP3 and some other proprietary audio formats (although Ogg Vorbis and FLAC do work). You need to make and install gst-plugins-bad and gst-plugins-ugly packages. If you're not sure how to do that, see SlackBuilds.org HOWTO.

Alternatively you can try switching to Phonon mplayer backend (System Settings -> Multimedia -> Backends; sorry if it's not exactly like that, my KDE is localized).

everal 03-04-2013 06:22 PM

Thankx audriusk, I will see that.

Brox, it is easy to find System Settings in KDE4, what is impossible is to find all the other functions that disappeared. Because of that I asked, in some kind of crazy dream where KDE is not going to nothingness and they are not destroying it all.


There is a lot of stuff that just disappeared. Do you meed me to make you a graphic?

Alien Bob 03-05-2013 06:37 AM

Quote:

Originally Posted by everal (Post 4904702)
There is a lot of stuff that just disappeared. Do you meed me to make you a graphic?

If you came from Slackware 10.1 (like your signature suggests) and recently moved to Slackware 14 then a lot has changed.
Things in KDE usually do not disappear. What version of KDE did you use before the KDE 4.8.5 in Slackware 14.0?
Tell us what you can not find and we will try to point you to the correct location.

Eric


All times are GMT -5. The time now is 07:46 AM.