LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2007, 12:52 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Rep: Reputation: 53
Where can I adjust the font size of top tool-bar


Hi folks,

slamd64
Firefox

Pls advise where can I increase the font size on the top toolbar? I have been looking around on the preferences and could not figure out a solution. There I can increase the font size on the body. TIA

B.R.
satimis
 
Old 02-15-2007, 03:17 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I believe the font for the toolbars is tied to gtk+, so you might have to change it in there.

Usually make or edit the file '~/.gtkrc-2.0' as follows

Code:
gtk-font-name = "Lucida Sans 14"
Put in whatever font you want, of course. (this is from my .gtkrc-2.0)

or search google for more:
http://linuxfromscratch.org/pipermai...er/046186.html
http://www.justlinux.com/forum/showthread.php?p=835257

Last edited by H_TeXMeX_H; 02-15-2007 at 03:19 PM.
 
Old 02-15-2007, 11:19 PM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi H_TeXMeX_H,

Tks for your advice.

Quote:
I believe the font for the toolbars is tied to gtk+, so you might have to change it in there.

Usually make or edit the file '~/.gtkrc-2.0' as follows

Code:
gtk-font-name = "Lucida Sans 14"
Put in whatever font you want, of course. (this is from my .gtkrc-2.0)
# find / -name gtkrc
Code:
/home/satimis/.kde/share/config/gtkrc
/etc/gimp/2.0/gtkrc
/etc/gxine/gtkrc
/usr/share/themes/Default/gtk/gtkrc
/usr/share/themes/Default/gtk-2.0-key/gtkrc
/usr/share/themes/Emacs/gtk-2.0-key/gtkrc
/usr/share/themes/Raleigh/gtk-2.0/gtkrc
/usr/share/themes/Xfce-smooth/gtk-2.0/gtkrc
/usr/share/themes/Xfce/gtk-2.0/gtkrc
/usr/share/themes/Xfce-winter/gtk-2.0/gtkrc
/usr/share/themes/Xfce-stellar/gtk-2.0/gtkrc
/usr/share/themes/Xfce-saltlake/gtk-2.0/gtkrc
/usr/share/themes/Xfce-b5/gtk-2.0/gtkrc
/usr/share/themes/Xfce-4.0/gtk-2.0/gtkrc
/usr/share/themes/Xfce-redmondxp/gtk-2.0/gtkrc
/usr/share/themes/Xfce-cadmium/gtk-2.0/gtkrc
/usr/share/themes/Xfce-dawn/gtk-2.0/gtkrc
/usr/share/themes/Xfce-dusk/gtk-2.0/gtkrc
/usr/share/themes/Xfce-kde2/gtk-2.0/gtkrc
/usr/share/themes/Xfce-kolors/gtk-2.0/gtkrc
/usr/share/themes/Xfce-basic/gtk-2.0/gtkrc
/usr/share/themes/Xfce-curve/gtk-2.0/gtkrc
/usr/share/themes/Xfce-light/gtk-2.0/gtkrc
/usr/share/gimp/2.0/themes/Small/gtkrc
/usr/share/gimp/2.0/themes/Default/gtkrc
/root/.kde/share/config/gtkrc
Can't find .gtkrc-2.0

# nano /root/.kde/share/config/gtkrc
# nano /home/satimis/.kde/share/config/gtkrc
No such item "gtk-font-name" found.


I recall on KDE desktop clicking:
KStart --> Settings --> Internet & Network --> Network Settings

started "Configure - KDE Control Modules" and "Unsupported Platform-KDE Control" windows simultaneously.

On "Unsupported Platform-KDE Control" I can't find "slamd64-11.0", only slackware-10.0.0/10.1.0 etc. there.

I suppose slamd64-11.0 is not supported by KDE


B.R.
satimis
 
Old 02-15-2007, 11:25 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Oh, I forgot ... this guy's a troll. Gotta write his name down ...

Nah, I found the ignore list.

Last edited by H_TeXMeX_H; 02-15-2007 at 11:26 PM.
 
Old 02-16-2007, 09:15 AM   #5
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 59
So just create a ~/.gtkrc-2.0 ie a .gtkrc-2.0 in your home directory
Code:
touch ~/.gtkrc-2.0
Open the file in your favourite text editor and insert the text (adjusting font size as needed), save it and restart XWindows.
 
Old 02-16-2007, 10:12 AM   #6
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Hi Eternal_Newbie,

Tks for your advice.

Quote:
So just create a ~/.gtkrc-2.0 ie a .gtkrc-2.0 in your home directory
Code:
touch ~/.gtkrc-2.0
Open the file in your favourite text editor and insert the text (adjusting font size as needed), save it and restart XWindows.
performed following steps

$ touch ~/.gtkrc-2.0
$ nano ~/.gtkrc-2.0
copied "gtk-font-name = "Lucida Sans 14" on it.

Restarted X and evoked Firefox. Font size increased.

Repeated the same steps as root.

Problem solved. Tks again.

B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to get menu bar at top of screen like Macs nadroj Linux - General 5 12-15-2005 10:21 AM
enlightenment - bar on top epoo Linux - Software 3 05-08-2005 12:53 AM
font and menu bar size is crazy ryancw Linux - Newbie 0 11-13-2003 09:54 PM
openbsd: moving windows w/out using top bar yocompia *BSD 2 10-28-2003 08:40 AM
Tool Bar EmmettHR Red Hat 2 10-05-2003 10:29 AM


All times are GMT -5. The time now is 01:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration