LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-16-2004, 10:15 PM   #1
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Rep: Reputation: 15
When Ever I Update to Current


I crash something. Here are my errors that I am getting........



1- Mixer_Applet2 Process 2441 has crashed

2- OAIFD:Gnome_MixerApplet Details: Unknown Corba excetion id: IBLmg.org/Corba/Comm_Failure :1.0

I also don't have a "speaker Icon" or mixer. (Probably caused it crashed)

Here is my lsmod..............

bash-2.05b$ lsmod
Module Size Used by Not tainted
snd-pcm-oss 37860 0 (unused)
snd-mixer-oss 12536 0 [snd-pcm-oss]
keybdev 2052 0 (unused)
mousedev 4212 1
hid 21092 0 (unused)
usbmouse 2040 0 (unused)
input 3200 0 [keybdev mousedev hid usbmouse]
uhci 24508 0 (unused)
ehci-hcd 17644 0 (unused)
usbcore 59436 1 [hid usbmouse uhci ehci-hcd]
i810_rng 2528 0 (unused)
snd-intel8x0 18888 0 (unused)
gameport 1420 0 [snd-intel8x0]
snd-mpu401-uart 3200 0 [snd-intel8x0]
snd-rawmidi 12768 0 [snd-mpu401-uart]
snd-seq-device 3888 0 [snd-rawmidi]
snd-intel8x0m 9892 0
snd-pcm 55880 0 [snd-pcm-oss snd-intel8x0 snd-intel8x0m]
snd-timer 13572 0 [snd-pcm]
snd-page-alloc 6324 0 [snd-intel8x0 snd-intel8x0m snd-pcm]
snd-ac97-codec 44508 0 [snd-intel8x0 snd-intel8x0m]
snd 30340 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-mpu401-uart snd-rawmidi snd-seq-device snd-intel8x0m snd-pcm snd-timer snd-ac97-codec]
soundcore 3396 7 [snd]
ohci1394 24112 0 (unused)
ieee1394 42372 0 [ohci1394]
8139too 14216 1
mii 2272 0 [8139too]
crc32 2880 0 [8139too]
ds 6612 1
yenta_socket 10336 1
pcmcia_core 39972 0 [ds yenta_socket]
ide-scsi 9360 0
agpgart 44036 0 (unused)

Now if I just leave it alone after installing and don't update I have no problems at all.


Any ideas?

Thanks again for the help.

FX
 
Old 04-17-2004, 03:52 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Are you using Slackware GNOME, or Dropline GNOME? What are you using to update...swaret? Slapt-get? If so, and you're using Dropline, have you excluded the GNOME files installed by Dropline from any update facilities? They are designated *.1dl.tgz for this very reason.

It sounds to me like your update is trying to overwrite Dropline files with Slackware files while they are in use... and if Dropline was completely compatible with GNOME-standard, it wouldn't need to be a separate installer and set of processes, it seems to me.
 
Old 04-17-2004, 11:30 AM   #3
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Original Poster
Rep: Reputation: 15
Nope just striaght up regular old Gnome.

FX
 
Old 04-17-2004, 12:39 PM   #4
tigerflag
Member
 
Registered: Aug 2002
Location: Phoenix, AZ
Distribution: PCLinuxOS 2012.08
Posts: 428

Rep: Reputation: 30
As motub asked, what tool are you using to update? Swaret?
If you're using Swaret there have been a LOT of problems updating v9.1 to -current. Use the Search feature at the top of the page, and you might find some answers already posted. I'm not trying to scold about searching first before asking a question, I'm just saying that there's already a lot of information about this upgrade problem in the boards, in particular to losing sound/Alsa. Some of us have decided to use Swaret just to keep v9.1 up to date, and wait for the next official release, rather than upgrade to -current with Swaret.

HTH,
Siri Amrit
 
Old 04-17-2004, 04:35 PM   #5
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Original Poster
Rep: Reputation: 15
Well I just installed and updated on the wifes laptop and it works great. Course she has a Dell Latitude C600 with maestro (spelling) sound deal and seems to work great. Maybe I'll just reinstall Slack on my laptop and leave it as is until the official comes out like stated.

Yes I was using Swaret too. Sorry for not answering that the first time around.


Thanks for the help anyways.

FX
 
Old 04-19-2004, 03:13 AM   #6
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Original Poster
Rep: Reputation: 15
Here is a update on my laptop. Like I said everything with the upgrade on the wifes laptop went without a hitch, but on mine I had a ruff time with the sound.

Hopefully this will help others out. Not sure if I did this in the correct manner or not, but its working, so here it goes....................


After doing alot of reading I kind of pieced this all together.

Update swaret with the "current" in the conf. file
.
Then upgrade, even the kernel, so "comment" out the "Exclude" for the kernel and let it update.

So run "swaret --upgrade"
Let it do its thing.

When asked for "y" or "n" on packages I said "y" to all EXCEPT anything to do with alsa. I DID NOT upgrade alsa at all.

When it was done with its upgrading I ran "updatedb" and then "/sbin/lilo" for the kernel upgrade. Just to be sure. I have read where swaret or the upgrade process will do this automatically, but I ran it just to be sure.

Now I didn't have sound on the reboot so what I did, after reading alot is I went to http://www.alsa-project.org/ and got the latest drivers, lib and utils and downloaded them into a dir I made called "alsa"

From there I went to this page http://www.alsa-project.org/alsa-doc...odule=intel8x0
and followed it step by step.

Now I have "intel8x0 sound and it worked for me. Now I'd imagine if anyone else is having this trouble would pick out thier card in the database there and followed the install instructions they would have just as good as luck as me.

FX
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
did a slackware-current update nuke .Xmodmap for anyone else? Danus ex Slackware 11 09-15-2005 06:35 PM
schedule() Do i need to update current state of a process? sunang Programming 4 11-17-2004 01:17 AM
Xorg broke after update to current coffeedemon Slackware 1 11-10-2004 01:07 PM
Cant eject cdrom after slackware-current update windsok Slackware 3 09-19-2003 06:30 AM
Current-Update:'libart_lgpl' causing X to not start BearClaw Slackware 1 09-11-2003 03:12 AM


All times are GMT -5. The time now is 04:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration