LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   wget error with new current updates (http://www.linuxquestions.org/questions/slackware-14/wget-error-with-new-current-updates-4175416734/)

fogpipe 07-14-2012 03:11 PM

wget error with new current updates
 
Code:

wget: error while loading shared libraries: libgnutls.so.26: cannot open shared object file: No such file or directory
The steps i normally use to update are:

slackpkg update
slackpkg install-new
slackpkg upgrade-all

The install-new portion of the process seemed to go ok, but after that i cant upgrade anything because wget isnt working. It was working yesterday, i downloaded an avi file with it and again the install new portion of the upgrade seemed to go ok.

The only version number i of libgnutls.so.xx i can find using locate is libgnutls.so.28

Im considering linking libgnutls.so.28 to libgnutls.so.26 just as a attempted quick and dirty fix.

Any tips on getting wget working again so i can upgrade? Thanks.

EDIT:
Code:

ln -s /usr/lib64/libgnutls.so.28 /usr/lib64/libgnutls.so.26
actually worked and wget seems fine now. Is it ok to just go on like that or will it likely break something later?

Didier Spaier 07-14-2012 03:13 PM

This is answered in this thread from post #10

fogpipe 07-14-2012 03:16 PM

Ty :)


All times are GMT -5. The time now is 05:23 AM.