LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-06-2006, 03:10 AM   #1
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Rep: Reputation: 30
Weird Gaim/DNS problem


Hello. I use my laptop at work and I have this weird Gaim issue. When I'm at work, I can connect to any Gaim account (MSN, AIM, Yahoo and Google Talk). But when I try using gaim on my home network, none of the gaim protocols connect. So I ran ethereal at home checking to see what was happening under the hood, and it looks like for some weird reason Gaim tries to resolve my DNS server at work which is obviously not accessible over the internet. I checked my /etc/resolv.conf file when I'm at home and I don't see my work nameservers in there. I know this is a problem with gaim or gaim caching that work nameserver somewhere, because I've tried Kopete and I have no issues with Kopete. But I might be wrong, it just might be my slackware install caching nameserver somewhere else. has anyone come across this problem or know where I can start checking for cache nameservers. btw. i'm running Slackware 11.0, with kernel 2.6.13

TIA
 
Old 12-07-2006, 02:00 AM   #2
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
If you can ping any host in the internet and can browse, there should be no issue with gaim since you as well said that kopete is working. Meaning, you are enabled to connect to the internet and name resolution is working just fine.

Quote:
it just might be my slackware install caching nameserver somewhere else. has anyone come across this problem or know where I can start checking for cache nameservers.
Just start bind if you have installed the package.

# chmod +x /etc/rc.d/rc.bind
# /etc/rc.d/rc.bind start

Then edit /etc/resolv.conf:

lookup file bind
nameserver 127.0.0.1

Using this setting, you don't need to change resolv.conf anywhere you go and you now have caching name server.

To test:

# dig +short localhost
127.0.0.1

Should reply back 127.0.0.1 as address for localhost.

# dig +short -x 127.0.0.1
localhost.

You just did the reverse lookup and should answer localhost for 127.0.0.1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Gaim Issue...Please Help! br00tal Linux - Software 10 09-13-2005 05:40 PM
Weird DNS (?) behaviour jalonsom Linux - Networking 1 10-31-2004 06:55 AM
Weird DNS error for web browers monkey2004 Linux - Networking 1 10-02-2004 02:48 PM
weird DNS related (?) issue bobcat Linux - Networking 1 06-10-2002 08:08 PM
really weird DNS issue. Help needed ASAP! Supp0rtLinux Linux - Networking 2 05-20-2002 10:02 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration