LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-14-2008, 11:51 AM   #1
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Rep: Reputation: 34
Question Weird: Changing runlevel from 3 to 4 makes sound not work


I've done quite a bit of searching, here and elsewhere, and just haven't seen anything else quite like this, and it's been ages since I've posted a question around here, so I figure I'm due.

I just bought a brand new Dell XPS m1330 and I'm running Slackware current (from an ISO made on 01/08/2008).

I know, I know. If it's in current, it's probably not stable. Humor me for a moment; I think this issue probably has a relatively simple configuration related solution, I'm just out of ideas as to what it might be.

Everything works great (well, except for the POS on-board Broadcom wired ethernet... but that's another story). Slackware-current as of 01/08/08 was on 2.6.23.12, and KDE 3.5.7. I've spent the better part of yesterday getting things installed, configured, and tweaked to the way I like them. I encountered an odd problem with sound that seems to be common on this laptop, based on my searching, where sound works fine through the headphone jack, but doesn't come out of the speakers.

I resolved this by downloading the latest stable Alsa source and compiled and installed it. Worked perfectly after that.

Since I had everything working, I edited /etc/inittab and switched from runlevel 3 to runlevel 4, using KDM as my login manager.

And then when I log into KDE from the login manager as a non-root user, sound no-worky. It squawks about "device /dev/dsp can't be opened (Permission denied)" or so it claims.

Ooooooo-kaaaay.

When I try to run "alsamixer" it comes back and says "alsamixer: function snd_ctl_open failed for default: no such device".

So this is clearly permissions related, since it works fine under root... but why should changing runlevel have anything to do with this?

When I switch back to runlevel 3 I can log in as a non-root user and "startx" to fire up KDE and sound works fine.

Any suggestions as to what I permissions should be looking at? It surely couldn't be permissions directly on /dev/dsp, could it?

Last edited by Melkor; 01-14-2008 at 11:56 AM.
 
Old 01-14-2008, 12:32 PM   #2
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,442

Rep: Reputation: 70
Is there anything out of place in /etc/rc.d/rc.4? Otherwise it is quite strange that it works fine in runlevel 3, but not 4...
 
Old 01-14-2008, 01:10 PM   #3
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by shadowsnipes View Post
Is there anything out of place in /etc/rc.d/rc.4? Otherwise it is quite strange that it works fine in runlevel 3, but not 4...
Good thought, but nope.

/etc/rc.d/rc.4 looks identical to the rc.4 file on my other (older) laptop running Slackware 12, and I've never had issues with that one in runlevel 4.

It's funny, too, because it only seems to be sound that's affected by this... nothing else. Everything else works fine as a non-root user in runlevel 4.

Bizarre.
 
Old 01-14-2008, 01:27 PM   #4
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Original Poster
Rep: Reputation: 34
To be sure, I have no problem leaving this laptop in runlevel 3, I should add.

It just puzzles me as to why this would make a difference.
 
Old 01-14-2008, 02:43 PM   #5
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
What about runlevel 1?
 
Old 01-14-2008, 03:49 PM   #6
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 930

Rep: Reputation: 96
Did you make sure that the old alsa package was removed before the upgrade?
 
Old 01-14-2008, 04:10 PM   #7
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by Ilgar View Post
Did you make sure that the old alsa package was removed before the upgrade?
Uhhhhh.

No.

You think that might do it? I'm actually thinking it just might be a borked binary of KDM that's doing it.

I suppose I could completely blow away and completely reinstall alsa from scratch. It's not hard to do.

I am half afraid that might break things worse though. I have myself convinced that "runlevel 3 ain't so bad".

Last edited by Melkor; 01-14-2008 at 04:15 PM.
 
Old 01-14-2008, 04:17 PM   #8
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by Alien_Hominid View Post
What about runlevel 1?
Haven't tried, but I'm not sure what runlevel 1 would accomplish. It works fine in runlevel 3, just not 4 (unless logging into KDE as root).



EDIT: For the hell of it, I just tried booting in runlevel 1. Sound works fine in KDE in runlevel 1, but that shouldn't be surprising; if it works in 3 it shouldn't have a problem in 1.
 
Old 01-14-2008, 04:43 PM   #9
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
In your place I would go with disabling things in rc.4 until it (sound) works.
 
Old 01-14-2008, 04:51 PM   #10
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by Alien_Hominid View Post
In your place I would go with disabling things in rc.4 until it (sound) works.
There isn't much in rc.4.... it fires up KDM, that's about it.

I've removed all traces of alsa and am in the process of installing everything alsa-related from source right now. We'll see if that does it, though I'm still skeptical it's an issue with KDM.
 
Old 01-14-2008, 04:53 PM   #11
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
The only one thing affecting sound in KDE should be arts(d), which has lots of bugs.
 
Old 01-14-2008, 05:14 PM   #12
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Original Poster
Rep: Reputation: 34
Yeah, that's the other thing I haven't looked at yet, mostly because I don't know squat about arts(d). I've never had any problems with it, thankfully, but I know my way around alsa pretty well, and since alsa was one of the things I was monkeying with, I figured I'd start there.

Completely removing and reinstalling alsa didn't fix the situation. arts(d) is my next stop in troubleshooting this, I suppose.
 
Old 01-14-2008, 10:35 PM   #13
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,442

Rep: Reputation: 70
I would imagine it has to have something to do with arts as well...maybe take a look at your settings in KDE...
 
Old 01-14-2008, 11:04 PM   #14
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
Quote:
Originally Posted by Melkor View Post
Everything works great (well, except for the POS on-board Broadcom wired ethernet... but that's another story).
I love a good story are you using the tg3 driver with your Broadcom card? Changing to that fixed a problem I was having with a workstation here.
 
Old 01-14-2008, 11:19 PM   #15
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,807

Rep: Reputation: 234Reputation: 234Reputation: 234
Just out of curiosity, what are the permissions on /dev/dsp?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
changing to runlevel 1 windycity_linux Linux - Newbie 5 01-16-2007 11:14 PM
Changing runlevel in Fedora Cake Linux - Newbie 1 11-11-2004 08:24 PM
problem in changing runlevel in linux schandak Red Hat 1 09-24-2004 06:25 PM
problem changing runlevel Smokey Slackware 3 08-17-2004 11:05 PM
mplayer makes weird beeping sounds when playing avi's gervin Linux - Newbie 0 03-25-2004 04:35 AM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration