LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-25-2008, 04:47 AM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Rep: Reputation: 36
weird behaviour with greek named directories and files


hello everyone,
i was trying to copy some files from a friend of mine that are named in greek...
i have an ntfs external hd to which i copied the files from his pc. then i came back and connected the external hd to a slack11 box as usual..

when i navigated into the folder the folders where not there...
ls -la didn't show anything either... and
du -sh wouldn't account for the size of these apparently non existing folders...

so i disconnected the drive and connected it to a winXP box and voila the folders where there....

what is my linux box missing to be able to understand greek ?

TIA,
nass
 
Old 12-25-2008, 07:04 AM   #2
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 924

Rep: Reputation: 94
Did you try mounting the drive manually with character set specified? Your drive probably uses utf8 encoding, so you can try that as a starter. We recently had a discussion about displaying Turkish characters under utf8, you may find some hints over there (we also discuss how to change the console encoding, which you don't need).
 
Old 12-25-2008, 12:46 PM   #3
gefst
LQ Newbie
 
Registered: Sep 2003
Posts: 28

Rep: Reputation: 17
Try adding a line to your fstab asking for a specific charset

for example

/dev/sdb2 /media/usb2 vfat,ntfs-3g user,rw,suid,dev,noexec,async,quiet,gid=100,iocharset=iso8859-7,umask=007 0 0

If you use the old ntfs (or the vfat) driver you should use the iocharset=iso8859-7 option for Greek or the option utf8, depending on the way you have configured your system (iso or utf greek). Man mount for details.

Normaly when you use the new ntfs-3g driver you don't need to pass any options, if you have proper greek support on your system. In case you still have problems try following the instructions found here

http://ntfs-3g.org/support.html#locale

since there is locale option you can set. Man ntfs-3g for details.

Gefst
 
Old 12-27-2008, 05:15 AM   #4
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
i somehow (without changing any settings in fstab) managed to mount the drive and this time i could see these folders from console...when i say 'see' i dont mean i could see the proper folder name but some weird glyphs instead... in order to see the proper names i must always do a 'unicode_start' ... then i can see everything properly...

my current LC_ALL system variable, I have set to en_US.utf8 ... so as not to screw up anything (some incompatible programs to el_GR.utf8)...
either way setting LC_ALL to el_GR.utf8 doesn't help as i always have to type in 'unicode_start' from a console window....

also adding unicode_start to my ~/.bashrc screws up my sftp connections, since i usually get this error msg after running unicode_start
Quote:
nass@stargaze:/mnt$ unicode_start
Couldnt get a file descriptor referring to the console
Couldnt get a file descriptor referring to the console
Couldnt get a file descriptor referring to the console
Couldnt get a file descriptor referring to the console
that the sftp client can not handle, and i can not redirect its output to /dev/null.. so that it won't screw up the sftp (even though i won;t be seeing the error msg anymore in the console window)

i think i need a serious and thorough look into the whole language thing in linux... locales, languages,utf, unicode etcetc... is there some good reading for it?
 
Old 12-27-2008, 05:32 AM   #5
gefst
LQ Newbie
 
Registered: Sep 2003
Posts: 28

Rep: Reputation: 17
You can find all the information you need here (in Greek):

http://members.hellug.gr/djart/grlinux.html

Patrick suggests to avoid utf8 if you can do without it for the moment.

Gefst

Last edited by gefst; 12-27-2008 at 05:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Copying files and sub-directories of a directory except the directories named ".abc" sri1025 Linux - General 2 08-24-2010 08:53 AM
Unable to create files named with latin characters in *some* directories in NTFS glalejos Linux - General 2 10-14-2008 04:01 PM
Weird thread behaviour brownflamigo1 Programming 4 07-25-2008 05:53 AM
weird gzip behaviour? vlkplk Debian 3 02-22-2008 03:26 AM
9.3 weird behaviour ????? bigjohn Suse/Novell 9 07-06-2005 05:44 AM


All times are GMT -5. The time now is 11:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration