LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-02-2012, 10:00 AM   #1
pcelka
LQ Newbie
 
Registered: Dec 2010
Location: Strasbourg (France)
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
WebkitGtk Slackbuild fails


Hello,

I have a problem with WebkitGTK Slackbuild. It fails with this output:

Code:
Source/WebCore/platform/graphics/opengl/GraphicsContext3DOpenGLCommon.cpp:1301:5: error: '::glCompressedTexSubImage2D' has not been declared
make[1]: *** [Source/WebCore/platform/graphics/opengl/libWebCore_la-GraphicsContext3DOpenGLCommon.lo] Error 1
make[1]: Leaving directory `/tmp/SBo/webkit-1.8.3'
make: *** [all] Error 2
I use Slackware 14 x64 with Alien Bob multilib and Sbopkg for slackbuilds management. Do you have any ideas?
Thanks!

Last edited by pcelka; 11-03-2012 at 05:09 AM. Reason: Solved by Kikinovac
 
Old 11-02-2012, 11:45 AM   #2
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,612

Rep: Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751Reputation: 751
Do you have a proprietary NVidia driver installed? If so, then remove it and 'slackpkg reinstall mesa', then try again to build your package.
 
Old 11-03-2012, 04:50 AM   #3
pcelka
LQ Newbie
 
Registered: Dec 2010
Location: Strasbourg (France)
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Merci, Thanks Kikinovac. Yes, indeed, I use the Nvidia blob. The webkitgtk.slackbuild works like a charm without the blob.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ffmpeg slackbuild fails in 13.37 arubin Slackware 3 04-29-2011 10:02 AM
FBReader Slackbuild fails bogzab Slackware 3 04-08-2011 09:41 AM
[SOLVED] Conky SlackBuild fails agi93 Slackware 6 07-02-2010 05:21 PM
lmms slackbuild fails with -current the_penguinator Slackware 3 02-03-2010 09:24 AM
wmii slackbuild fails... What can I do...? Alexvader Slackware 3 11-02-2009 09:59 AM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration