-   Slackware (
-   -   WebkitGtk Slackbuild fails (

pcelka 11-02-2012 11:00 AM

WebkitGtk Slackbuild fails

I have a problem with WebkitGTK Slackbuild. It fails with this output:


Source/WebCore/platform/graphics/opengl/GraphicsContext3DOpenGLCommon.cpp:1301:5: error: '::glCompressedTexSubImage2D' has not been declared
make[1]: *** [Source/WebCore/platform/graphics/opengl/libWebCore_la-GraphicsContext3DOpenGLCommon.lo] Error 1
make[1]: Leaving directory `/tmp/SBo/webkit-1.8.3'
make: *** [all] Error 2

I use Slackware 14 x64 with Alien Bob multilib and Sbopkg for slackbuilds management. Do you have any ideas?

kikinovak 11-02-2012 12:45 PM

Do you have a proprietary NVidia driver installed? If so, then remove it and 'slackpkg reinstall mesa', then try again to build your package.

pcelka 11-03-2012 05:50 AM

Merci, Thanks Kikinovac. Yes, indeed, I use the Nvidia blob. The webkitgtk.slackbuild works like a charm without the blob.

All times are GMT -5. The time now is 09:50 PM.