LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-09-2009, 11:50 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,271

Rep: Reputation: 49
Waiting lots of time for the page to be loaded when entering an URL.


Hi.

GNU/linux kernel 2.6 - Slackware distribution.
Its been a time now since, when I enter an url in my web browser, any of
the three I have, I must wait a great deal of time before I can see the
page. I must say I do this in the GUI, that is, under the X server. Although
the difference in speed between using a graphical web browser and a console
text browser such as 'links' should essensially be the great quantity of
elements to transmit in the graphical case.

However, when I try to download a file from the slackware official site (www.slack
ware.org) I notice the download speed goes almost to the top of the band-
width granted to me by my ISP.

Is reinstallation of the o.s. the only solution? Any suggestion
will be welcome. Thanks for your time.
 
Old 08-09-2009, 02:36 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,620

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
IMHO, this is a DNS problem
 
Old 08-09-2009, 08:45 PM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,271

Original Poster
Rep: Reputation: 49
May be. I know this: when I boot the same machine in another o.s., everything's fine. Hence, the problem should be in the linux partition,
and not in the outsidde world. Thanks for reading.
 
Old 08-09-2009, 09:49 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
What is the output of "cat /etc/resolv.conf" please; from the Slackware
installation that is giving you this problem.
 
Old 08-09-2009, 10:45 PM   #5
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
This sounds like a DNS resolution problem. If your /etc/resolv.conf looks okay, do you use a customized /etc/hosts file? If any IP addresses in that file get stale then any lookup to that address would stall.
 
Old 08-11-2009, 05:42 AM   #6
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,271

Original Poster
Rep: Reputation: 49
I'm very sorry about the delay. The system on my machine
is to blame.
$ cat /etc/resolv.conf
# Generated by dhcpcd for interface eth0
nameserver 200.42.0.111
nameserver 200.42.97.111
nameserver 200.42.97.110
nameserver 200.42.0.110
nameserver 172.20.2.201
$
Thanks for your interest.
 
Old 08-11-2009, 06:26 AM   #7
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
I may also be a Javascript problem in case you have disabled it in some way (manually or with an extension/plugin) and if you only experience this with some, but not all sites. Google Maps for example didn't work right for me because of this.
 
Old 08-12-2009, 07:41 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,271

Original Poster
Rep: Reputation: 49
I experience it with all sites. Thank you for your feedback.
About /etc/hosts I've never touched it in my life.
 
Old 08-12-2009, 09:51 AM   #9
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,563
Blog Entries: 29

Rep: Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179
What are the DNS server settings on the other OSes on the same machine?

Does your Internet browser show what it is doing? If it sits for a while showing something like "Looking up ..." then the problem area is name resolution, probably DNS unless you have configured Slackware to use other name resolution mechanisms.

Try this script to see how your Slackware's DNS servers are responding. It's a bit of a hack but should do the trick.
Code:
#! /bin/bash

set -o posix
set -o nounset
shopt -s extglob # allow extended pattern matching operators 

# Executables
# ~~~~~~~~~~~
# So can change to suit OS variant
nslookup='/usr/bin/nslookup'
sort='/usr/bin/sort'

#--------------------------
# Name: test_servers
# Purpose: tests response times of list of servers
# $1 - list of servers
# $2 - results heading
#--------------------------
function test_servers {

	local oIFS out secs server

	out=''
	for server in $1
	do
		echo -n '.'
		# DEVELOPMENT NOTE: -timeout=5 in command below does not seem to be effective; default 15 timeout operates
		secs="$(/usr/bin/time -f '%e' $nslookup '-timeout=5' 'www.google.com' $server 2>&1 1>/dev/null)"
		out="$out
	$secs $server"
	done
	
	out="$(echo "$out" | $sort --general-numeric-sort)"
	
	echo
	echo "$2"
	oIFS="$IFS"
	IFS='
	'
	for buf in $out
	do
		IFS="$oIFS"
		IP_address="${buf#* }"
		response_time="${buf% *}"
		if [[ ${response_time%.*} -lt 5 ]]; then
			response_time="$response_time seconds"
		else
			response_time='Timed out'
		fi
		printf '%16s  %s\n' "$IP_address" "$response_time"
	done


	return 0

}  # end of function test_servers

my_servers='
200.42.0.111
200.42.97.111
200.42.97.110
200.42.0.110
172.20.2.201
'

test_servers "$my_servers" 'My DNS servers with query response times'
Check your resolv.conf man page. Ubuntu 8.04's says only the first three DNS servers are used.

If your ISP has unreliable DNS servers then you will get better average performance by overriding the default 5 seconds timeout by adding this line to resolv.conf
Code:
timeout:1
 
Old 08-13-2009, 06:34 AM   #10
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,271

Original Poster
Rep: Reputation: 49
Hi.
The DNS server setting on the other OS on the same machine is DHCP.
Yes. My internet browser shows what it is doing (on a bar at the bottom
of the screen). And itsits for a while showing "Looking up ...". I have
not configured slackware to use other name resolution mechanism.
Follows the output of your script:

.....
My DNS servers with query response times
200.42.97.111 0.05 seconds
200.42.97.110 0.07 seconds
172.20.2.201 Timed out
200.42.0.110 Timed out
200.42.0.111 Timed out


Thank you for your kindness.
Enrique.
 
Old 08-13-2009, 07:01 AM   #11
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,563
Blog Entries: 29

Rep: Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179
The test script showed that the first DNS server listed in your resolv.conf did not respond. By default, the name resolution mechanism will wait 5 seconds for it to reply before trying the next listed DNS server. If the "great deal of time" you mentioned in your first post is ~5 seconds then this is enough to explain the symptoms you are seeing and you can fix the problem by changing the dhcpd configuration that generates resolv.conf, putting the two fastest servers at the top of the list. I am not familiar with dhcpd configuration.

That leaves the issue of the other DNS servers' non-response. Presumably their IP addresses were supplied by your ISP so this is an ISP-specific issue.

If your ISP's DNS service is unreliable then the optimal solution is to install dnsmasq with a resolv-file=/etc/resolv.dnsmasq.conf line in /etc/dnsmasq.conf then populate /etc/resolv.dnsmasq.conf with all the half-decent DNS servers you know about. dnsmasq silently tries all the DNS servers it is given and uses the fastest, switching from DNS server to DNS server as the situation changes. Nice!

My ISP has a very unreliable DNS service; dnsmasq has improved performance dramatically. I used to test and change DNS servers whenever name resolution became slow. Now dnsmasq does it automatically an a lot faster.

Last edited by catkin; 08-13-2009 at 07:07 AM. Reason: Clearer language
 
Old 08-13-2009, 04:28 PM   #12
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,271

Original Poster
Rep: Reputation: 49
I will do what you say, but this can take me some time, because I am
foreign to networking so, regrettable I won't be able to feedback about
the result, as I would like to do, for a while. By the way, in my case,
it is the whole ISP who is unreliable. Thanks and good bye,
Enrique.
 
  


Reply

Tags
url


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
waiting for long time ahmed gamal Slackware 2 11-05-2008 02:37 PM
Waiting time for a script shipon_97 Linux - Newbie 4 12-16-2007 06:33 PM
My browser, all day today: 'waiting for linuxquestions.org...' ..waiting.. waiting .. GrapefruiTgirl LQ Suggestions & Feedback 18 05-25-2007 06:35 AM
Entering Wireless Networking for the First Time, Need Suggestions goldennuggets Linux - Wireless Networking 7 10-15-2006 03:09 PM
URL not followed by a '/' takes to another page nutsaboutlinux Linux - General 2 04-28-2004 05:45 AM


All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration