LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-28-2006, 07:38 PM   #1
pocon
LQ Newbie
 
Registered: May 2006
Posts: 2

Rep: Reputation: 0
vsftpd 530 login incorrect


Hi Folks,

I'm trying to setup vsftpd, looks like I'm partly there because I'm able to connect - I'm just not able to login.

I have this line in my vsftpd.conf file: local_enable=YES
If I'm not mistaken this is supposed to enable local users to login with their accounts.

I also have taken these steps from the root account:

Code:
# groupadd ftp-users
# mkdir /home/ftp-docs
# chmod 750 /home/ftp-docs
# chown root:ftp-users /home/ftp-docs
# useradd -g ftp-users -d /home/ftp-docs user1
# passwd user1 ( and of course assigned a password )
Next I copied a file into /home/ftp-docs

Finally issued thes commands:

Code:
# chown root:ftp-users /home/ftp-docs/*
# chmod 740 /home/ftp-docs/*
At this point I restarted the server.

Here's what happens when I try to connect:

ftp 192.168.0.199
Connected to 192.168.0.199.
220 Slackbox FTP
User (192.168.0.199:(none)): user1
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp>

I know the user1 acounts was actually created, because I'm able to logon to the machine locally with it, just not via ftp.

Any idea what I'm missing?

Thanks,
Paul
 
Old 05-29-2006, 03:09 AM   #2
imagineers7
Member
 
Registered: Mar 2006
Distribution: BackTrack, RHEL, FC, CentOS, IPCop, Ubuntu, 64Studio, Elive, Dream Linux, Trix Box
Posts: 310

Rep: Reputation: 30
Hi paul,

Your vsftpd.conf should look like this:-

#anonymous_enable=YES
local_enable=YES
write_enable=YES
pam_service_name=vsftpd
userlist_enable=YES

Also check /etc/vsftpd/user_list and /etc/ftpusers

This will allow the local users to access their home directories via ftp

Bye


Aniruddha

Last edited by imagineers7; 11-11-2006 at 11:41 PM.
 
Old 05-29-2006, 03:15 AM   #3
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
Quote:
Originally Posted by imagineers7
Hi paul,

Your vsftpd.conf should look like this:-

#anonymous_enable=YES
local_enable=YES
write_enable=YES
pam_service_name=vsftpd
userlist_enable=YES

Also check /etc/vsftpd/user_list and /etc/ftpusers

This will allow the local users to access their home directories via ftp

Bye
If you don't have gnome installed (10.2 doesn't even have it) pam is not on your system anyway.

(One of the problems of different distros. What one has, another doesn't)
 
Old 05-29-2006, 03:26 AM   #4
imagineers7
Member
 
Registered: Mar 2006
Distribution: BackTrack, RHEL, FC, CentOS, IPCop, Ubuntu, 64Studio, Elive, Dream Linux, Trix Box
Posts: 310

Rep: Reputation: 30
Hi cwwilson,

Thanks, I did not know it because I've never used slcakbox

Anyway thanks,



Aniruddha

Last edited by imagineers7; 11-11-2006 at 11:41 PM.
 
Old 05-30-2006, 12:17 AM   #5
pocon
LQ Newbie
 
Registered: May 2006
Posts: 2

Original Poster
Rep: Reputation: 0
What I needed to do was add check_shell=NO to the vpsftpd.conf
Worked like a charm.

Thanks for the help, it started me in the right direction.

Paul
 
Old 10-30-2006, 03:25 AM   #6
edenCC
Member
 
Registered: May 2006
Location: Gz,China
Distribution: RH,FB
Posts: 196
Blog Entries: 1

Rep: Reputation: 32
pam_service_name=vsftpd
I've tried, when using vsftpd-1.1.3-8(default version for redhat-9) and vsftpd-2.0.5, if you dont specify this parameter, you'll get a

530 Login incorrect.
Login failed.

Seems to be a bug =.=
 
Old 12-13-2011, 10:22 PM   #7
oppiet30
LQ Newbie
 
Registered: May 2008
Location: Carbondale, IL
Distribution: Fedora Core
Posts: 6

Rep: Reputation: 0
Actually it isn't a bug. Try putting /bin/bash in your /etc/shells file.
 
Old 03-08-2012, 08:30 AM   #8
Catfish023
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
Thumbs up

Oppiet30 Thank you SO much!!! I set up a new FTP server, moved over all my users from the old server, and could NOT get them to log in... But I had a special shell named for all of them and forgot to put it in to /etc/shells... Instant fix! Thanks a bunch!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsFTPD login error 530 gag.halfrunt Linux - Software 8 08-10-2012 02:52 PM
ProFTPd on SuSE 9.1:Error 530 (Login Incorrect) bmctee Linux - Software 0 08-10-2004 01:21 AM
530 Login incorrect & proftp 80s Linux - Newbie 7 05-11-2004 09:06 PM
vsftp 1.1.2 on redhat 7.1 -- 530 incorrect login issue triggerfish Linux - Networking 12 10-29-2003 01:43 AM
vsftpd 1.1.2 on redhat 7.1 -- 530 incorrect login issue triggerfish Linux - Software 4 08-17-2003 08:58 PM


All times are GMT -5. The time now is 09:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration