LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-20-2013, 09:09 PM   #1
aihaike
Member
 
Registered: Feb 2006
Location: Shanghai, China
Distribution: Slackware
Posts: 210

Rep: Reputation: 15
Question VPN issue


Dear all,

My using Slackware 14.0 and I'm having an issue creating a vpn client.

I followed the instruction of section 3.2 from this page : https://www.linuxquestions.org/linux...ackware_How_to

My problem is ppp0 is not used.

Here is what /var/log/messages contains:
Code:
pppd 2.4.5 started by root, uid 0
Using interface ppp0
Connect: ppp0 <--> /dev/pts/2
anon log[main:pptp.c:314]: The synchronous pptp option is NOT activated 
anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request' 
anon log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
anon log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request' 
anon log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
anon log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 22528). 
CHAP authentication succeeded
MPPE 128-bit stateless compression enabled
local  IP address local-ip
remote IP address remote-ip
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
anon log[logecho:pptp_ctrl.c:677]: Echo Reply received.
the default destination shows by netstat -r is not the one shows by ifconfig ppp0.

I tried to use route as the following but did not work out:

Code:
/sbin/route add -host remote-ip dev ppp0
Can someone tell me what am I doing wrong?
Thanks,

Éric.
 
Old 06-20-2013, 11:41 PM   #2
aihaike
Member
 
Registered: Feb 2006
Location: Shanghai, China
Distribution: Slackware
Posts: 210

Original Poster
Rep: Reputation: 15
For some obscure reason it gets working after starting a vpnc client ....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VPN issue anishkumarv Linux - Networking 3 10-16-2010 08:12 PM
routing / vpn issue Rickead2000 Linux - Software 1 01-24-2010 06:34 PM
VPN connection issue Joe_Zhu Linux - Networking 8 12-17-2009 09:20 PM
VPN Connectivity Issue? your_shadow03 Linux - Newbie 7 04-22-2009 06:43 AM
VPN and AIX issue Avernus Linux - Security 7 09-17-2003 03:36 PM


All times are GMT -5. The time now is 09:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration