LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-17-2013, 05:20 PM   #1
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
VLC and Fullscreen Video


Hello,

I've installed libdvdcss and now I'm able to watch Film-DVDs with VLC.

Unfortunately I don't have fullscreen. When I select Fullscreen in the VLC-menu, the Videoscreen is smaller than my monitor. On the same computer I can watch Films on Windows with VLC in fullscreen.

It's a laptop with Radeon a HD5470 grapics adapter. I'm running Slackware64-current and use the radeon module, not the proprietary fglrx-driver.

VLC is Alien-Bobs package.

How can I optain fullscreen when watching DVDs with VLC.

Thanks in advance.

Markus

Last edited by markush; 04-17-2013 at 06:11 PM. Reason: added some text
 
Old 04-17-2013, 06:12 PM   #2
slack_rick
LQ Newbie
 
Registered: Apr 2013
Location: Florida,
Distribution: Slackware 64 Current - Slackware 14 x86_64
Posts: 9
Blog Entries: 1

Rep: Reputation: Disabled
Are you using XFCE? I have a Radeon HD 4500 - not fglrx. To full screen video's I have to un-maximize the screen, then go full screen.
 
1 members found this post helpful.
Old 04-18-2013, 01:32 AM   #3
maciuszek
Member
 
Registered: Nov 2010
Location: Toronto, Ontario
Distribution: Slackware + FreeBSD
Posts: 95

Rep: Reputation: 30
using vesa?
 
1 members found this post helpful.
Old 04-18-2013, 03:12 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by slack_rick View Post
Are you using XFCE? I have a Radeon HD 4500 - not fglrx. To full screen video's I have to un-maximize the screen, then go full screen.
Well, I'm using Xmonad which means that any Window is maximized by default. I'll try it with another WM, thanks for the hint.

Markus
 
Old 04-18-2013, 04:54 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,293

Rep: Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712
In xmonad, for me, mplayer will go fullscreen without any issue, but for VLC I just move it to its own fullscreen workspace (using "noBorders Full" as a layout), which then works fine -- without fullscreen, it is a full maximized window but with toolbars etc. visible, and going to fullscreen just hides the toolbars. This is definitely a weird interaction with xmonad's tiling and not a VLC bug (though obviously VLC's fullscreen feature is not as independent as mplayer's -- VLC relies on the window manager for help while mplayer does not). There may be a more clever workaround with xmonad+VLC but I just have "noBorders Full" as a layout option and I just cycle to it when needed.
 
1 members found this post helpful.
Old 04-18-2013, 06:51 PM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
I've now tried fluxbox. But it doesn't really work. It seems to be a good idea not to maximize the window. I'll try different WMs.

I'll follow up with a solution if I find one.

Thanks for the answers.

Markus
 
Old 04-18-2013, 07:07 PM   #7
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 2,029

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
I am using VLC in Fluxbox, full screen, without problems.

I have not seen it mentioned in this thread, but VLC has two controls which affect "full screen" viewing:

1. View >> Fullscreen interface (F11)
2. View >> Minimal interface (Ctrl-H)

Going "full screen" still shows the controls. Using "minimal interface" gets rid of everything except the window decorations. With both active it is genuine full screen like other players.
 
1 members found this post helpful.
Old 04-18-2013, 07:08 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,619
Blog Entries: 2

Rep: Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076
FWIW, I just tried it with i3 (also a tiling WM) and VLC behaves like it should do, rescaling the video to the maximum size that is possible with keeping aspect ratio when going fullscreen, so this seems really to be an issue with Xmonad.

Tested with:
Slackware 14.0 32 bit, Slackware -current 64 bit, i3 compiled from git (2013-03-13), VLC 2.0.5 from AlienBob
 
1 members found this post helpful.
Old 04-18-2013, 07:09 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,619
Blog Entries: 2

Rep: Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076Reputation: 4076
Quote:
Originally Posted by astrogeek View Post
I am using VLC in Fluxbox, full screen, without problems.

I have not seen it mentioned in this thread, but VLC has two controls which affect "full screen" viewing:

1. View >> Fullscreen interface (F11)
2. View >> Minimal interface (Ctrl-H)

Going "full screen" still shows the controls. Using "minimal interface" gets rid of everything except the window decorations. With both active it is genuine full screen like other players.
I just press "f" to go fullscreen.
 
Old 04-18-2013, 07:13 PM   #10
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware: 12.1, 13.1, 14.1, 64-14.1, -current, FreeBSD-10
Posts: 2,029

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Quote:
Originally Posted by TobiSGD View Post
I just press "f" to go fullscreen.
Yes I know that too, but I thought it might be worth pointing out that two things are at play here, just for completeness.
 
Old 04-18-2013, 08:48 PM   #11
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Do you have "video auto scaling" ticked in the settings? I seem to recall clicking something myself that set the video to its own resolution and not my monitor's.
 
1 members found this post helpful.
Old 04-19-2013, 03:23 AM   #12
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by astrogeek View Post
I am using VLC in Fluxbox, full screen, without problems.

I have not seen it mentioned in this thread, but VLC has two controls which affect "full screen" viewing:

1. View >> Fullscreen interface (F11)
2. View >> Minimal interface (Ctrl-H)

Going "full screen" still shows the controls. Using "minimal interface" gets rid of everything except the window decorations. With both active it is genuine full screen like other players.
This did the trick. I've appended two screenshots (using KDE). the first shows the old screen and the second shows the screen as I expected (like it is in Windows).

Maybe some of you try to guess which Film it is

Markus
Attached Images
File Type: jpg kde.jpg (30.2 KB, 28 views)
File Type: jpg kde2.jpg (32.0 KB, 28 views)
 
Old 04-19-2013, 08:50 PM   #13
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 254

Rep: Reputation: 28
brubaker? shawshank? blues brothers? chained heat? walk the line?
 
Old 04-20-2013, 02:58 AM   #14
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Original Poster
Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by glorsplitz View Post
brubaker? shawshank? blues brothers? chained heat? walk the line?
It's Walk the Line.

Markus
 
  


Reply

Tags
dvd, fullscreen, vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
If video is loaded in web browser I cannot hear video in VLC or other video player... LinusStallman Linux - Software 0 12-17-2011 10:48 AM
No video fullscreen in Pinguy 11.04 rmcellig Linux - Software 0 05-21-2011 07:33 AM
Games fullscreen is distorted, but video fullscreen is fine - older laptop xmrkite Linux - Software 7 07-20-2009 12:40 PM
How to make VLC stay in fullscreen while changing playlist items r00tb33r Linux - Software 0 01-06-2009 02:44 AM
VLC dies at fullscreen Ephracis Linux - Software 0 01-07-2005 03:15 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration