LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   VLC and Fullscreen Video (http://www.linuxquestions.org/questions/slackware-14/vlc-and-fullscreen-video-4175458536/)

markush 04-17-2013 04:20 PM

VLC and Fullscreen Video
 
Hello,

I've installed libdvdcss and now I'm able to watch Film-DVDs with VLC.

Unfortunately I don't have fullscreen. When I select Fullscreen in the VLC-menu, the Videoscreen is smaller than my monitor. On the same computer I can watch Films on Windows with VLC in fullscreen.

It's a laptop with Radeon a HD5470 grapics adapter. I'm running Slackware64-current and use the radeon module, not the proprietary fglrx-driver.

VLC is Alien-Bobs package.

How can I optain fullscreen when watching DVDs with VLC.

Thanks in advance.

Markus

slack_rick 04-17-2013 05:12 PM

Are you using XFCE? I have a Radeon HD 4500 - not fglrx. To full screen video's I have to un-maximize the screen, then go full screen.

maciuszek 04-18-2013 12:32 AM

using vesa?

markush 04-18-2013 02:12 AM

Quote:

Originally Posted by slack_rick (Post 4933561)
Are you using XFCE? I have a Radeon HD 4500 - not fglrx. To full screen video's I have to un-maximize the screen, then go full screen.

Well, I'm using Xmonad which means that any Window is maximized by default. I'll try it with another WM, thanks for the hint.

Markus

T3slider 04-18-2013 03:54 PM

In xmonad, for me, mplayer will go fullscreen without any issue, but for VLC I just move it to its own fullscreen workspace (using "noBorders Full" as a layout), which then works fine -- without fullscreen, it is a full maximized window but with toolbars etc. visible, and going to fullscreen just hides the toolbars. This is definitely a weird interaction with xmonad's tiling and not a VLC bug (though obviously VLC's fullscreen feature is not as independent as mplayer's -- VLC relies on the window manager for help while mplayer does not). There may be a more clever workaround with xmonad+VLC but I just have "noBorders Full" as a layout option and I just cycle to it when needed.

markush 04-18-2013 05:51 PM

I've now tried fluxbox. But it doesn't really work. It seems to be a good idea not to maximize the window. I'll try different WMs.

I'll follow up with a solution if I find one.

Thanks for the answers.

Markus

astrogeek 04-18-2013 06:07 PM

I am using VLC in Fluxbox, full screen, without problems.

I have not seen it mentioned in this thread, but VLC has two controls which affect "full screen" viewing:

1. View >> Fullscreen interface (F11)
2. View >> Minimal interface (Ctrl-H)

Going "full screen" still shows the controls. Using "minimal interface" gets rid of everything except the window decorations. With both active it is genuine full screen like other players.

TobiSGD 04-18-2013 06:08 PM

FWIW, I just tried it with i3 (also a tiling WM) and VLC behaves like it should do, rescaling the video to the maximum size that is possible with keeping aspect ratio when going fullscreen, so this seems really to be an issue with Xmonad.

Tested with:
Slackware 14.0 32 bit, Slackware -current 64 bit, i3 compiled from git (2013-03-13), VLC 2.0.5 from AlienBob

TobiSGD 04-18-2013 06:09 PM

Quote:

Originally Posted by astrogeek (Post 4934381)
I am using VLC in Fluxbox, full screen, without problems.

I have not seen it mentioned in this thread, but VLC has two controls which affect "full screen" viewing:

1. View >> Fullscreen interface (F11)
2. View >> Minimal interface (Ctrl-H)

Going "full screen" still shows the controls. Using "minimal interface" gets rid of everything except the window decorations. With both active it is genuine full screen like other players.

I just press "f" to go fullscreen.

astrogeek 04-18-2013 06:13 PM

Quote:

Originally Posted by TobiSGD (Post 4934386)
I just press "f" to go fullscreen.

Yes I know that too, but I thought it might be worth pointing out that two things are at play here, just for completeness.

273 04-18-2013 07:48 PM

Do you have "video auto scaling" ticked in the settings? I seem to recall clicking something myself that set the video to its own resolution and not my monitor's.

markush 04-19-2013 02:23 AM

2 Attachment(s)
Quote:

Originally Posted by astrogeek (Post 4934381)
I am using VLC in Fluxbox, full screen, without problems.

I have not seen it mentioned in this thread, but VLC has two controls which affect "full screen" viewing:

1. View >> Fullscreen interface (F11)
2. View >> Minimal interface (Ctrl-H)

Going "full screen" still shows the controls. Using "minimal interface" gets rid of everything except the window decorations. With both active it is genuine full screen like other players.

This did the trick. I've appended two screenshots (using KDE). the first shows the old screen and the second shows the screen as I expected (like it is in Windows).

Maybe some of you try to guess which Film it is :D

Markus

glorsplitz 04-19-2013 07:50 PM

brubaker? shawshank? blues brothers? chained heat? walk the line?

markush 04-20-2013 01:58 AM

Quote:

Originally Posted by glorsplitz (Post 4935015)
brubaker? shawshank? blues brothers? chained heat? walk the line?

It's Walk the Line.

Markus


All times are GMT -5. The time now is 01:04 PM.