LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-11-2010, 07:49 AM   #1
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Rep: Reputation: 15
VirtualBox (windowsxp guest) sound problem


For those that use Virtualbox on their slackware host and have a windows (xp) guest running.
I have tried various settings for sound (Alsa, PulseAudio), the AC97 drivers are installed in the Windows xp guest os, but there is no sound and there is an unknown audio device (in the windows device manager). If I remove the AC97 drivers and use the soundblaster16 drivers in the Vbox settings there is no unknown sound device, but there's still no sound. Any ideas why I can't get sound working?
 
Old 03-11-2010, 07:58 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,139
Blog Entries: 52

Rep: Reputation: Disabled
Try the OSS setting. It works for me.
 
Old 03-11-2010, 09:29 AM   #3
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
See this thread where this same issue is discussed.

http://www.linuxquestions.org/questi...sound.-754662/

No one answered my question about how recompiling SDL would fix the issue, and it didn't fix it for me. I just upgraded my system to the latest -current64, and sound now works when using ALSA. You can also try compiling pulseaudio and using it.
 
Old 03-11-2010, 09:47 AM   #4
Cheesesteak
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 101

Rep: Reputation: 24
Here's my setup

My computer is using its on-motherboard HDA Intel audio, and I have sound working for guests in VirtualBox with PulseAudio. I have GSB 2.26 installed on my box, and I am using its PulseAudio packages (v0.9.15)... shouldn't matter whether you use GSB or roll your own packages from SBo. VirtualBox is PUEL for USB support, version 3.1.4.


my /etc/asound.conf
Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
          type pulse
          }
        ctl.!default {
          type pulse
          }
I created a group/user as hinted at SlackBuilds.org
Code:
groupadd -g 216 pulse
useradd -u 216 -g pulse -d /var/lib/pulse  pulse
Open up the PulseAudio Preferences window
Code:
Click on the Simultaneous Output tab
Tick the box for "Add virtual output device for simultaneous output on all local sound cards."
Audio settings in VirtualBox:
Code:
Host Audio Driver: PulseAudio
Audio Controller: ICH AC97

My only real beef with PulseAudio at the moment is that it seems to lower you output levels... need to crank up the decibels.

Last edited by Cheesesteak; 03-11-2010 at 09:49 AM.
 
Old 03-11-2010, 02:51 PM   #5
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Original Poster
Rep: Reputation: 15
Thanks for your help.
I hadn't installed PulseAudio, let's do that first.
Prior to building I installed libtool and removed the previous version.
But after running the PulseAudio configure script, it is not able to find it while it is correctly installed in /usr/local/bin/libtool


checking for lt_dladvise_init in -lltdl... no
configure: error: Unable to find libltdl version 2. Makes sure you have libtool 2.2 or later installed.

What's wrong now?

if test "x$LIBLTDL" = "x"; then :
as_fn_error "Unable to find libltdl version 2. Makes sure you have libtool 2.2 or later installed.
" "$LINENO" 5
fi

in the configure script.

LIBLTDL is somehow not defined

while
$ libtool --version
ltmain.sh (GNU libtool) 2.2.6b

Last edited by Kristian2; 03-11-2010 at 02:54 PM.
 
Old 03-11-2010, 03:53 PM   #6
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by Kristian2 View Post
Thanks for your help.
I hadn't installed PulseAudio, let's do that first.
Prior to building I installed libtool and removed the previous version.
But after running the PulseAudio configure script, it is not able to find it while it is correctly installed in /usr/local/bin/libtool


checking for lt_dladvise_init in -lltdl... no
configure: error: Unable to find libltdl version 2. Makes sure you have libtool 2.2 or later installed.

What's wrong now?

if test "x$LIBLTDL" = "x"; then :
as_fn_error "Unable to find libltdl version 2. Makes sure you have libtool 2.2 or later installed.
" "$LINENO" 5
fi

in the configure script.

LIBLTDL is somehow not defined

while
$ libtool --version
ltmain.sh (GNU libtool) 2.2.6b
There is a bug between the SBo version of pulseaudio and the libtool installed in Slackware. Try using the latest version of pulseaudio.

You can also review my other thread on the proper setup and configuration of pulseaudio under -current64.

http://www.linuxquestions.org/questi...=1#post3882766

To Cheesesteak's comments above about modifying the pulseaudio preferences, I gave up on pulseaudio under Slackware because I don't use gnome, and many of the support tools for pulseaudio have gnome library dependencies.

Like I said in my other post, my recent upgrade to the latest version of -current seemed to fix my ALSA problems. Have you tried upgrading to -current?
 
Old 03-11-2010, 10:36 PM   #7
Cheesesteak
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 101

Rep: Reputation: 24
I haven't had any luck using VirtualBox with a pure ALSA setup. On my host, I have no trouble concurrently playing an mp3 in Audacious, watching a video with audio on Youtube and getting sound effects through Pidgin. Should I be doing any of those, then choose to start a VBox guest, it complains that it can't access the specified audio device. If I'm not doing anything on the host when I fire up a VBox guest, it will have sound. Of course, the reverse then happens that I can't do anything on the host with audio until I shut the guest down.

Going a little further, I tried a few versions of VMware Workstation (6.5 and 7.0). On a stock Slackware64 13.0 setup, sound works between the host and guest(s) without any monkey-business. No Pulse, just pure ALSA. Aside from the painless audio, I don't have a compelling reason to use VMware over VirtualBox.
 
Old 03-12-2010, 02:36 AM   #8
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Original Poster
Rep: Reputation: 15
@rmjohnso

Well I removed the libtool from Slackware and replaced it with the 2.2 version, and I downloaded the latest sources of PulseAudio (0.9.21). That's is why I don't understand the error.
libtool is properly installed in /usr/local

I do not have the 64 bit Slackware version.

Last edited by Kristian2; 03-12-2010 at 02:45 AM.
 
Old 03-12-2010, 11:00 AM   #9
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by Kristian2 View Post
@rmjohnso

Well I removed the libtool from Slackware and replaced it with the 2.2 version, and I downloaded the latest sources of PulseAudio (0.9.21). That's is why I don't understand the error.
libtool is properly installed in /usr/local

I do not have the 64 bit Slackware version.
Have you tried reinstalling the Slackware version?
 
Old 03-12-2010, 11:47 AM   #10
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Original Poster
Rep: Reputation: 15
Reinstalling is not what I would like to do, I would rather wait for Slackware 14 or 15 for that, and honestly I don't see why that would solve the problem. There seems to be something the trouble with the configure script. I have to pinpoint the problem why the configuration doesn't see the newest libtool version. Change something in the script perhaps. Then I can install PulseAudio and see if that solves the sound problem.
 
Old 03-12-2010, 05:55 PM   #11
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
What I meant was to re-install the current version of the libtool Slackware package (not a full system re-install).
 
Old 03-13-2010, 04:46 AM   #12
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Original Poster
Rep: Reputation: 15
The version of Libtool distributed with Slackware is 1.5.26, while the latest PulseAudio requires 2.2 which is the Libtool version I replaced it with. I will have to see I can make some changes in the configure script to make it work.
 
Old 03-13-2010, 12:40 PM   #13
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
libtool-2.2.6b is a part of -current. You might try that.
 
Old 03-13-2010, 05:19 PM   #14
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Original Poster
Rep: Reputation: 15
PulseAudio is now installed, I forgot to remove the old libltdl files in /usr/lib which were still used instead of the newest ones in /usr/local/lib, oh well.
I made the changes in /etc/asound.conf, but no sound yet. Will continue tomorrow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Install Guest additions and run fullscreen mode on VirtualBox Guest OS | Linux LXer Syndicated Linux News 0 01-17-2010 06:30 PM
Problem on assigning static ip address.. RHEL 5 as guest OS on Virtualbox odessy Linux - Networking 1 08-28-2009 10:22 AM
problem installing guest additions in Fedora 11 guest (virtualbox) mia_tech Linux - Desktop 9 07-28-2009 01:15 AM
Virtualbox Gentoo Guest - Can't get guest additions working MALDATA Gentoo 3 06-19-2009 12:43 AM
Problem accessing dirs with VirtualBox and guest additions crisostomo_enrico Solaris / OpenSolaris 6 03-24-2008 06:38 AM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration