LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Virtualbox Current 32b nvidia KDE(failsafe) works but regular KDE does not (http://www.linuxquestions.org/questions/slackware-14/virtualbox-current-32b-nvidia-kde-failsafe-works-but-regular-kde-does-not-871148/)

slkrover 03-26-2011 12:23 PM

Virtualbox Current 32b nvidia KDE(failsafe) works but regular KDE does not
 
I have 13.1 on its own drive and works fine. I installed virtualbox in 64b windoz on a different drive with the same computer so I can play with all the different linux systems. Around 6 weeks ago I installed slack current from alien bobs mirror with no problems. An update a week ago? and kde would not work. KDE failsafe and all other desktops work fine.

adamk75 03-26-2011 04:02 PM

Disable compositing in your /etc/X11/xorg.conf file.

Adam

kingbeowulf 03-26-2011 04:17 PM

The new X.org way is to create a file (such as) disable-composite.conf in /etc/X11/xorg.conf.d with the lines:
Code:

Section "Extensions"
    Option "Composite" "Disable"
EndSection

This is in the changelog just before we went RC status. This appears to be needed not just for Nvidia GPU using nv, nouveau, vesa, but also for some ati/radeon and intel GPUs with open source drivers.

slkrover 03-26-2011 05:31 PM

Quote:

Originally Posted by beowulf999 (Post 4304555)
The new X.org way is to create a file (such as) disable-composite.conf in /etc/X11/xorg.conf.d with the lines:
Code:

Section "Extensions"
    Option "Composite" "Disable"
EndSection

This is in the changelog just before we went RC status. This appears to be needed not just for Nvidia GPU using nv, nouveau, vesa, but also for some ati/radeon and intel GPUs with open source drivers.

This did not work. But should it be "Composite" or "Composting"?

Thanks.

slkrover 03-26-2011 05:37 PM

Sorry this did work after I noticed there was 7 spaces between the margin and the line starting with "Option". Didn't think that would make a difference.

Thanks.

adamk75 03-27-2011 09:33 AM

Quote:

Originally Posted by beowulf999 (Post 4304555)
The new X.org way is to create a file (such as) disable-composite.conf in /etc/X11/xorg.conf.d with the lines:
Code:

Section "Extensions"
    Option "Composite" "Disable"
EndSection

This is in the changelog just before we went RC status. This appears to be needed not just for Nvidia GPU using nv, nouveau, vesa, but also for some ati/radeon and intel GPUs with open source drivers.

Only if the drivers are not working for some reason and fall back to software rendering.

Adam


All times are GMT -5. The time now is 10:12 PM.