LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2009, 02:29 AM   #1
cowyn
Member
 
Registered: Oct 2006
Location: Hangzhou, China
Distribution: Slackware
Posts: 49

Rep: Reputation: 15
VirtualBox binary 3.0.0 packaging issue


I built VBox 3.0.0 package using VBox for RHEL5 rpm <http://download.virtualbox.org/virtualbox/3.0.0/VirtualBox-3.0.0_49315_rhel5-1.x86_64.rpm>, the same way to package the past VBox releases.
This time I got an error while trying to start VirtualBox after install, it's a libcrypto.so.6 issue. I found that openssl rpm was built with `librel=6' and resulting a libcrypto.so.%{libmaj}.%{libmin}.%{librel}, which file VBox for rhel depends on, while it's libcrypto.so.0 in Slackware64.
Linked libcrypto.so.6 to libcrypto.so.0 solved this problem, so ugly. :(

Anyone else encountered the same problem?
I'm using binary edition because I need the USB and SATA features.
So, is there any other better solution to build a package?
Thank you.
 
Old 07-01-2009, 05:41 AM   #2
/dev/me
Member
 
Registered: May 2008
Distribution: Slackware 13
Posts: 116

Rep: Reputation: 20
The generic Linux installer?? It worked for me

wget http://dlc.sun.com/virtualbox/3.0.0/...-Linux_x86.run
 
Old 07-01-2009, 06:44 AM   #3
aszabo
Member
 
Registered: Mar 2009
Location: Budapest, Hungary
Distribution: Slackware
Posts: 91

Rep: Reputation: 15
Quote:
Originally Posted by /dev/me View Post
The generic Linux installer?? It worked for me

wget http://dlc.sun.com/virtualbox/3.0.0/...-Linux_x86.run
Hi,

the install of VirtualBox-3.0.0-49315-Linux_x86.run worked me also but when I run VirtualBox I get an error:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: /opt/VirtualBox/libQtNetworkVBox.so.4: undefined symbol: _ZO9QListData5eraseEPPv

Do you know the resolution of the problem?

Thanks
 
Old 07-01-2009, 06:48 AM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by /dev/me View Post
The generic Linux installer?? It worked for me
x2

Not sure why you selected the Red Hat version?

The "All Distributions" version comes with an installer that takes care of the all the hard work, and it even does upgrades.

Comes in 32 and 64 bit versions
 
Old 07-01-2009, 06:56 AM   #5
/dev/me
Member
 
Registered: May 2008
Distribution: Slackware 13
Posts: 116

Rep: Reputation: 20
Quote:
Originally Posted by aszabo
the install of VirtualBox-3.0.0-49315-Linux_x86.run worked me also but when I run VirtualBox I get an error:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: /opt/VirtualBox/libQtNetworkVBox.so.4: undefined symbol: _ZO9QListData5eraseEPPv

Do you know the resolution of the problem?
Nope. It appears your problem is *new*


A bug perhaps? Maybe something from a failed install got in the way? Or some customization somewhere? I don't know.
 
Old 07-01-2009, 06:57 AM   #6
cowyn
Member
 
Registered: Oct 2006
Location: Hangzhou, China
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by /dev/me View Post
The generic Linux installer?? It worked for me

wget http://dlc.sun.com/virtualbox/3.0.0/...-Linux_x86.run
No, I built the package using RHEL RPM. I don't like the way using install script.
Thanks anyway.

Last edited by cowyn; 07-01-2009 at 06:58 AM. Reason: typo
 
Old 07-01-2009, 07:16 AM   #7
aszabo
Member
 
Registered: Mar 2009
Location: Budapest, Hungary
Distribution: Slackware
Posts: 91

Rep: Reputation: 15
Quote:
Originally Posted by /dev/me View Post
Nope. It appears your problem is *new*


A bug perhaps? Maybe something from a failed install got in the way? Or some customization somewhere? I don't know.
I made the install as till now, I had no such problem with the older version(s) because I used till now the versions 1.6 till 2.2.4 with the same way.

Another idea?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tar archive from windows to linux, binary file issue jblevins Linux - General 3 04-13-2009 11:50 PM
Virtualbox modules/app. version issue aquaboot Debian 6 12-13-2008 09:49 AM
j2sdk installation issue - cannot execute binary file mcolley73 Linux - Software 2 04-18-2004 12:40 PM
Packaging a binary so others can use it. Travis86 Linux - Software 3 09-17-2003 08:56 PM


All times are GMT -5. The time now is 04:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration