LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-10-2008, 08:52 AM   #1
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Rep: Reputation: 40
VirtualBox and Slackware guest (problems resizing desktop)


My travails installing Slack 12.1 as a vbox guest are documented in other threads. Thanks to T3slider for his assistance so far. My latest thing is trying to resize the desktop higher than 1024x768.

I've added a couple extra entries to the mode line of my xorg.conf, but the KDE display properties still only list three possible resolutions (640x, 800x & 1024x). From the docs and other posts, that appears all I need to do. Any tips?

Code:
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor     "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

#   DefaultDepth 8
#   DefaultDepth 16
   DefaultDepth 24
#   DefaultDepth 32

# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

    Subsection "Display"
        Depth       8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes "1920x1200" "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        # Modes "1920x1200" "1680x1050" "1280x1024" "1024x768"
	Modes "1680x1050" "1280x1024"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1024x768" "800x600" "640x480"
    EndSubsection

EndSection
 
Old 07-10-2008, 08:43 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,233

Rep: Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575
I don't have time right now to look further into it, but I remember someone getting it to work at higher resolutions in this thread. However, they did not really post a satisfactory solution in full, so I am really just posting the thread so you can follow what happened and possibly go from there. I tried a while ago (although very briefly) to get fullscreen resolution working, but I couldn't figure it out with both OpenSuSE and Slackware guest OSes. I may give it a try over the weekend if nothing has materialized by then (but I won't have time until then). It may be possible to use a custom Modeline in VirtualBox, but I haven't tried it and I have no idea if the VESA drivers will even support such a thing (plus I don't think the Modeline should be necessary if everything is working correctly). Just throwing ideas (good or bad) out there.

Last edited by T3slider; 07-10-2008 at 08:44 PM.
 
Old 07-10-2008, 10:34 PM   #3
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Original Poster
Rep: Reputation: 40
Thanks, T3.
In a nutshell, that thread says load the additions and edit xorg.conf. I've done this. The xorg.0.log shows the vbox video driver is loading. I'll try the docs again but I've been there a couple times already.
 
Old 07-17-2008, 08:01 PM   #4
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Original Poster
Rep: Reputation: 40
Bumping this should anyone have a tip.
 
Old 07-18-2008, 08:31 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,233

Rep: Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575
I may get some time this weekend to work on this (though I won't promise anything). I haven't had time to do much in Slackware as of late, but I'll play around with xorg.conf, the guest additions, Modelines, etc. and see what I can rig up. I'm most certainly not promising success here though.
 
Old 07-19-2008, 03:15 AM   #6
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
I have virtual Slackware machine running under VirtualBox. I installed the guest additions and even if I don't specify 1280x800 i.e. my host native resolution in the (virtual) xorg.conf (the maximal I wrote is 1024x768), I can get that resolution when I use the fullscreen mode. The virtual X adjusts itself to the VBox window size in a way. The driver I specified is "vboxvideo", which comes with guest additions. I gave 32 MB memory for graphics, but you may need more for higher resolutions. Also, I think this dynamic adjusting of the resolution is taken care of by the VBoxClient program running in the bacground of the guest. It's in the autostarted applications list of XFCE, for example (it should be added there automatically).

Last edited by Ilgar; 07-19-2008 at 03:17 AM.
 
Old 07-19-2008, 03:18 PM   #7
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,233

Rep: Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575
OK, it works. Make sure you are using the vboxvideo driver (that was my problem) in /etc/X11/xorg.conf. I had to manually add my resolution in xorg.conf (just switching to Fullscreen mode would just leave big black bars around the sides), but it works perfectly when adding my resolution to xorg.conf (no Modeline was needed either). If you want cutting and pasting to work between the guest OS and host OS you have to run `vboxadd-xclient` (you can add it to your .xinitrc or add it to a startup script in your WM/DE). That solves basically everything I think.

Thanks Ilgar!
 
Old 07-19-2008, 05:19 PM   #8
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
You're welcome, I'm glad to hear that it works now.
 
Old 07-19-2008, 10:33 PM   #9
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Original Poster
Rep: Reputation: 40
T3, I couldn't find the vboxadd-xclient file on my system. I looked at the additions file contents and found a reference to 98vboxadd-xclient. It's a script that does nothing but call /usr/bin/VBoxClient but after the vboxadditions install, it is nowhere to be found on my pc. Loading /usr/bin/VBoxClient in /xinitrc allowed me to resize my screen.

I did some more poking around. There is a file called
/etc/xdg/autostart/vboxclient.desktop the content are this:
[Desktop Entry]
Type=Application
Encoding=UTF-8
Version=1.0
Name=vboxclient
Name[C]=vboxclient
Comment[C]=VirtualBox Client
Comment=VirtualBox Client
Exec=/usr/bin/VBoxClient
X-GNOME-Autostart-enabled=true

I can'y find much information about xdg, it it appears this should start the client s/w
 
Old 07-20-2008, 03:02 AM   #10
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
As I mentioned above it's VBoxClient that takes care of screen resizing (and maybe more, like shared clipboard). That xdg directory should be related to freedesktop.org's desktop standards. Not all window managers fully support it yet. The XFCE desktop on my virtual system recognizes freedesktop's autostart directory so it automatically starts VBoxClient. For other window managers you may have to start it manually.
 
Old 07-20-2008, 10:41 AM   #11
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,233

Rep: Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575Reputation: 575
I had heard mention of 98vboxadd-xclient and VBoxClient, but neither are present on my guest OS with Guest Additions installed. However, I am a few VirtualBox versions behind, so that may have something to do with it. Since everything works as it should for me, I'm happy -- but most people should probably follow your advice instead of mine.
 
  


Reply

Tags
resolution, slackware, virtualbox


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to connect to a VirtualBox Windows guest through RDP ErEn Linux - Networking 1 04-03-2010 03:45 PM
Configure USB in Windows XP guest at virtualbox nos1833 Debian 1 03-07-2008 11:51 PM
Ubuntu Host Virtualbox guest Networking weirdness ddales Linux - Networking 0 01-20-2008 02:24 PM
Zenwalk 4.8 does not work as a Linux guest in Virtualbox 1.5 paulsiu Zenwalk 7 11-21-2007 12:14 PM
Compiling Virtualbox Guest Additions paulsiu DamnSmallLinux 5 11-19-2007 10:35 PM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration